Another look at HPET High Precision Event Timer

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Bukkake, Sep 18, 2012.

  1. BlackNova92

    BlackNova92 Member Guru

    Messages:
    104
    Likes Received:
    7
    GPU:
    16gb
    yeah i only have disabledynamictick active and useplatformtick for the timers and got rid of the rest.
     
  2. kelzthetraxer

    kelzthetraxer Member

    Messages:
    47
    Likes Received:
    7
    GPU:
    Aorus RX580 8GB
    Okay, I think I will still post this for those who are running similar or even identical system to mine. Specs:

    i7 4790k stock
    Asrock Z97M Pro4 motherboard
    16GB of RAM on 2400 mhz
    Windows 10 1803

    Best setting that I've found that got a balance between smoothness and input lag is using command useplatformtick yes and HPET enabled in BIOS. @Smough recommends to leave it on, so I decided to leave it on (although, with it off it wasn't bad at all, but I'm free to follow any advice here). Without useplatformtick command, things feel less smooth, especially in Chrome when scrolling. I have a 75hz monitor and without that command scrolling feels like 60hz, but with it ON, it feels just right, very snappy. ALTHOUGH, it does add input lag quite noticeably, kinda like VSync which gives smoothness but adds input lag, so keep that in mind. Another thing that I use is a small service/program that you can apply with CMD that can help your timer run at 0.5 (0.499 in my case) right from the start and you don't need any program open to force it. Believe it or not, but lower timer DID help with smoothness and input lag as well. I DID NOT expect it and it was a complete surprise. For those who want the link for that service which helps with the timer, you can message me then. I've got it from one of the youtube videos. Now, Disabledynamictick enabled adds HUGE stutters to my system UNLESS I use useplatformclock off, so I just don't use these commands. And that's all.

    TL;dr: Using one of the bcdedit commands does makes my system smoother indeed, so it never hurts trying these. I know some people will still check this thread so that's why I decided to write all this.
     
    Last edited: Nov 21, 2020
  3. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,300
    Likes Received:
    7,404
    GPU:
    GF RTX 2070 Super
    kelzthetraxer likes this.
  4. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,300
    Likes Received:
    7,404
    GPU:
    GF RTX 2070 Super
    kelzthetraxer likes this.

  5. Hook

    Hook Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    GTX 1060 6GB
    hello, I have got hpet disabled in bios but it still remains in device manager, is this expected behaviour? I tried uninstalling it and it reappeared again. I have seen a picture here previously of users computer without hpet on IRQ(0) only system timer, how did he achieved that?
     
  6. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,300
    Likes Received:
    7,404
    GPU:
    GF RTX 2070 Super
    I have no idea. I have never tried to disable it in Device Manager.
     
  7. Terepin

    Terepin Master Guru

    Messages:
    759
    Likes Received:
    50
    GPU:
    MSI 2070S GAMING X
    I have a small issue. After I delete useplatformclock, it tends to come come back for some reason. Anyone have idea why is that?
     
  8. Cyberdyne

    Cyberdyne Ancient Guru

    Messages:
    3,581
    Likes Received:
    297
    GPU:
    2080 Ti FTW3 Ultra
    Deleting the value should make windows repopulate the setting with the default setting. Not totally get rid of it.
     
  9. Terepin

    Terepin Master Guru

    Messages:
    759
    Likes Received:
    50
    GPU:
    MSI 2070S GAMING X
    So how can I disable it permanently?
     
  10. Astyanax

    Astyanax Ancient Guru

    Messages:
    9,140
    Likes Received:
    3,131
    GPU:
    GTX 1080ti
    no, its totally gotten rid of. the bootloader's defaults are hard coded.
     

  11. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,300
    Likes Received:
    7,404
    GPU:
    GF RTX 2070 Super
    Just delete with bcdedit.exe until it disappears...
     

Share This Page