Another look at HPET High Precision Event Timer

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Bukkake, Sep 18, 2012.

  1. Straszy

    Straszy New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    gtx 1060 6gb
    Face-palm...

    Read again what i wrote and you are wrong.

    What i meant in my post is (look screenshot) qpc value 3.58 mhz instead of 10 mhz on win10 1909.

    And "useplatformclock no" is not disabling hpet, this command depends on hpet in bios...

    Hpet ON in bios with useplatformclock yes will force to use hpet only, useplatformclock no will force to use tsc only
    Hpet off in bios with useplatformclock yes will give you way different timer, useplaformclock no will force to use tsc only.

    I'm not even gonna mention about disabledynamictick that's not even related to hpet.
     
    Last edited: Jan 6, 2020
  2. Smough

    Smough Master Guru

    Messages:
    639
    Likes Received:
    112
    GPU:
    GTX 1060 3GB
    You seem to be a bit confused. Watch this video:

    You need to keep HPET active in BIOS all of the time, then disable it on Windows. This gives the best O.S timers with less latency, if HPET is not enabled in BIOS, everything will sync worse. He explains it on that video.
     
  3. mbk1969

    mbk1969 Ancient Guru

    Messages:
    11,125
    Likes Received:
    8,621
    GPU:
    GF RTX 2070 Super
    He does not explain anything. He just shows some tools' windows with numbers and dots.
     
    Last edited: Jan 7, 2020
    -Tj- likes this.
  4. X7007

    X7007 Ancient Guru

    Messages:
    1,658
    Likes Received:
    38
    GPU:
    Sapphire 6900XT
    How did you manage to get the proper time without the Meltdown and Spectre protections which is usually 10 mhz?


    Yea mate, I have AMD I just wanted to say both so incase someone didn't know SMT. and sometimes SMT/HT can cause an issue in games or even in windows. but not talking about that. everything works fine but I just want to understand why it happened. it must happen because I change settings with the cpu affinity priority and then disabled SMT. it must change something and I just want to know how to reset it. because for some weird reason even on Windows to Go it is exactly the same, so it must be something in bios for some weird reason, could be IMMOU or something else I disabled.

    For the moment last tests I've discovered for mouse movement is don't change the Nvidia control panel settings. keep it on Quality and not High Quality. and set your Color settings to Use Nvidia color settings. and set prefer maximum performance.

    I will test PCI-E Speed when it's idle 1.1 in windows, compare to forced 3.0 all the time. those power-saving screw everything! we had perfect mouse movement because we didn't have all these power savings.
     

  5. Straszy

    Straszy New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    gtx 1060 6gb
    Hpet off in bios with useplatformclock yes will give you way different timer.

    It's called Local APIC timer. Better responsive, lower performance.
     
  6. Astyanax

    Astyanax Ancient Guru

    Messages:
    11,308
    Likes Received:
    4,244
    GPU:
    GTX 1080ti
    "Hpet off in bios with useplatformclock yes will give you way different timer, useplaformclock no will force to use tsc only."

    lol, wrong.
     
  7. mbk1969

    mbk1969 Ancient Guru

    Messages:
    11,125
    Likes Received:
    8,621
    GPU:
    GF RTX 2070 Super
    Which part is wrong?

    What is the point in replying so short and dry? Tell us your wisdom.
     
  8. Astyanax

    Astyanax Ancient Guru

    Messages:
    11,308
    Likes Received:
    4,244
    GPU:
    GTX 1080ti
    his claim that "no" does something.

    all documentation shows it is the same thing as not having the bcdedit entry present at all.
     
  9. mbk1969

    mbk1969 Ancient Guru

    Messages:
    11,125
    Likes Received:
    8,621
    GPU:
    GF RTX 2070 Super
    It does. When "no" entry is not present OS decides. When "no" entry is present Windows can`t decide to use any platform timers.
    On old rigs with CPU with faulty implementation of TSC OS will chose platform timer. If you specified to not use platform timers OS will use faulty TSC.
    Of course on modern rigs two cases - without and with "no" entry - will give the same result.
     
  10. evgenim

    evgenim Master Guru

    Messages:
    237
    Likes Received:
    17
    GPU:
    RTX 2060 OC

  11. X7007

    X7007 Ancient Guru

    Messages:
    1,658
    Likes Received:
    38
    GPU:
    Sapphire 6900XT
    Last edited: Jan 17, 2020
  12. Ripan_

    Ripan_ Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    980ti
    Im stuck at 3.41 mhz and want to use TSC + hpet , i have HPET enabled in bios and tried theuseplatformclock no. Why am i still at 3.41?
     
  13. mbk1969

    mbk1969 Ancient Guru

    Messages:
    11,125
    Likes Received:
    8,621
    GPU:
    GF RTX 2070 Super
    You broke synthetic timer Widows was using before your manipulations. :cool:
     
  14. Ripan_

    Ripan_ Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    980ti
    so i need to reinstall?
     
  15. Astyanax

    Astyanax Ancient Guru

    Messages:
    11,308
    Likes Received:
    4,244
    GPU:
    GTX 1080ti
    just default your bcdedit config
     

  16. mbk1969

    mbk1969 Ancient Guru

    Messages:
    11,125
    Likes Received:
    8,621
    GPU:
    GF RTX 2070 Super
    Execute in elevated command prompt

    bcdedit /enum

    and see whether you forgot about some settings like "tscsyncpolicy".
     
  17. Ripan_

    Ripan_ Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    980ti
    I use Windows 7, btw. But how do i defualt by bdedit config?

    I dont think i can use any command for tscsyncpolicy. They dont work :(
     
  18. mbk1969

    mbk1969 Ancient Guru

    Messages:
    11,125
    Likes Received:
    8,621
    GPU:
    GF RTX 2070 Super
    Are you kidding us? Only in Win10 QueryPerformanceFrequency returns 10MHz when not forced to use platform timers. In all older versions it always returns 3,(smth) MHz.
     
  19. Ripan_

    Ripan_ Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    980ti

    No im not. Im not that good on what does what. I just wanna try it for performance boost in csgo. So i cant any other than 3.4 and 14 in Windows 7?
     
  20. Ripan_

    Ripan_ Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    980ti
    But i read somewhere that TSC + Hpet was 3.9
     

Share This Page