1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AMD Radeon Software Crimson 16.3

Discussion in 'Videocards - AMD Radeon Drivers Section' started by d2kx, Mar 9, 2016.

  1. jokerinho

    jokerinho Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Powercolor R9 280x OC
    Does anyone else have the problem with all the crimson drivers that csrss.exe is doing constant GPU usage? Doing nothing it's at 1-3% for me, but i can even have nothing open and just scroll up and down faster in the process explorer and it will go up to 14%.

    What's also strange is that if I run a game that has around 90% GPU usage, the csrss.exe still shows up jumping around from 30-95% all over.

    I wonder what's causing this, can anyone see if they have the same problem? It really sucks to have such a high GPU usage for nothing.
     
  2. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,046
    Likes Received:
    35
    GPU:
    RX 580 8GB
    Seems they've hardcoded it to be off/on for certain hardware but didn't remove the option for it. I guess the code that says "this feature isn't for GCN 1.x, remove menu"? No idea. I have managed to get it "Off" but it's automatically made "On" after restarting Radeon Settings.
     
  3. TheDukeSD

    TheDukeSD Member Guru

    Messages:
    131
    Likes Received:
    6
    GPU:
    MSI GT 1030 2GH OC
    that setting vanish for me after i click it and doesn't come back after restart. only way to get it back is to reinstall radeon settings and it's again set to on (other settings are kept). so it basicaly does nothing on my gpu, probably it does only for some particular gpus.
    In case someone can turn it on and off without problems (like it remember it was set to off after restart) please tell what reg key is changed (if any).
     
  4. BAZOKA1942

    BAZOKA1942 Member Guru

    Messages:
    170
    Likes Received:
    3
    GPU:
    sapphire r9 390
    vsr wont enable and apply !! even with radeonmod ? any help return to disable after screen blanking
     

  5. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    6,972
    Likes Received:
    120
    GPU:
    Sapphire 7970 Quadrobake
    I guess that's it. I haven't noticed any changes in actual behavior, and it keeps appearing being "on". The card maintains max clocks even in Pillars of Eternity, so no real problems.
     
  6. THEAST

    THEAST Master Guru

    Messages:
    211
    Likes Received:
    18
    GPU:
    HD7950 + HD7970 CF
    What option exactly are you guys referring to? If you are referring to the option that enables you to force CrossFire profile from one game in another, it is still there under AMD Crossfire Mode>Use AMD pre-defined profile for me. I *updated* from previous v16.2, though. Never did this *wipe everything clean with DDU* stuff people are doing these days for every new driver installation.

    I also have the Power Efficiency toggle even though the changelog says it is for Radeon 300 and Fury. Never had problem with fluctuating clocks, though; I did notice that happening in one game but it didn't seem to cause any performance issues. I don't think Radeon 200/HD 7000 were affected to begin with.
     
  7. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    The option to globally enable cfx for all software who has not a predefined profile.

    This option was present in old CCC in the same window where we enable/disable cfx.

    It dissapeared after 15.12, starting 16.1 it wasn't there anymore.
     
  8. The Mac

    The Mac Ancient Guru

    Messages:
    4,409
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    290 here, no power optimizations toggle, but ive never had a downclocking issue anyway.

    are you guys who see it on a 290/7970 using radeon mod?

    according to the release notes, its only for 390/fury
     
  9. THEAST

    THEAST Master Guru

    Messages:
    211
    Likes Received:
    18
    GPU:
    HD7950 + HD7970 CF
    I am pretty sure they are not referring to that option because that was, as you said, removed some time ago and not in this driver. Based on RexOmnipotentus's reply, these are two separate issues.


    Are you checking your game profiles or the Global profile? Because it is only available in the latter. I have it on 7950 + 7970 CF and I am not using RadeonMod.
     
  10. The Mac

    The Mac Ancient Guru

    Messages:
    4,409
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    both.

    release notes clearly state "select 390 and fury"
     

  11. THEAST

    THEAST Master Guru

    Messages:
    211
    Likes Received:
    18
    GPU:
    HD7950 + HD7970 CF
    LOL, I wanted to make a screenshot but it seems the option has disappeared from my profile settings! I reckon it should be there but as other people also reported, it disappears for no reason.
     
  12. niczerus

    niczerus Master Guru

    Messages:
    290
    Likes Received:
    3
    GPU:
    MSI GamingX 580 4GB
    same problem here .
     
  13. Mercennarius

    Mercennarius Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    Sapphire Tri-X R9 390X
    Can someone with Ashes of the Singularity run the benchmark with these new drivers? I think they are causing it to stutter/be choppy for me.
     
  14. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    I forgot to comment on that. :)

    OFC It's your personal decision to only use the AMD drivers uninstaller or to also use DDU to delete all leftovers (driver files and registry entries).

    In both cases GPU drivers must work properly (an equally) as if they were installed in a fresh OS.

    GPU drivers must not (and can't) rely in leftovers.

    Just installed OS obviously has no leftovers.
     
  15. WarDocsRevenge

    WarDocsRevenge Master Guru

    Messages:
    294
    Likes Received:
    0
    GPU:
    Fury-x Crossfire
    amazing driver and great vulkan performance only issue is opengl 4.5 is bugging opengl games and i get a black screen
     

  16. Osjur

    Osjur Member

    Messages:
    34
    Likes Received:
    0
    GPU:
    Radeon Fury X
    Blah, and so I lost all my game profiles when upgrading to these. C'mon AMD, do you even test these out or do you just let us end customers be the pre-alpha testers?
     
  17. OnnA

    OnnA Ancient Guru

    Messages:
    8,302
    Likes Received:
    1,513
    GPU:
    Vega 64 XTX LiQuiD
    Upgraded to 16.3 + Reistalled CCC 15.11.1
    Everything is in Order, Games working well (as far BF4 Mantle and SW BF DX11.3)
    Games Profiles remain intact ;-)
    Also i have Turn OFF Power saving Feature in my R280X in Crimson Options (i leave them on default)
    Also when i Play HEVC x265 Movie i have GPU acceleration :) i have it also in 16.2.1

    OK Driver IMO
     
  18. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    Is the frankenbuild driver install process necessary to make 16.3 work properly?Did you tried a clean driver install?

    Can you check if the power toggle is still there (doesn't vanished)?

    It's supposed to be only for series 300 (and Fury).

    Thanks. :)
     
  19. Octopuss

    Octopuss Master Guru

    Messages:
    876
    Likes Received:
    53
    GPU:
    -
    I'd like to believe it was added after I brought it up to the AMD guy's attention doing Q&A on reddit recently :D
     
  20. nav-jack

    nav-jack Master Guru

    Messages:
    254
    Likes Received:
    0
    GPU:
    980 ti 1520/2000
    i guess after i'm done exporting some videos i'll install this new driver and tell you guys what is up. only a handful of actual 390/390x owners posted about any of the features working or not and the ones that did i possibly might not trust their technical prowess. i'll go over this with a fine tooth comb.
     

Share This Page