AMD Radeon Crimson 17.7.2 WHQL Download & Discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Jul 26, 2017.

  1. Passus

    Passus Maha Guru

    Messages:
    1,106
    Likes Received:
    203
    GPU:
    GTX 1060 3GB
    Give it a rest guys, play games or go outside, your call
     
  2. MaCk0y

    MaCk0y Master Guru

    Messages:
    537
    Likes Received:
    161
    GPU:
    GB RX 5700 XT OC
    Does anyone get worse performance in Doom multiplayer using Vulkan? I have lower minimum FPS. Before it didn't use to get lower than 90FPS but now it even goes down to high 50s sometimes. Could it be the new Vulkan API/driver version?
     
  3. Keff91

    Keff91 New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    Sapphire Nitro R9 390
    feel like this 17.7.2 is crappy.

    i get bad performance with overwatch playing with this new driver, after switch back to old 17.7.1, no more issue.
     
  4. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,144
    Likes Received:
    146
    GPU:
    RX VEGA 56
    I play Overwatch DAILY.
    And performance for me is the same if not a little bit better.

    Try DDU and reinstall.
     

  5. Only Intruder

    Only Intruder Maha Guru

    Messages:
    1,131
    Likes Received:
    150
    GPU:
    Sapphire Fury Nitro
    No it isn't the UVD bug but it is similar.

    I've found clock rate to be stuck at 300MHz when attempting to use 3rd party clocking tools, not getting clock/power states being stuck by running video decoding on hardware though.

    Remember, the UVD bug is when the GPU gets stuck in the video decoding powerstate through normal use.

    This bug is that when attempting to modify the clock state through 3rd party tools, the card gets stuck in it's idle state (I've just confirmed it myself). MSI Afterburner is letting me set different clock speeds but it's then getting stuck in idle clock state, it's probably wattman profiles being screwy again, not the first time wattman has been a pain in the arse. Sapphire Trixx isn't even registering the card at the moment for me. Infact, looking at wattman, it is completely broken for me right now, I can't do anything with it, this is clearly an incompatibility with Wattman and MSI Afterburner.
    [​IMG]
    Aside from Temperature, fan speed and power limit, I can't change gpu frequency or voltage on any of the states.

    Again, similar bug but not quite the same because we're actively attempting to change the clock speeds through other tools. (I can't change the power limit at all in MSI Afterburner now).

    Don't misunderstand me though you're not wrong, the bug is happening, it's reproducible, it's just not the same bug since this is occurring via different methods but it's not specifically the UVD bug.

    I guess we should say this is a powerstate bug but it certainly looks like a wattman issue.
     
    Last edited: Jul 31, 2017
  6. thatguy91

    thatguy91 Ancient Guru

    Messages:
    6,648
    Likes Received:
    97
    GPU:
    XFX RX 480 RS 4 GB
    I have two displays, one via displayport and the other HDMI. Main monitor is freesync, the other is a TV. With Enhanced Sync enabled, if I use MPC-BE and madVR on the TV it causes a video_tdr_error GSOD. Plays fine on the main monitor. It only happens with Enhanced Sync, any other mode works fine.
     
  7. Keff91

    Keff91 New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    Sapphire Nitro R9 390
    Is it, do you also modify the Radeon Wattman setting or use the default one?
    I modify by raising the fan speed (modify the overwatch profile) to reduce a bit of the hot temperature.

    I do this also to 17.7.1, no issue through, but when 17.7.2 wow very laggy suddenly.
    Other than fan speed, all use normal setting.
     
  8. Fox2232

    Fox2232 Ancient Guru

    Messages:
    9,755
    Likes Received:
    2,203
    GPU:
    5700XT+AW@240Hz
    No, I do not think it got enabled. Tested on Torchlight 2 where I got around 150fps on 144Hz screen.

    As for HW ID. It is simple inf change and disabling windows driver signature verification.
    Let's say you have Hawaii GPU and want to install stuff from Polaris 10:
    Code:
    "%AMD67B9.2%" = [B]ati2mtag_Hawaii[/B], PCI\VEN_1002&DEV_67B9
    "%AMD67DF.1%" = ati2mtag_Polaris10, PCI\VEN_1002&DEV_67DF&SUBSYS_0B371002&REV_C4
    Change to:
    Code:
    "%AMD67B9.2%" = [B]ati2mtag_Polaris10[/B], PCI\VEN_1002&DEV_67B9
    "%AMD67DF.1%" = ati2mtag_Polaris10, PCI\VEN_1002&DEV_67DF&SUBSYS_0B371002&REV_C4
    But availability of this feature and wattman + others is not based on some registry values.
    I did learn it when I changed vBIOS HW IDs from Fiji to Polaris10. With that mod, Driver installs for Polaris 10 without any inf modification or signature verification tampering.
    Card presents itself as Polaris 10 based card everywhere except RadeonSettings itself. So RadeonSettings communicates with GPU to obtain "feature set".
     
  9. Dennisbest

    Dennisbest Member

    Messages:
    26
    Likes Received:
    0
    GPU:
    Sapphire Radeon 7950
    I will agree that the thing Fury users experience is not UVD bug. This is just a stuck clock no matter what and I also experienced it when I had afterburner installed. After I removed MSI AB the clocks were fixed...UVD bug is completely different , the card enters UVD state which means that the clocks can either be the normal UVD clocks(500mhz for an 7950) and the stock 3d clocks of the card. This means that the card indeed runs in 3d clocks when needed , but not overclocked .
     
  10. Romulus_ut3

    Romulus_ut3 Master Guru

    Messages:
    670
    Likes Received:
    138
    GPU:
    AMD RX 570 4GB
    The PC equipped with a Fury card at work was stuck at 300/500 without changing any settings with 3rd party tools whatsoever after I clean installed 17.7.2 for the first time. I don't have MSI AB or any other software running at startup and I won't overclock a GPU that belongs to my employers, the only thing MSI AB is installed for is the custom fan curve. I noticed that the viewport in 3DS Max was taking a long time to make objects visible and that's when I realized that the clock is stuck.

    The argument started when I wrote in a post that the UVD feature (that issue has been present in the drivers for so long I no longer think it suffices to call it a bug anymore but a feature, referencing to the P state issue) has started to surface itself in latter cards now. That's when Krteq decided to question the issue's existence, then once the issue's existence was shown to him, decided to get technical and label it as not a power state switching issue which I labeled as the UVD bug.

    The term "UVD bug" was used as a reference to the power state switching/stuck issue. It falls in the same category, be it triggered under different circumstances with different outcomes. But the essence is the same.

    And read above. I have faced it prior to running MSI AB. I realized the issue's existence and confirmed it once I went into Wattman before even running AB. The same issue was present in an earlier driver 6 or 7 months ago.

    All in all, a user shouldn't have to go through three driver installations to make something as basic as proper power state switching to work which you take for granted.
     
    Last edited: Jul 31, 2017

  11. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,144
    Likes Received:
    146
    GPU:
    RX VEGA 56
    I do.
    I OC and change the Power Limit to 50%

    All I can think is that maybe you have Power Efficiency turned ON in the Global Settings profile.

    If not, I don't know what could it be your issue.
     
  12. Jackalito

    Jackalito Master Guru

    Messages:
    541
    Likes Received:
    70
    GPU:
    Radeon RX 5700 XT
    Guys, any word on when is AMD going to release the new SDK so that 3rd party applications can be updated accordingly?

    I miss Afterburner already, but I don't want to rollback to a previous driver, because this one lessens some rough edges related to WDDM 2.0 on Windows 10 Creators Update.

    Thanks :)
     
  13. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,004
    Likes Received:
    137
    GPU:
    Sapphire 7970 Quadrobake
    They can't even write a proper driver for their new flagship card, I believe we'll have to wait for that.
     
  14. Benik3

    Benik3 Master Guru

    Messages:
    489
    Likes Received:
    5
    GPU:
    Asus Radeon RX580 4GB
    Yes I have FreeSync monitor LG 27MP68HM-P and enabled it...
     
  15. Only Intruder

    Only Intruder Maha Guru

    Messages:
    1,131
    Likes Received:
    150
    GPU:
    Sapphire Fury Nitro
    Ever since the introduction of Wattman, every other driver has presented a problem of some kind, some drivers are fine and then some, Wattman goes completely tits up and then there is the the support with 3rd party tools that keeps getting broken every time.
     

  16. olymind1

    olymind1 Member

    Messages:
    45
    Likes Received:
    2
    GPU:
    Asus R7 265 2 GB
    Same here in MEA (dx11).
     
  17. garyb

    garyb Active Member

    Messages:
    71
    Likes Received:
    14
    GPU:
    MSI GTX 1080TI 11GB
    Strange either way still a driver issue as older drivers work.
     
  18. Benik3

    Benik3 Master Guru

    Messages:
    489
    Likes Received:
    5
    GPU:
    Asus Radeon RX580 4GB
    But this is how the enhanced sync should work...
    It will never be smooth like vSync, but it will have better input lag (because vSync add high input lag when enabled)
     
  19. RzrTrek

    RzrTrek Ancient Guru

    Messages:
    2,347
    Likes Received:
    628
    GPU:
    RX 580 ❤ MESA 19.2
    17.7.x has been giving me a lot of trouble lately, where it takes about 30s to wake up my monitor from standby.
     
  20. holler

    holler Master Guru

    Messages:
    220
    Likes Received:
    39
    GPU:
    2x AMD Radeon VII
    went back to 17.4.4 WHQL, this latest release is half baked for older GCN cards like my 290xs it appears. getting slow to respond monitor and black screens when running Overwatch in crossfire mode with my 100hz Samsung freesync 21:9
     
    Last edited: Aug 1, 2017

Share This Page