AMD Radeon Adrenalin Edition 21.3.2 driver download & discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Hilbert Hagedoorn, Mar 29, 2021.

  1. X7007

    X7007 Ancient Guru

    Messages:
    1,577
    Likes Received:
    29
    GPU:
    Sapphire 6900XT
    Did you try this driver?
    https://forums.guru3d.com/threads/amd-radeon-software-uwp-v27-20-21001-7005.437511/#post-5903513
     
  2. BossAB117

    BossAB117 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ROG SRTIX 5700xt 8g
  3. passenger

    passenger Master Guru

    Messages:
    427
    Likes Received:
    71
    GPU:
    Sapphire RX580 8GB
    Wrong again. FreeSync+10bpp runs smoothly on RX580 in Win21H1 19043.867.
     
  4. Chastity

    Chastity Ancient Guru

    Messages:
    2,710
    Likes Received:
    902
    GPU:
    Nitro 5700 XT
    Is that with just 10bit monitor enabled, or actually using the 10bit Desktop Pixel Format. (not the same thing)
     

  5. OnnA

    OnnA Ancient Guru

    Messages:
    12,830
    Likes Received:
    3,205
    GPU:
    Vega XTX LiQuiD
    For me it's stutter fest, tried some time ago out of curiosity ;)
    No difference at all, Movies 10Bit & HDR and games tested.
    It's for Pro app. usage like Photoshp etc. (CMYK vs RGB).
     
    itpro likes this.
  6. chispy

    chispy Ancient Guru

    Messages:
    8,985
    Likes Received:
    1,219
    GPU:
    RX 6900xt / RTX3090
    I'm having an issue with my htpc APU 3400G Vega 11 using this driver that i have never encounter before with older drivers. I just updated to this driver yesterday and i'm getting a lot of green screens while using google chrome browser and hardware accelerated graphics. It will show after using chrome for a long time without closing it or with many tabs open , same as playing videos from youtube , i get full screen turn green :/ , i need to re-start the pc to get back vga signal. Using Vega 11 of the 3400G on a Asrock deskmini A300W with 3600Mhz ram 2x8gb / OS is W10 latest and updated / Using Samsung KS8000 4K HDR TV via hdmi. Like i stated , this never happened before with older drivers and this htpc is On 24/7.

    Anyone else having this issue ? I will report this to amd team to see if they fix it on the next driver release :/ , meanwhile i had to roll back to older driver 20.12.1 fix this problem and i do not get green screen.
     
  7. passenger

    passenger Master Guru

    Messages:
    427
    Likes Received:
    71
    GPU:
    Sapphire RX580 8GB
    Of course, 10 bit per channel (bpc)related to the number of bits per color channel, 10 bit per pixel format (bpp) number of bits per each pixel, which I use and looks and works beautiful in Win21H1 19043.867.
     
  8. The Stilt

    The Stilt Member

    Messages:
    19
    Likes Received:
    4
    What display are you using?

    This shouldn't have anything to do with the display thou, since currently there are no proven combinations where "10-bit pixel format" and FreeSync would work properly, simultaneously.
    I know several people with the same issue, and most of them are using a different display make and model. I personally use a ProDesigner PE320QK display and FreeSync combined with the 10-bit pixel format has never worked even remotely on AMD.
    They both can be enabled simultaneously however, the tearing is the same as with FreeSync disabled and additional, heavy stuttering is introduced on top of that.

    Without 10-bit pixel format enabled, there is a significant amount of banding visible (e.g. the NEC demo).

    On nVidia cards 10-bit output and FreeSync work perfectly fine and there is no banding either.
    The really sad thing is that I've been unable to use my 6800 XT for over four months, since I need 10-bit colors for the video and definitely want FreeSync for gaming.

    I also tried this on old Polaris card (RX 460 or 560) few months back and it didn't work any better on that either. So it isn't an issue isolated on the driver path of just the newer cards.
     
    OnnA likes this.
  9. OnnA

    OnnA Ancient Guru

    Messages:
    12,830
    Likes Received:
    3,205
    GPU:
    Vega XTX LiQuiD
    ^^ Yup, something is broken TBH.
    IMhO it should work NP...
     
  10. passenger

    passenger Master Guru

    Messages:
    427
    Likes Received:
    71
    GPU:
    Sapphire RX580 8GB
    Maybe you are on some older Windows version, didn't work on 20H1, FreeSync with 10bpp works very good on 21H1 with uwp 27.20.21001.7005 drivers. I have AOC q3279vwfd8 a 8+2 ips freesync1 display.

    Please provide link of NEC demo.
     

  11. The Stilt

    The Stilt Member

    Messages:
    19
    Likes Received:
    4
    Here is the NEC demo: https://www.sharpnecdisplays.us/documents/software/nec_10_bit_video_windows_demo.zip

    Obviously this only tests the color gradients, not FreeSync. But part of the problem, regardless.
     
    passenger likes this.
  12. The Stilt

    The Stilt Member

    Messages:
    19
    Likes Received:
    4
    How are you enabling the 10-bit pixel format on this driver, when there is no Radeon Settings included which has the control for it? Registry hack?

    E: There was two different drivers (UWP and DCH) with the same version, got it installed.
     
    Last edited: Apr 13, 2021
  13. The Stilt

    The Stilt Member

    Messages:
    19
    Likes Received:
    4
    Pleased to report that finally, it appears that driver version 27.20.21001.7005 does in fact fix the issue with "10-bit pixel format" and FreeSync.

    Windows 19042.928 (20H2), 27.20.21001.7005 UWP, AMD Radeon 6800XT reference and Acer ProDesigner PE320QK 4K FreeSync monitor (connected with DP).

    Thank you, now I can finally get rid of the 2060S I've been forced to use.
     
    passenger likes this.
  14. boombastik

    boombastik Master Guru

    Messages:
    335
    Likes Received:
    47
    GPU:
    rx580 Pulse 8Gb
    RX580 with below drivers i take tdr errors with Mozilla back to 21.2.3 and all ok. (all drivers with ddu unistallation and i tried another psu)
    21.3.2 , 21.3.1 ,27.20.21001.7005
     
  15. passenger

    passenger Master Guru

    Messages:
    427
    Likes Received:
    71
    GPU:
    Sapphire RX580 8GB
    Glad it helped, thanks for demo, enjoy the colors.
     
    The Stilt likes this.

  16. ms178

    ms178 Member Guru

    Messages:
    122
    Likes Received:
    43
    GPU:
    Vega 56
    Strange, but I can at least work around this issue with using pointer trails in the mouse settings. If I do that, I don't get the lag spikes in the UFO test anymore (an easy way to provoke the spikes is to set the test in full screen mode and move the mouse up until the box appears to exit full screen mode). I don't know why though and I can't stand the pointer trails.
     
  17. Espionage724

    Espionage724 Member Guru

    Messages:
    113
    Likes Received:
    45
    GPU:
    Radeon RX 580 8G
    I've used 21.3.1, 27.20.21001.7005, and I believe every other driver before 21.3.1, and have never had a TDR with Firefox or Thunderbird (only Mozilla stuff I use) and a RX 580.
     
    itpro and DanielRX like this.
  18. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,334
    Likes Received:
    3,718
    GPU:
    GTX 1080ti
  19. Dekaohtoura

    Dekaohtoura Master Guru

    Messages:
    336
    Likes Received:
    44
    GPU:
    Sapphire V56 Pulse
    Holy Sh.t Batman! It's an AIDA vs AMD matter?

    I've discarded countless mem profiles as unstable (trying to make the most out of my X370Taichi+5600X), because I was getting random restarts when running the mem bench.

    Nice one, thanks!
     
    Espionage724 likes this.
  20. boombastik

    boombastik Master Guru

    Messages:
    335
    Likes Received:
    47
    GPU:
    rx580 Pulse 8Gb
    I found also someone else in a Greek forum with the same issue like me.
    Also i found some people on reddit.
    1.jpg


    When it start you need to clean install the driver to fix this.
     
    Last edited: Apr 14, 2021

Share This Page