AMD Radeon Adrenalin Edition 19.5.2 driver download & discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by mtrai, May 23, 2019.

  1. OnnA

    OnnA Ancient Guru

    Messages:
    9,701
    Likes Received:
    2,026
    GPU:
    Vega 64 XTX LiQuiD
    26MHz GPU & 167MHz HBM2 in desktop mode :p
    All fine, im on 19.5.1 now, waiting for WHQL (should be around the 'corner' now)
     
    SpajdrEX and LocoDiceGR like this.
  2. Mesfigas

    Mesfigas Member

    Messages:
    37
    Likes Received:
    8
    GPU:
    RX 580 4Gb
  3. Undying

    Undying Ancient Guru

    Messages:
    11,860
    Likes Received:
    1,535
    GPU:
    Aorus RX580 XTR 8GB
    If you look at few posts back you'll see your not the only one.
     
  4. SpajdrEX

    SpajdrEX Ancient Guru

    Messages:
    2,067
    Likes Received:
    420
    GPU:
    GB RTX 2060 SUPER
    Thanks for the tip, I'm back to 19.5.1 for now too.
     
    OnnA likes this.

  5. Mesfigas

    Mesfigas Member

    Messages:
    37
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    which means ?
    is it a bug?
    should i go to a previous drivers version ?
    which one ?
     
  6. Undying

    Undying Ancient Guru

    Messages:
    11,860
    Likes Received:
    1,535
    GPU:
    Aorus RX580 XTR 8GB
    Well all latest drivers is the same for me. Since i started using more than one monitor i have this issue.
    Like @Chastity said its bug when using different monitors/refresh rates.
     
  7. Mesfigas

    Mesfigas Member

    Messages:
    37
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    both my monitors runs at 75 HZ
    1 LG ultrawide 29 inch 2560 resolution
    2. LG 23 inch 1980 resolution
    75 hertz both
     
  8. Mesfigas

    Mesfigas Member

    Messages:
    37
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    o.k i unplugged 2nd monitor completely until they find a solution
    i feel that it was a waste of electricity
    i ll wait till newer drivers fix it
     
  9. RzrTrek

    RzrTrek Ancient Guru

    Messages:
    2,342
    Likes Received:
    625
    GPU:
    RX 580 ❤ MESA 19.2
    I hope AMD got something for us today, because I've had it with freesync always freaking out and today is a big day as far as I'm concerned.
     
  10. Undying

    Undying Ancient Guru

    Messages:
    11,860
    Likes Received:
    1,535
    GPU:
    Aorus RX580 XTR 8GB
    Whats the issue? How does a freesync freaks out?
     

  11. SpajdrEX

    SpajdrEX Ancient Guru

    Messages:
    2,067
    Likes Received:
    420
    GPU:
    GB RTX 2060 SUPER
    What problems you had? :)
     
  12. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    1,970
    Likes Received:
    546
    GPU:
    Gigabyte R9 380 4G
    Why today is a big day? Any Pc games are coming out? Or you have any inside info? :)
     
  13. RzrTrek

    RzrTrek Ancient Guru

    Messages:
    2,342
    Likes Received:
    625
    GPU:
    RX 580 ❤ MESA 19.2
    I've been struggling with running my DX11 games in fullscreen and more often than not, it gets very laggy (and/or with a lot of stutter), when closing my games.
     
  14. MaCk0y

    MaCk0y Master Guru

    Messages:
    535
    Likes Received:
    159
    GPU:
    GB RX 5700 XT OC
    Connecting the second monitor has always set the memory clock at 3D Clocks speed in idle for me. That's why I connect it to the iGPU instead. Currently, the memory speed clocks down at idle if I change the refresh rate down to 100Hz from 144Hz. But this wasn't the case before. In another thread, someone asked about this and I tested it. It was the around way round for me. At 144Hz, my memory clock speed at idle was 300MHz and went I changed the refresh rate down to 120Hz, the speed actually increased to 2000MHz. Something changed recently.
     
  15. Fox2232

    Fox2232 Ancient Guru

    Messages:
    9,755
    Likes Received:
    2,203
    GPU:
    5700XT+AW@240Hz
    Radeon Settings UI starts immediately as it is preloaded. If you kill it and start a new, it takes just 2 seconds to be fully ready with everything and displayed.
     

  16. Krteq

    Krteq Master Guru

    Messages:
    497
    Likes Received:
    68
    GPU:
    RX Vega 56 +64 BIOS
    Don't feed a troll.
     
  17. Montville

    Montville Member Guru

    Messages:
    198
    Likes Received:
    17
    GPU:
    Aorus RX 570 4GB
    Me too my RX-570 got elevated idle speeds with 19.5.x - 570/1000 but should be 300/300

    I returned to 19.4 to fix this
     
  18. BlackZero

    BlackZero Ancient Guru

    Messages:
    8,880
    Likes Received:
    470
    GPU:
    RX Vega
    Hilbert has already said what needed saying.

    Let's please stay on topic, and cut out the name calling.

    Anyway, the clock speed idle bug doesn't appear to be related to multiple monitors, as I can still get it even with a single monitor plugged in.
     
  19. Krteq

    Krteq Master Guru

    Messages:
    497
    Likes Received:
    68
    GPU:
    RX Vega 56 +64 BIOS
    Yep, seems to be a confirmed bug at least for Polaris based cards :(
     
    BlackZero likes this.
  20. Mesfigas

    Mesfigas Member

    Messages:
    37
    Likes Received:
    8
    GPU:
    RX 580 4Gb
    when i m on single monitor i dont have the bug
    when i connect 2nd monitor the bug is there
    when i disconnect the 2nd monitor everything back to normal
     

Share This Page