AMD Radeon Adrenalin Edition 19.5.2 driver download & discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by mtrai, May 23, 2019.

  1. Romulus_ut3

    Romulus_ut3 Master Guru

    Messages:
    670
    Likes Received:
    138
    GPU:
    AMD RX 570 4GB
    Using DVI here, RX 570 4GB if it matters.

    If the PC is put to sleep, whenever a key is pressed to wake up, the screen turns into TV like static White noise. Unplugging and replugging the monitor (DVI) seems the only way to make it work again. Updated to Windows 10 1903 and the behavior is the same. Tried a couple of different VBIOSes, still the same.

    For those of you who make like such a problem doesn't exist: Google the terms "AMD won't wake up from sleep" "AMD monitor wake up snow" etc. etc. and you'll find thousands of forum posts where people shared their experiences of having the same issue, and it dates back to half a decade ago. Such problems made a lot of people switch camps, and when you look at the market share for GPUs, it is like that for a reason.

    AMD had an epidemic of R9 290/290X cards randomly displaying black screen and not waking up from sleep (probably an issue that existed for the HD 7000 series of cards too) and taking almost a year to partially solve the issue back then, there's also the UVD bug for the HD 7000 series of cards but my HD 7950 passed away so that no longer bothers me, but just goes to show how "competent" AMD's Radeon group is.
     
    rafaelluik and AlleyViper like this.
  2. AlleyViper

    AlleyViper Master Guru

    Messages:
    470
    Likes Received:
    61
    GPU:
    2070S Strix A|480 X
    Yes, the non-wake up affected CGN 1.0 too for almost a year. The CGN 1.0 UVD bug was finally solved last year, but both 7870s in my possession used on a secondary system passed away too.

    Meanwhile, since April (when I moved the card to it) on every DDU driver installation I do under 1903 and my RX480 paired with an old DVI w2207, at the point the driver is changing in the progression bar and the screen blinks for the ~3rd time, my screen goes either perma-red/black, cyan/magenta, green/yellow or even full of white noise (happened once only). Re-plugging the monitor or restarting solves it. Seen one user complaint with the same issue and other monitor on a Polaris card, sent my usual report do amd.

    Sometimes one wonders what can go wrong with an old proven DVI connection when it only fails with one card; that monitor had always been free of trouble paired with two 7870s, 7970, two 4890s, and a 6800GT for a long time. Now I have the DVI>DVI no wake up problem that strangely is solved with a DVI>HDMI cable (but not the crazy colors at driver install). Sigh.
     
    Last edited: Jun 4, 2019
    Romulus_ut3 likes this.
  3. OnnA

    OnnA Ancient Guru

    Messages:
    10,528
    Likes Received:
    2,336
    GPU:
    Vega 64 XTX LiQuiD
    Adrenalin 2019 Edition 19.5.2 WHQL

    Release Date
    6/3/2019

    I need to test this one out :D
     
  4. geronimo666

    geronimo666 Member Guru

    Messages:
    116
    Likes Received:
    9
    GPU:
    MSI RX Vega 56 AB
    I recently changed my GPU from GTX1060 to vega56 and after the switch I'm unable to use sleep cos whenever I turn it back on the PC is very slow and only restart helps. sometimes it resets by itself also during that process of waking up.
    I'm def sure it's related to radeon drivers.
    I'm currently on win7 on that machine so I'm not sure if it's the same problem as you describe.
    I tried cleaning with DDU. tried a few versions of drivers (some very old) and it's always the same.
    Other than that I'm very happy with the card especially cos I can finally use freesync under win7 with it, and I bought it pretty cheaply :).
     

  5. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,072
    Likes Received:
    619
    GPU:
    Gigabyte R9 380 4G
    Its the same as 19.5.2 Beta, like everytime :)

    -

    @geronimo666 I think its time for Windows 10.
     
  6. geronimo666

    geronimo666 Member Guru

    Messages:
    116
    Likes Received:
    9
    GPU:
    MSI RX Vega 56 AB
    win10 is malware/spyware :(.

    I am in the process of building gaming machine with win10, but for everting else I will keep SB and win7, at least for now. Vega 56 will be moved to that machine and 1060 will be back in SB.

    I'm just trying to figure out why I have this problem cos I didn't find similar on the web.
    With 1060 no problems ever, only unable to use freesync which is why I changed GPU camp after many many years.
     
  7. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,072
    Likes Received:
    619
    GPU:
    Gigabyte R9 380 4G
    Pffffffffffffffffff...........remove that mindset, its not good for you.

    Even your internet provider ''spy'' on you, anyway, whatever.

    Just use the wpd app and disable everything.

    Its a shame people with the newest hardware use windows 7...or hell windows 8.1! LOL.
     
  8. dezmand07

    dezmand07 Member

    Messages:
    47
    Likes Received:
    1
    GPU:
    Intel IrisProGraphics 580
    This driver is compatible with Radeon RX Vega M GH (Intel Hades Canyon NUC (NUC8i7HVK2))?
    Intel does not write a new driver, only 18.12.2 is available on their website.
     
  9. Romulus_ut3

    Romulus_ut3 Master Guru

    Messages:
    670
    Likes Received:
    138
    GPU:
    AMD RX 570 4GB
    I too get the crazy colors after the driver is installed. It goes away once I restart. You can see the crazy color for a glimpse when Windows is loading during the username greeting screen, just for a split second.
     
    Last edited: Jun 4, 2019
    AlleyViper likes this.
  10. SpajdrEX

    SpajdrEX AMD Vanguard

    Messages:
    2,257
    Likes Received:
    592
    GPU:
    Sapphire RX5700XT
    I'm also getting various colors when installing/reinstalling driver and also when Windows.
     

  11. RaulR

    RaulR Master Guru

    Messages:
    259
    Likes Received:
    1
    GPU:
    RX 5700 XT
    Yeah I have the crazy colors too when installing/ reinstalling the drivers. The games run great tough.. At first I thought the card is on it's way out. I have a RX 480 from Sapphire. I also tried the WHQL one released last night, and the same issue appears.
     
  12. Mufflore

    Mufflore Ancient Guru

    Messages:
    11,667
    Likes Received:
    753
    GPU:
    1080Ti + Xtreme III
    You like jumping on people with legitimate concerns.
    Windows 10 is spyware and is one major reason I dont use it. There are MANY more.
    I wouldnt leave my front door open at night because my house has already been burgled.
    Badly managing your systems security isnt something you should push on people who didnt even ask you!

    I dont have any issues not using it, performance or usability.
    Avoiding win10 is one of the best decisions I made, watching the crap people have been subjected to isnt funny.
     
    Romulus_ut3, MS-DOS and geronimo666 like this.
  13. OnnA

    OnnA Ancient Guru

    Messages:
    10,528
    Likes Received:
    2,336
    GPU:
    Vega 64 XTX LiQuiD
    Various colors is knows Windows bug.
    It can be resolved by CRU (check CRU thread)...
    Didn't saw bug when Installing 19.5.2 WHQL today, so it's fine :p
     
  14. Awesome Donkey

    Awesome Donkey Member

    Messages:
    14
    Likes Received:
    6
    GPU:
    Radeon RX 580 8GB
    Fluent design transparency effects still broken in 1903?
     
  15. AlleyViper

    AlleyViper Master Guru

    Messages:
    470
    Likes Received:
    61
    GPU:
    2070S Strix A|480 X
    I confirm it on log in, some days ago I even got a green checkered screen with a vga crash there -- it could be related to a 1.15V spike caused by the driver at that point, because my low voltage asic gpu hates them (can't run at that constant voltage).

    I get the crazy colors almost 99% of times after DDU'ing a driver (after regular uninstall) and then installing a new one. But if I don't uninstall anything, run the installer for the new driver and press "clean install", which will only uninstall/reboot and launch the driver setup again not requiring a restart at the end, it doesn't seem to happen at least as often. It might be related to all the stuff it installs at the same time on a truly clean state.
     
    Last edited: Jun 4, 2019

  16. OnnA

    OnnA Ancient Guru

    Messages:
    10,528
    Likes Received:
    2,336
    GPU:
    Vega 64 XTX LiQuiD
    Yes i think so.
     
  17. Chastity

    Chastity Ancient Guru

    Messages:
    2,245
    Likes Received:
    628
    GPU:
    Nitro 5700 XT
    1) I bet you don't use an active DVI to HDMI adapter, but a passive one.

    2) Your Win10 kung-fu is weak. Fear is the mind killer. Get better, experienced, and make Win10 your bitch.
     
  18. Mufflore

    Mufflore Ancient Guru

    Messages:
    11,667
    Likes Received:
    753
    GPU:
    1080Ti + Xtreme III
    What?

    What?
     
    MS-DOS and geronimo666 like this.
  19. Chastity

    Chastity Ancient Guru

    Messages:
    2,245
    Likes Received:
    628
    GPU:
    Nitro 5700 XT
    What?
     
  20. Alessio1989

    Alessio1989 Ancient Guru

    Messages:
    1,645
    Likes Received:
    368
    GPU:
    .
    yes, still randomly broken. sometimes they work, sometimes they do not.
     

Share This Page