AMD PCI Express (3GIO) Filter and PCI Bus Driver requires manually updating.

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Watcher, Jan 13, 2013.

  1. mais4u

    mais4u Member

    Messages:
    41
    Likes Received:
    2
    GPU:
    XFX 6900XT
    The install did work if you update the driver in safe mode.
    Restart the pc when you get the prompt to do so and not before.

    hope it helps!
     
  2. boombastik

    boombastik Master Guru

    Messages:
    335
    Likes Received:
    47
    GPU:
    rx580 Pulse 8Gb
    With secure boot don't work.
     
  3. X7007

    X7007 Ancient Guru

    Messages:
    1,577
    Likes Received:
    29
    GPU:
    Sapphire 6900XT
    I'll try safe mode

    Still the same after restart, it just reinstalls the old version, I think because I need to uninstall the old pci bus driver. did you all uninstalled it or over update?
     
    Last edited: Apr 12, 2021
  4. boombastik

    boombastik Master Guru

    Messages:
    335
    Likes Received:
    47
    GPU:
    rx580 Pulse 8Gb
    remove secure boot and uninstall the old version in safe mode and install the new one.
    With secure boot don't work.
     

  5. martinn

    martinn Member

    Messages:
    16
    Likes Received:
    2
    GPU:
    /
    thanks for the effort
     
  6. martinn

    martinn Member

    Messages:
    16
    Likes Received:
    2
    GPU:
    /
  7. X7007

    X7007 Ancient Guru

    Messages:
    1,577
    Likes Received:
    29
    GPU:
    Sapphire 6900XT
    Secure boot disabled.
    doesn't matter what I do in Safe mode, uninstalling the driver and installing in safe mode, it always installs the 20.50 on normal.
     
  8. GeRmAnOs

    GeRmAnOs Active Member

    Messages:
    95
    Likes Received:
    24
    GPU:
    StriX Vega64
    It installs only with AMD Radeon Software - UWP - v27.20.21001.7005 for me, with older ones i got reverted back to 20.50 after few monitor blinks.
     
  9. X7007

    X7007 Ancient Guru

    Messages:
    1,577
    Likes Received:
    29
    GPU:
    Sapphire 6900XT
    Thanks for confirming. so it doesn't fix the stuttering in VR and some games and UFO Test.
     
    martinn likes this.
  10. THEBOSS619

    THEBOSS619 New Member

    Messages:
    4
    Likes Received:
    3
    GPU:
    GTX 1660ti 6GB
    martinn likes this.

  11. Espionage724

    Espionage724 Member Guru

    Messages:
    113
    Likes Received:
    45
    GPU:
    Radeon RX 580 8G
    I'm wondering if there's some other reason for the stuttering. Not certain on VR, but the UFO test for me seems fine (after 2 minutes, no spikes above 1.2ms):

    [​IMG]
     
  12. grumpynator

    grumpynator Member

    Messages:
    28
    Likes Received:
    4
    GPU:
    tuf 5700rx 8gb
    is there any fix for this as it happens to me besides roll back
     
  13. X7007

    X7007 Ancient Guru

    Messages:
    1,577
    Likes Received:
    29
    GPU:
    Sapphire 6900XT
    Do you have Hardware Acceleration Enabled?
    What GPU do you have?

    if it's any 6xxx series? if YES then is Hardware Acceleration Enabled? if YES then you suppose to have stuttering.
    Which Browser?
     

Share This Page