AMD doesn't seem to know what driver I should use!

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by dove, Aug 8, 2014.

  1. dove

    dove Master Guru

    Messages:
    312
    Likes Received:
    0
    GPU:
    Powercolor 6950 2GB
    If I go via the main page http://support.amd.com/en-us/download and select my HD4200 IGP, it takes me to

    http://support.amd.com/en-us/download/desktop/legacy?product=legacy2&os=Windows 8 - 64

    where it says the latest recommended driver for my legacy device is 13.1 from the start of 2013 but if I click on a google search link to the german pages it takes me here

    http://support.amd.com/de-de/download/desktop/legacy?product=legacy2&os=windows+7+-+64

    which offers me 13.9 from the end of 2013!

    Anyone have any idea what AMD is playing at and what driver I should actually use?

    EDIT: It seems in fact that the 13.9 package, despite saying it's for Win 8, doesn't offer me a driver when I go to install it, whereas the 13.1 package does, so I'll have to use that.
     
    Last edited: Aug 8, 2014

Share This Page