AMD Chipset Drivers [Main Thread]

Discussion in 'Processors and motherboards AMD' started by WhiteLightning, Oct 19, 2020.

  1. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    29,237
    Likes Received:
    2,081
    GPU:
    GTX1070 iChillx4
  2. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,527
    Likes Received:
    2,930
    GPU:
    MSI 6800 "Vanilla"
    How very bright white. :D

    But it's easy enough to highlight the text when using the light(?) theme, nice with a update for these after a few months now. :)
     
    patteSatan likes this.
  3. Chastity

    Chastity Ancient Guru

    Messages:
    2,884
    Likes Received:
    1,029
    GPU:
    Nitro 5700 XT
    Well, he IS WhiteLightning, so I expect White text

    Installed, no BOOM. :)
     
    Last edited: Oct 20, 2020
  4. jbscotchman

    jbscotchman Ancient Guru

    Messages:
    5,873
    Likes Received:
    4,750
    GPU:
    MSI 1660 Ti Ventus
    Installed without issue on my ASRock B450M Pro 4.

    thumbsup.gif
     

  5. uKER

    uKER Member Guru

    Messages:
    196
    Likes Received:
    218
    GPU:
    Gigabyte RTX 2070
    Code:
    MSI (c) (44:CC) [22:48:12:332]: Note: 1: 1708
    MSI (c) (44:CC) [22:48:12:332]: Product: AMD_Chipset_Drivers -- Installation operation failed.
    MSI (c) (44:CC) [22:48:12:333]: Windows Installer installed the product. Product Name: AMD_Chipset_Drivers. Product Version: 2.10.13.408. Product Language: 1033. Manufacturer: Advanced Micro Devices, Inc.. Installation success or error status: 1603.
    MSI (c) (44:CC) [22:48:12:334]: Grabbed execution mutex.
    MSI (c) (44:CC) [22:48:12:334]: Cleaning up uninstalled install packages, if any exist
    MSI (c) (44:CC) [22:48:12:336]: MainEngineThread is returning 1603
    Already tried uninstalling the existing version of the drivers.
     
  6. Nicked_Wicked

    Nicked_Wicked Master Guru

    Messages:
    204
    Likes Received:
    114
    GPU:
    6900XT
    Installed fine on X570 and FP6.
     
  7. Undying

    Undying Ancient Guru

    Messages:
    17,279
    Likes Received:
    6,058
    GPU:
    Aorus RX580 XTR 8GB
    Do you have to uninstall previous one or you can install on top?
     
    akbaar likes this.
  8. Webhiker

    Webhiker Master Guru

    Messages:
    737
    Likes Received:
    254
    GPU:
    EVGA GTX 1080Ti SC2
    I installed on top no problems. I'm using 1usmus's powerplan and it still is the selected one after install.
     
    Undying likes this.
  9. MaBo974

    MaBo974 New Member

    Messages:
    8
    Likes Received:
    2
    GPU:
    nVidia GTX 1650
    That post made me discover there is a dark theme! Thanks!
     
    makavelipr likes this.
  10. Horus-Anhur

    Horus-Anhur Ancient Guru

    Messages:
    2,071
    Likes Received:
    2,179
    GPU:
    RTX 2070 Super
    OMG, So did I.
    With a dark theme, this forum is so much better.
     
    eGGroLLiO and MaBo974 like this.

  11. HARDRESET

    HARDRESET Master Guru

    Messages:
    805
    Likes Received:
    353
    GPU:
    1080Ti / 290X CFX
    Installed fine on Insider build 20241, fail to install on last build.
     
  12. uKER

    uKER Member Guru

    Messages:
    196
    Likes Received:
    218
    GPU:
    Gigabyte RTX 2070
    Same here.
    That said, I guess it was the update installation that fixed the issue and not something specific to the build.
     
    HARDRESET likes this.
  13. HARDRESET

    HARDRESET Master Guru

    Messages:
    805
    Likes Received:
    353
    GPU:
    1080Ti / 290X CFX
    I did not have to uninstall , just updated , new chipset working fine.
     
    Last edited: Oct 22, 2020
    Undying likes this.
  14. Undying

    Undying Ancient Guru

    Messages:
    17,279
    Likes Received:
    6,058
    GPU:
    Aorus RX580 XTR 8GB
    Did the same and installed just fine.
     
    HARDRESET likes this.
  15. Kool64

    Kool64 Maha Guru

    Messages:
    1,156
    Likes Received:
    462
    GPU:
    Gigabyte RTX2070S
    same here
     

  16. MaBo974

    MaBo974 New Member

    Messages:
    8
    Likes Received:
    2
    GPU:
    nVidia GTX 1650
    - Installation: OK
    - Post-installation changes: my customized "AMD Ryzen Balanced" power plan was reverted to default settings. I had to restore my two changes which are:
    [​IMG] [​IMG]
    - Post-installation benchmark: I use 3DMark's "Night Raid" test, and got a +1% CPU score. Btw only ran it 1 time so could be a lucky run.
     
  17. OnnA

    OnnA Ancient Guru

    Messages:
    14,227
    Likes Received:
    3,833
    GPU:
    3080Ti VISION OC
    AMD_Chipset_Software_2.07.14.327 -> This one is recommended for X370 users (No BSODS or other issues)
    Full Stable.

    On 2.10.13.408 i have 2 BSODS in a week already.
    One watching YT and today when in BFV Multi.
    Im 99% sure that this is PCIe driver fault ;)
     
    Last edited: Oct 29, 2020
  18. liviut

    liviut Member Guru

    Messages:
    182
    Likes Received:
    26
    GPU:
    Nvidia GTX 1080/8GB
    no problems for my x370 gaming pro carbon till now and i installed it on release day
     
  19. OnnA

    OnnA Ancient Guru

    Messages:
    14,227
    Likes Received:
    3,833
    GPU:
    3080Ti VISION OC
    Next release should be fine.
     
  20. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,527
    Likes Received:
    2,930
    GPU:
    MSI 6800 "Vanilla"
    https://www.station-drivers.com/ind...tory&Itemid=352&func=fileinfo&id=4691&lang=en

    2.11.26.106

    Probably some motherboard vendor again but yeah November 26th chipset drivers.

    EDIT:
    AMD's
    https://www.amd.com/en/support/kb/release-notes/rn-ryzen-chipset-2-10-13-408

    The above one.

    Tuning of the AMD Power Plan profiles from the looks of it comparing the two version numbers of included components.
     
    Last edited: Dec 4, 2020
    Pictus likes this.

Share This Page