AMD Catalyst Von modded

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Von Dach, Nov 12, 2010.

  1. Valerys

    Valerys Master Guru

    Messages:
    373
    Likes Received:
    12
    GPU:
    Gigabyte RTX2080S
    The trick worked because under Windows 7 the MLAA option and all the other were there. The bad thing is that MLAA causes strange flickering on every game I've tried; guess it was locked on other cards for a reason.
     
  2. streakpt

    streakpt Master Guru

    Messages:
    277
    Likes Received:
    0
    GPU:
    Sapphire 290 Crossfire
    Do these tweaks work well with crysis 2?
     
  3. khikhe

    khikhe New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    ati gigabyte 6870 1024
    Well why dont you just test it by yourself on your rig? And any other game you have installed in the process and share with us your gaming experience :)
     
  4. Gameslove

    Gameslove Master Guru

    Messages:
    650
    Likes Received:
    0
    GPU:
    GTX760 4GB OC/GTS450physX
    Where I can download AMD Catalyst Von Tweaks 1.3? Version 1.6 can't work with new beta driver.:3eyes:
     

  5. Prince2k

    Prince2k Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD 5770
    Does anyone else has a problem playing unencoded videos that were recorded using Fraps after following the guide steps installing these tweaks?
    Before I could play them just fine, but right after the videos stopped working for me. Both in VLC and MPC:HC (my default player). Also I can't even encode the recorded videos using MeGUI too, as it also unable to open the videos because the format is no longer supported :3eyes:

    edit: Restoring the back up that Driver Sweeper made and re-installing the drivers without applying these tweaks seems to partially fix the problem. Videos are now can be played in MPC:HC and can be encoded using MeGUI, but VLC still unable to play them.
    Well, it plays them, but only the video. No sound now with this error: "No suitable decoder module:
    VLC does not support the audio or video format "undf". Unfortunately there is no way for you to fix this.".

    Any idea what causes this?
     
    Last edited: Apr 24, 2011
  6. Gameslove

    Gameslove Master Guru

    Messages:
    650
    Likes Received:
    0
    GPU:
    GTX760 4GB OC/GTS450physX
    Please, give link to AMD Catalyst Von Tweaks ver. 1.3
     
  7. Prince2k

    Prince2k Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD 5770
    Bumping, to check if someone can help.
     
  8. maxpoz

    maxpoz Active Member

    Messages:
    66
    Likes Received:
    0
    GPU:
    Ati X1600
    with this method it's possible to use the optimized driver for 3dsmax?
     
  9. Von Dach

    Von Dach Master Guru

    Messages:
    623
    Likes Received:
    1
    GPU:
    NV560Ti @900/2394 ATI4890
    It's surely not because of the tweaks, they just make visible more 3D options in CCC.

    Von Tweaks now only modify registry display class subkey 0000 because if you follow the procedure you will have your master gpu card reseted to this default 2D driver path location like a brand new Windows installation. However if you have multiple graphic cards, your subkey might be 0001, 0002 or even 0003. Then you just have to try again with edited reg files keys, from 0000 to 0001/0002 or 0003, you can modify that yourself easily.
     
  10. Von Dach

    Von Dach Master Guru

    Messages:
    623
    Likes Received:
    1
    GPU:
    NV560Ti @900/2394 ATI4890
    Read carefully the uninstall/install procedure, I updated it to reflect changes in latest Win7 SP1 RTM DVD.

    1. Open Device Manager (Control Panel\System and Security\System)> right-click Uninstall for every display adapters, ticking "Delete the Driver Software for this Device" also if available. Display device class should now be empty. We have to do that before uninstalling AMD Catalyst because under some configurations you may get a black screen when uninstalling it, screwing the uninstall procedure.
    2. Uninstall AMD Catalyst Suite from Control Panel. Don't Express Uninstall if you have an AMD chipset motherboard. Don't reboot when asked.
    3. Open Device Manager> right-click "Scan for hardware changes". Windows will reinstall his WDDM 1.1 default driver. Don't reboot if asked.
    4. Run Driver Sweeper v3.0.0 (or newer). Don't reboot if asked.
    5. Run "Von_Display_Driver_Keys_Cleaner.cmd"
    6. (Optional) It's a good moment to do a complete registry cleaning with various specialized applications like told in Complementary General Tweaks thread (see link below).
    7. Open Device Manager> Go to Display adapters> right-click Update Driver Software> Browse my computer for driver software> Let me pick from a list of device drivers on my computer> Standard VGA Graphics Adapter. Repeat for all display adapters. All WDDM 1.1 drivers are now cleaned and Standard VGA settings are in registry.
    8. Reboot
    9. Install your new AMD Catalyst driver. Don't reboot even when asked.
    10. Run "AMD_Catalyst_Application Profiles_(CAP)_Von_Switcher.cmd". Install latest CAP or dummy. Don't reboot.
    11. Run "AMD_Catalyst_Von_Tweaks.cmd".
    12. Run "AMD_Catalyst_Von_Enhanced_Defaults.cmd" if you want enhanced quality settings by default.
    13. Reboot!

    Notes
    • Be sure to run all this with an Administrator account and with UAC disabled.
    • Von Tweaks now only modify registry display class subkey 0000 because if you follow the above procedure you will have your master gpu card reseted to this default 2D driver path location like a brand new Windows installation. However if you have multiple graphic cards, your subkey might be 0001, 0002 or even 0003. Then you just have to try again with edited reg files keys, from 0000 to 0001/0002 or 0003, you can modify that yourself easily.
    • If at any moment Windows stay stuck at "Starting Windows" boot screen, don't panic, restart in Safe Mode, open Device Manager, uninstall all display adapters even if it's already "Standard VGA", tick "Delete the Driver Software for this Device" also if available. Then right-click "Scan for hardware changes". Reboot in Normal Mode, restart the procedure, that should fix it.
    • If a specific game doesn't work good, use included Catalyst Application Profiles (CAP) Switcher, try a dummy (0KB) CAP. Dummy CAP seem to improve image quality too, textures look shinier, crisper but may cost you some fps.
    • Master forums thread: http://forums.guru3d.com/showthread.php?t=332395
    • Complementary General Tweaks: http://forums.guru3d.com/showthread.php?t=327922

    Cheers! -Von Dach

    Disclaimer
    Those tweak files are provided as is, they should work for most of us but can also create havoc in "unusual" users/systems. You take full responsibility for what may ensue and may not get back support from myself or the community if you mess up. Nothing is endorsed by AMD and the "AMD Catalyst" name is only used to point that specific software suite (driver) it intent to tweak.

    Von Display Driver Keys Cleaner 1.1
    http://www.multiupload.com/6STJ74YINH

    AMD Catalyst Application Profiles (CAP) Von Switcher 11.5 CAP1
    http://www.multiupload.com/DWOEYR6E50

    AMD Catalyst Von Tweaks 1.7
    http://www.multiupload.com/NVR4GFXJZH
     

  11. Valken

    Valken Maha Guru

    Messages:
    1,469
    Likes Received:
    79
    GPU:
    Forsa 1060 3GB Temp GPU
    Thank you Von Dach!
     
  12. Von Dach

    Von Dach Master Guru

    Messages:
    623
    Likes Received:
    1
    GPU:
    NV560Ti @900/2394 ATI4890
  13. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    1
    GPU:
    570m / MSI 660 Gaming OC
    what happens if my ratio is 1 aka no timing issue when i run that wintimer app from XS?
     
  14. khikhe

    khikhe New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    ati gigabyte 6870 1024
    Hi Von Dach. The update is working perfect but i have one slight problem, dont think its related to the tweaked drivers but i was hoping you can point me to the right direction to fix it.

    As i said, drivers are working great BUT after installing radeonpro and clicking the ATI red icon i found out that my adapter type is read as a 5770 even tho i have a 6950. So when i check radeonpro summary i have a Graphic Card HD 5700 and a Video Adapter 6900 therefore i dont get many of the tweaking boxes like eqaa etc. Right now im using ati tray tools mixed with radeonpro to fix that since att has eqaa avalaible for my card but i really want to match those series.

    I had a 5770 like a year ago and a 6870 after that. And i recall that b4 i reinstalled the catalyst drivers, my adapter type read 6800 but didnt give it much thought since i was about to install the 11.5.

    English is not my native language so if i didnt make myself clear let me know plz.

    Thx :nerd:
     
  15. VictorMizer

    VictorMizer New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    XFX 5870
    Does installing the Enhanced Defaults setting effect performance much von?
     

  16. TheOriginalTO

    TheOriginalTO Master Guru

    Messages:
    287
    Likes Received:
    0
    GPU:
    ATI 5870m
    Your mods get rid of the mouse lag in the top right corner... so awesome
     
  17. V1tol

    V1tol Master Guru

    Messages:
    284
    Likes Received:
    0
    GPU:
    MSI 1070 Gaming X
    What mods - Von Tweaks? If that's true, we have to find what exact tweak fixes it and get profit until Catmaker fixes it.
     
  18. Von Dach

    Von Dach Master Guru

    Messages:
    623
    Likes Received:
    1
    GPU:
    NV560Ti @900/2394 ATI4890
    Read the thread in http://forums.electronicarts.co.uk/b...l#post19316575 answers are there, it might take some days before I clone the valuable datas across all forum sites I care about.

    Well if it was me, I'll first uninstall RadeonPro & ATT. Manually deleting any remaning folders/files related to them too.

    Then I'll delete old ghosted devices in Device Manager:
    http://support.microsoft.com/kb/315539
    Right-click My Computer.
    Click Properties.
    Click the Advanced tab.
    Click the Environment Variables tab.
    Set the variables in the System Variables box.
    Variable name: devmgr_show_nonpresent_devices
    Variable value: 1
    Reboot.
    Device Manager> Show hidden devices> delete ghosted Display devices.

    Then proceed with clean uninstall/install like I updated it. Maybe use my tweaks.

    If really important to you then reinstall latest RadeonPro/ATT.


    On my 4890 the performance impact is almost none but visual quality improve a lot, I can't live without it!

    It is probably the clean uninstall/install method who fix this, not the reg file tweaks. In fact NVIDIA users should use this method too, it's really the only method to clean install a new display driver.

    Or maybe it is the admin cmd "bcdedit /set useplatformclock true", I never had this issue so I can only guess.
     
    Last edited: May 20, 2011
  19. V1tol

    V1tol Master Guru

    Messages:
    284
    Likes Received:
    0
    GPU:
    MSI 1070 Gaming X
    I always clean install new drivers, but mouse lag is still present for my IGP, and it was on my 5670 too.
     
  20. TheOriginalTO

    TheOriginalTO Master Guru

    Messages:
    287
    Likes Received:
    0
    GPU:
    ATI 5870m
    /edit only gets rid of it on the desktop, games still have it terribly.
     

Share This Page