1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AMD Catalyst 16.5.2.1 Released

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by Rich_Guy, May 16, 2016.

  1. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,122
    Likes Received:
    348
    GPU:
    Sapp. RX Vega 64 LC
    Last edited: May 17, 2016
  2. stasio

    stasio Member Guru

    Messages:
    139
    Likes Received:
    0
    GPU:
    Evga GTS 450 SC
    Last edited: May 17, 2016
  3. fragba1t

    fragba1t Master Guru

    Messages:
    485
    Likes Received:
    5
    GPU:
    GTX Strix 1060 6GB
    Tested with my 270x in SP mode in one spot near the start.

    Older drivers - 45fps
    These drivers - 60fps

    That's an amazing increase!
     
  4. Havel

    Havel Master Guru

    Messages:
    359
    Likes Received:
    16
    GPU:
    RTX2070
    No changes here. Oh wait I have 290X, not 390.
    [​IMG]
    Look at GPU usage. Another POS from AMD.
    Enough of this sht. I preordering almost AAA games and every start it's an uber fail. I can't simply play, because of support.
    I'll buy 1070 or 1080 soon. Good bye AMD.
     

  5. Krteq

    Krteq Master Guru

    Messages:
    450
    Likes Received:
    47
    GPU:
    RX Vega 56 +64 BIOS
    Nah, just a double V-sync -> exactly 30FPS and lower GPU usage. Review your settings.

    No such issue here - much higher FPS and GPU usage between 90 - 99%.
     
  6. freeman94

    freeman94 Master Guru

    Messages:
    292
    Likes Received:
    4
    GPU:
    MSI GTX 1070 ARMOR
    Good to see improvments for you.
    Giving the fact that I have HD7870 with is besicly the 270x
    I should also see a nice performance boost.
    So now I'm cerious if this also get OpenGL 4.5 to work or is it still workign on 4.3

    Some thing that I notice, first is that it have older Vulkan version with ends at 0.8 (same as the 16.5.1) and not 0.11 (like from the 16.5.2)
    maybe the newest wasn't so good, so they use old don't know.
    and 2nd, the madvr still not working for me just like on 16.5.2

    Overally up to 30% looks very interesting on paper, I'm waiting for some re-bench of DOOM with this one.
     
  7. Romulus_ut3

    Romulus_ut3 Master Guru

    Messages:
    647
    Likes Received:
    121
    GPU:
    HD 7950 Vapor-X 3GB
    Are you using a reference card? The last time you posted a screen, your card was at 82 degrees.
     
  8. PieEyedPiper

    PieEyedPiper Master Guru

    Messages:
    600
    Likes Received:
    0
    GPU:
    MSi HD7950 Twin Frozr/3GB
    Thank for posting.
    I was all hitting the quote button with glee to say the same.
    Def. a vsync/triple buffering issue.
     
  9. Virs

    Virs Member Guru

    Messages:
    164
    Likes Received:
    0
    GPU:
    R9 390
    Performance on my 390 at Ultra, standing in the first room:
    Went from 36 fps to 75.

    To answer another question: it still uses OpenGL 4.3.
     
  10. PieEyedPiper

    PieEyedPiper Master Guru

    Messages:
    600
    Likes Received:
    0
    GPU:
    MSi HD7950 Twin Frozr/3GB
    Anyone else getting no read from the gpu with regards to Doom's nightmare hw info display?
    Worked this morning..
     

  11. sean8102

    sean8102 Member Guru

    Messages:
    168
    Likes Received:
    1
    GPU:
    EVGA GTX 1080 SC
    Massive improvements for me on my 390X. I was also able to bump shadow quality from high to ultra, everything else was already on nightmare/ultra settings. I've taken out 3 gore nests so far and didn't see one single drop below 60FPS.

    Also seems to have fixed the v-sync bug that was driving me crazy where it would go to 30FPS sometimes. Both of these shots are with v-sync on, 30FPS is previous driver 60FPS is today's.

    http://i.imgur.com/3GUR6vC.jpg

    http://i.imgur.com/ijNla5z.jpg
     
  12. sean8102

    sean8102 Member Guru

    Messages:
    168
    Likes Received:
    1
    GPU:
    EVGA GTX 1080 SC
    Yeah I get the same thing with the new drivers as well. Can see it in my screenshot above. I think I can live with it for the performance benefit :D
     
  13. Gothik

    Gothik Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    AMD R9 380X 4GB
    Can't play Doom at all with these drivers, boots to black screen and just stays there. Have to shut down my PC to be able to get the desktop back. Returning to 16.5.2..
     
  14. Virs

    Virs Member Guru

    Messages:
    164
    Likes Received:
    0
    GPU:
    R9 390
    The only differences for me:
    Compatibility profile context went from 16.150.2401.1002
    to 16.200.1010.1002

    And my reported vram went down by 1. 8171 to 8170. IMMA ASK FOR A REFUND.
     
  15. MerolaC

    MerolaC Ancient Guru

    Messages:
    2,995
    Likes Received:
    83
    GPU:
    RX VEGA 56
    Doom is working wonderful for me.
    Having 90 to 130 fps.
    Before I was having 50 to 80 fps.
     

  16. Fox2232

    Fox2232 Ancient Guru

    Messages:
    8,659
    Likes Received:
    1,596
    GPU:
    -NDA +AW@240Hz
    That is not very helpful post. Try to at least fill your HW details. Then state how you installed drivers and if you tried using AMD installation manager to remove previous driver before installation.
    And if you went to DDU as last resort.

    @Rich: Thank You.
     
    Last edited: May 17, 2016
  17. passenger

    passenger Master Guru

    Messages:
    287
    Likes Received:
    19
    GPU:
    Sapphire RX 580 8GB
    Anyone got a mirror? AMD.com doesn't work last 2 hours for me, every other site works...:(
     
  18. Agonist

    Agonist Ancient Guru

    Messages:
    2,705
    Likes Received:
    145
    GPU:
    R9 Fury X
    Check your settings before spewing such non sense.

    No statement of Resolution used or settings.
    Obviously you are capped at 30 fps due to double vsync but want to blame AMD for your own problems.
     
  19. Fox2232

    Fox2232 Ancient Guru

    Messages:
    8,659
    Likes Received:
    1,596
    GPU:
    -NDA +AW@240Hz
    I did just DL it, try to set your DNS to 8.8.8.8 as that's from google and usually fixes local ISP problems.
     
  20. PieEyedPiper

    PieEyedPiper Master Guru

    Messages:
    600
    Likes Received:
    0
    GPU:
    MSi HD7950 Twin Frozr/3GB
    Copy that! Glad it's a bug and not just me.
    Very impressed with the improvements.
     

Share This Page