AMD Catalyst 15.9.1 Beta Driver

Discussion in 'Videocards - AMD Radeon Drivers Section' started by OrionCheung, Oct 1, 2015.

  1. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    what the hell is "turn off the display for it"

    never heard of it.

    is this a win 8.1 thing?
     
  2. Truder

    Truder Maha Guru

    Messages:
    1,362
    Likes Received:
    310
    GPU:
    Sapphire Fury Nitro
    He's on about this thing

    [​IMG]

    I'm on Win10, these options have been present in this manner since vista
     
  3. d0X

    d0X Member Guru

    Messages:
    190
    Likes Received:
    11
    GPU:
    MSI RTX2070S Ventus
    I am getting plenty of driver crashes in comparison with 15.7.1. Madvr is crashing like hell too.
     
  4. thatguy91

    thatguy91 Ancient Guru

    Messages:
    6,643
    Likes Received:
    98
    GPU:
    XFX RX 480 RS 4 GB
    That's right, and it works :).
     

  5. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    nope, dont have that option in win7 or win10 on either of my computers.
     
  6. thesmokingman

    thesmokingman Member

    Messages:
    36
    Likes Received:
    0
    GPU:
    XFX 6950
    The panel on the left under Power Options should have a link for "Choose what the power buttons do." It's under there. If you don't have it then there's something wrong on your end because it's supposed to be there. I haven't used Win 7 in a while and it feels like I've forgotten much of it, but it should be there too. In Win 10, I'm looking at my option right now.

    And by default, power button should set to power down for a desktop.
     
  7. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    im well familiar with the powers option panel.

    Aint there, on two different computers.

    One windows 10 pro Z97, another win7 pro Z87.

    [​IMG]
     
  8. thesmokingman

    thesmokingman Member

    Messages:
    36
    Likes Received:
    0
    GPU:
    XFX 6950
    Have it here on W10.

    [​IMG]
     
  9. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    dunno, i dont have the issue anyway, just something ive never seen before.
     
    Last edited: Oct 6, 2015
  10. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,622
    Likes Received:
    620
    GPU:
    MSI 2070S X-Trio
    Finally got these ones on, and no issues so far :)
     

  11. N0bodyOfTheGoat

    N0bodyOfTheGoat Member Guru

    Messages:
    192
    Likes Received:
    0
    GPU:
    Sapphire Nitro R9 390 8GB
    Good tip, changed the setting earlier, left pc for a while and touched standby button to re-activate monitor screen.:eek:c:
     
  12. thatguy91

    thatguy91 Ancient Guru

    Messages:
    6,643
    Likes Received:
    98
    GPU:
    XFX RX 480 RS 4 GB
    Thanks! Hopefully they'll fix the bug soon. You may need to press the button twice, one to turn the monitor(s) off and again to turn them back on. I can't remember exactly!
     
  13. Despoiler

    Despoiler Master Guru

    Messages:
    244
    Likes Received:
    0
    GPU:
    Sapphire TRI-X R9 Fury
    I've got this bug with these drivers. CTRL+ALT+DEL wakes it up for me.
     
  14. PieEyedPiper

    PieEyedPiper Master Guru

    Messages:
    620
    Likes Received:
    2
    GPU:
    RX 580
    Has anyone has the SoD bug (Sleep of Death bug) since installing Win10?
    I've tried a handful of drivers so far and none have exhibited the behavior, whereas, in the past, my system was a prolific example of such.

    Goat, Despoiler, are you on Win10?
     
  15. thatguy91

    thatguy91 Ancient Guru

    Messages:
    6,643
    Likes Received:
    98
    GPU:
    XFX RX 480 RS 4 GB
    If that works that's good too I guess. When you ctrl+alt+del, the screen changes to the option list. HOWEVER the interesting aspect is that the waking of the monitor (the issue worked around by the power button) is very easily the driver. The workaround you put forth suggests a Windows bug?... Pressing the power button resets the display system, but ctrl-alt-del I believe just opens up that command list. Who knows, maybe there is some level of re-inititialisation when that occurs that triggers the display wakeup properly?
     

  16. PieEyedPiper

    PieEyedPiper Master Guru

    Messages:
    620
    Likes Received:
    2
    GPU:
    RX 580
    Bingo ^^

    The action of CTRL+ALT+DEL and Win+P have the same effect of "resetting the display system".

    In win8.1 and win10 the screen blinks ever so slightly when given those commands (very noticeable on an old laptop though).

    As mentioned, I've had many iterations of this problem but I've not ever been able to solve it through any windows feature because for me, it's a driver issue. But it's all good since I haven't seen it in months now. Pretty sure since win10.
     
    Last edited: Oct 7, 2015
  17. joe187

    joe187 Master Guru

    Messages:
    485
    Likes Received:
    20
    GPU:
    Nvidia GTX1070 FE
    Good drivers for me so far. Only issue i am still having though, the setting in CCC called "Reduce DVI Frequency on high-resolution displays". Checking it fixes issues for me, when running a lower desktop res other then native which i want to be able to do (it fixes funky looking edges).

    The problem is, it appears to stay checked , but it really doesn't survive reboot/logoff, even going into full-screen game and exiting. Have to always uncheck, then recheck and apply.

    I know this hasn't worked at all in any driver after 15.6 on win10 for me, maybe even drivers before that but i'm not sure since i haven't needed it then. Tried it in 15.7, 15.7.1, 15.8, and now of course 15.9.1. Probably not a big priority since most don't have need for this setting but i know i'm not the ONLY one out there.

    EDIT: i did submit bug report to amd about it whatever good that will do :banana:
     
    Last edited: Oct 7, 2015
  18. Tat3

    Tat3 Ancient Guru

    Messages:
    11,719
    Likes Received:
    114
    GPU:
    GB GTX 1660 Ti OC
    I'm getting crashes to desktop with this driver and previous non beta. W10 and games like SC2 and The Witcher 2 (have not played other games with this PC yet). No error, it just goes. Any idea if it's the drivers or something else ?
     
  19. AsiJu

    AsiJu Ancient Guru

    Messages:
    6,718
    Likes Received:
    1,805
    GPU:
    MSI RTX 2070 Armor
    I got crashes to desktop too in FIFA 15 and one in Shadow Warrior. However, they weren't necessarily due to the driver as I had HID-devices disabled and ran my memory beyond XMP spec.

    After resetting defaults for memory and re-enabling HID-devices no crashes yet. Will see, haven't played much though.

    W10 x64 10240.
     
  20. Despoiler

    Despoiler Master Guru

    Messages:
    244
    Likes Received:
    0
    GPU:
    Sapphire TRI-X R9 Fury
    Yes Win10 Pro x64 Insider Build 10547. More info, a reboot seems to have fixed the issue for few days now. It took a few days to get the bug after installing the drivers. Whatever it is it seems like something triggers the bug for me not that it's ever present.
     

Share This Page