AMD Catalyst 15.7 WHQL Driver - Download & Discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by AMDMatt, Jul 8, 2015.

  1. MaxiM

    MaxiM New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    ATI Radeon HD 7870
    OpenCL is not working even under Windows 7. How the hell is this a WHQL driver... who is testing this?

    Unless I can find a workaround, I will have to revert back to the unstable 15.5beta because OpenCL turned out to be a steaming pile of failure yet again in this release :bang:

    EDIT: OK, so people are saying the OpenCL files are in 15.7, but after a fresh install OpenCL was not working at all. Found this in another thread:

    After unpacking the files to system folders it started working. And it's the 15.7 files, so I'm confused now. Broken installer?
     
    Last edited: Jul 28, 2015
  2. JaxMacFL

    JaxMacFL Ancient Guru

    Messages:
    1,715
    Likes Received:
    1,065
    GPU:
    3090 FTW3 ULTR/HYBR
    Just realized that crossfire doesn't work with TDU2 anymore.
    Rolled back to 15.6 beta, everything as advertised.
     
  3. judicator

    judicator Member

    Messages:
    39
    Likes Received:
    0
    GPU:
    PNY 3090 RTX Revel
    Re: error - SYSTEM_THREAD_EXCEPTION_NOT_HANDLED - atikmdag.sys
    OS: Windows 8.1 and now Windows 10 same problem

    I do not know if it was this release or the one prior. But suddenly I've started to get this error. On my system I have 2 BENQ displays with an ATI R9-280x. As well I have a Pioneer receiver plugged in via HDMI. I can now reproduce this error every time I turn on my receiver while the computer is running and it tries to re-detect the displays. If I start the computer with the receiver already on then it works fine as it always has. I used to be able to turn the receiver on and off anytime and it would detect it fine with no problems.

    [​IMG]
     
    Last edited: Aug 2, 2015
  4. Dch48

    Dch48 Ancient Guru

    Messages:
    1,822
    Likes Received:
    1
    GPU:
    Sapphire Nitro+ RX 470 4g
    My system seems to like this driver better than the newer 15.7.1 where I was getting graphics driver crashes and black screens.
     

  5. niczerus

    niczerus Master Guru

    Messages:
    290
    Likes Received:
    3
    GPU:
    MSI GamingX 580 4GB
    on witcher 3 have a lot of Display driver stopped responding and has recovered" with the last drivers on win 7x64 :/ .
     
  6. Valken

    Valken Ancient Guru

    Messages:
    1,721
    Likes Received:
    179
    GPU:
    Forsa 1060 3GB Temp GPU
    Windows 7 x64 Pro

    I had a ton of problems with these drivers so finally dropped back down to 15.6. I tested mainly OpenGL and performance dropped hard with 15.7 and 15.7.1. 15.6 brought it back up. Probably the last codepath for my card though.

    Also, CCC did not work even after I nuked .net 4/4.5 and let the installers reinstall.

    15.6 CCC still does not work either so I just uninstalled it and use Radeon Pro for my game settings.

    DEFAULT video playback settings on 15.6 looks way better than 15.7 or 15.7.1 for some reason. I believe its the color settings, but without CCC, I can't change it. I had to a registry change to fix the overscan black borders but its working now.

    If I need future drivers for games compatibility, I will just drop DLLs.
     
  7. Garwinski

    Garwinski Member Guru

    Messages:
    183
    Likes Received:
    4
    GPU:
    XFX Fury X
    This was a problem with drivers quite a while ago, but it began again with the windows 10 drivers:

    My computer freezes in a black screen during installation.

    I uninstall with DDU, then install with the installer: freeze. Installing manually through device manager, I get the black screen freeze as well. After a while and some freezes and I have to reset my computer again, device manager tells me the drivers are updated non the less, but now I get throttling on one of my chips, which is normally resolved with a good decent reinstall of my drivers, but yea...

    Anyone with the same problem?
     
  8. paradoxical

    paradoxical New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    ATI HD4850
    Hey guys;

    Is there any working driver with good performance for hd4850 in win10?
     
  9. 22JHP

    22JHP Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    Asus 380 4GB
    there is no windows 10 driver for 4850.
     
  10. sathyrion

    sathyrion Active Member

    Messages:
    67
    Likes Received:
    4
    GPU:
    MSI RX5700XT MechOC
    I'm having a issue with BF4 and BFHardline with my crossfire setup. I'm getting about 86% utilization on GPU1 and 99% on GPU2. CPU are around 50-70%. And if I crack up the MSAA to 2 or 4 the game drops to 15-20 fps, ang gpu usage drops both cards to 40-50%.. Running ultra without AA @ 90-120 fps. Anyone else having this issue?

    Running a i7 3770 and 2x Identical XFX HD7850 2GB. 16GB DDR3 1333Mhz and SSD.

    Could it be my PSU that cant give enough power?
    It's absolutely in the dangerzone as it's only a 500w 80Plus Bronze :D
     

  11. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,649
    Likes Received:
    578
    GPU:
    Inno3D RTX 3090
    Are you using Windows 10?
     
  12. sathyrion

    sathyrion Active Member

    Messages:
    67
    Likes Received:
    4
    GPU:
    MSI RX5700XT MechOC
    Yes I am. Also tried the latest 15.7.1 driver with the same result.
     
  13. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,649
    Likes Received:
    578
    GPU:
    Inno3D RTX 3090
    You get exactly the same as I was getting with AC Unity when I was upping either the texture quality, or the resolution. Huge performance decrease across the board (much much more than expected), and the performance would go recover only if I dialed the settings back and restarted the game.

    I have reported it to AMD more than once, but I believe you should report it too, because it sounds like a more generic problem.
     
  14. sathyrion

    sathyrion Active Member

    Messages:
    67
    Likes Received:
    4
    GPU:
    MSI RX5700XT MechOC
    Ok, Sent a report on it.
    The low gpu usage happens on other games aswell. Like Dirt Rally and Project Cars.
    CS:GO, GTA V, TESO, Heaven/Valley and 3DMark runs at 99% on both GPU's.
     
  15. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,649
    Likes Received:
    578
    GPU:
    Inno3D RTX 3090
    It hasn't happened to me in any other game up to now. The pattern is usually something that forces the usage of more VRAM for me, and then instead of getting hitching at points, the game becomes permanently slow. Now that I think about it, they did say that they would check their VRAM usage for the first time in the drivers now, didn't they? I remember something like that being said during the launch of the Fury X.
     

Share This Page