AMD Catalyst 15.7 WHQL Driver - Download & Discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by LtMatt81, Jul 8, 2015.

  1. Romulus_ut3

    Romulus_ut3 Master Guru

    Messages:
    762
    Likes Received:
    224
    GPU:
    AMD RX 570 4GB
    My driver crashes too on Windows 10 while running Google Chrome every once in awhile, but it doesn't seem like it's related to the clocks or anything. And I can confirm that there're issues with older games on Windows 10, I was trying Deus EX Invisible Wars and it crashed if I tried to change the resolution.
     
  2. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,652
    Likes Received:
    271
    GPU:
    RX 580 8GB
    Report all these bugs to AMD/Microsoft guys!
     
  3. soryuuha

    soryuuha Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    xxx 270 xxx
    saw someone said do not install HDMI driver, so i dont...

    can someone highlight back what was the problem with hdmi driver on 15.7?
     
  4. fish

    fish Active Member

    Messages:
    59
    Likes Received:
    2
    GPU:
    MSI 5700 XT
    I am also having a couple of issue with:

    Win 10 / 15.7 / 290x

    Assetto Corsa stutters very badly when you start a race.
    When the race loads and the camera is panning around your car - it stutters badly - once every 6/7 seconds this continues for about 30-40 seconds - then everything is smooth as it should be for the duration of the race. Repeats when you start a new race.

    Insurgency: Similar to above with stuttering when in game, does not resolve itself like assetto corsa does.

    Loads of other games are working fine, tried a DDU uninstall and reinstall of 15.7 also tried 1040 drivers - same symptoms.
     

  5. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,652
    Likes Received:
    271
    GPU:
    RX 580 8GB
    AMD tell you to contact Microsoft and Microsoft tell you to contact AMD.
    I guess what we have to do is wait for Windows 10 to be officially released so we can report bugs to AMD.
    GTA V has bad stutter here.
     
  6. Garwinski

    Garwinski Member Guru

    Messages:
    185
    Likes Received:
    4
    GPU:
    XFX Fury X
    I have exactly the same problems! I recently installed windows 10 and thought the problems to be Windows 10 related, but it seems like it is the 15.7 drivers. Will try it with the latest update trough windows update (1023.7).
     
  7. seb4771

    seb4771 Guest

    For WOT, it's WOT 9.9 problem, not 15.7.

    15.7 + wot 9.8 version = no problem, no hang up, no windows return, no crash.
    update 9.9 = most problems for people (see WG forum).

    - GTA 5 = "big" micro stutter with 15.7 but gain +3 fps.

    + The witcher 3 (+E3 mod) gain +4 fps

    - 15.7 have 1 problem for me after upgrading my computer (7970 Ghz => 7970 Ghz + R9 280x asus dcuII), system crashing after 7h without activity (irc only).
    no specific message, no windows errors, no software specific error.
    + 15.6 beta doesn't have this problem

    using win7 x64 version.

    UPDATE : Crashes when playing on a PC with combination AMD (Radeon) + Catalyst 15.7 driver
    Also when using this driver you might face an issue when landscape on a map may disappear.
    This Issue is quite complex. We are investigating it and trying to find a solution. Unfortunately we didn't filtered out this bug during Common test, since this version of the driver was released on 7 July when CT was almost finished. We can recommend as a temporary solution to use an older version of a driver. We are working on the solution and hope to fix the issue soon.

    Confirmed by WG
     
    Last edited by a moderator: Jul 21, 2015
  8. rafaelluik

    rafaelluik Active Member

    Messages:
    95
    Likes Received:
    0
    GPU:
    AMD Radeon R9 280
    No problems on the Windows 10 RTM until now.
    I use Opera (based on the latest stable Chromium/Chrome) with hardware acceleration enabled and no crashes with it.
     
  9. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    8,085
    Likes Received:
    929
    GPU:
    Inno3D RTX 3090
    Everything is completely closed from the Xbox app.
     
  10. CrunchyBiscuit

    CrunchyBiscuit Master Guru

    Messages:
    316
    Likes Received:
    94
    GPU:
    AMD Radeon HD6950 2GB
    Yey, some serious changes and improvements!

    They finally fixed driver v-sync in Rage on my HD6950 and I presume in other OpenGL titles and on other cards as well. 15.7 is also generally faster in OpenGL than 14.7 (the last driver without v-sync issues in OpenGL before this release) was, so I currently use these for OpenGL. I'm glad it got fixed. Let's hope it doesn't get broken again.

    Both Crysis 2 and 3 run faster on these drivers than on any driver released before (only tested in DX9 on a HD6950 in Win7x64).

    Resident Evil 6 still has the exact same issues. The odd, consistent frame drops are still there all the time, even in the main menu and during the intro movies. Going all the way back to 13.10b2 (or drivers before that release) instantly fixes it.

    Kingdoms of Amalur is still slower on these. Going all the way back to 13.12 results in higher frame rates, without any side effects.

    All my currently installed UE3-games seem to perform te same on my machine on all drivers released since 13.12, including these.

    Seems like a pretty good driver set, delivering performance improvements for various older games on dated hardware, without breaking stuff that wasn't broken before.

    I just use the older driver *.dlls for those games that perform better using older drivers.

    EDIT: V-sync also works again in Aquaria, another OpenGL title. Sweet.
     
    Last edited: Jul 19, 2015

  11. rafaelluik

    rafaelluik Active Member

    Messages:
    95
    Likes Received:
    0
    GPU:
    AMD Radeon R9 280
    I can't get motion blur to work on Tomb Raider (when going down in zip lines or moving the camera really fast) since a lot of releases already. 14.4 was the last one that I got it working.
    I used DDU. Verified the game files through Steam. Reinstalled the game... It was not working in Win 8.1 and doesn't work after the Windows 10 upgrade + DDU + new 15.7 driver package either.

    Does anyone else have the same issue or any tips so I can try to solve it?
     
  12. crazyazz

    crazyazz New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    MSI GTX 780 OC
    Running win 10 100240 and a HD 7850, in dxdiag should i see DX 12 listed as supported?
     
  13. mR Yellow

    mR Yellow Ancient Guru

    Messages:
    1,935
    Likes Received:
    0
    GPU:
    Sapphire R9 Fury
    Guys, i'm experiencing major lag and stutter in GTA V using build 15.7 in Win10 (build 10240).

    Frames are high but gameplay is jerky. Wasn't like that in Win8.1.

    Anyone else experience this?
     
  14. aaronne

    aaronne Member

    Messages:
    27
    Likes Received:
    4
    GPU:
    MSI 1060 mxm 6GB
    Me! but I read over forum that issue before.

    But I reverted back to 15.6b with DDU and now all goes fine, I speak for my 7970m on both win7 and win10 (from build 10166 to 10240 the proposed win driver seems as 15.200.1023.7 from dxdiag, never worked well).
     
  15. MatrixNetrunner

    MatrixNetrunner Member Guru

    Messages:
    125
    Likes Received:
    0
    GPU:
    Powercolor PCS+ R9 270X
    A lot of people (including me) turn off motion blur, especially if the game is running at 60+ fps. You can always try to use the DLL injection method and use 14.4 driver DLLs for Tomb Raider only. But then you are missing out on better performance of 15.7 (10-15% faster).
     

  16. Passus

    Passus Ancient Guru

    Messages:
    2,129
    Likes Received:
    704
    GPU:
    3060Ti GamingZ Trio
    dxdiag does display dx12 but highest feature level for us GCN 1.0 owners is 11.2

    we will however have some (software?) support and i do notice a massive increase in the 3dmark APi overhead test
     
  17. crazyazz

    crazyazz New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    MSI GTX 780 OC
    Thanks mate
     
  18. rafaelluik

    rafaelluik Active Member

    Messages:
    95
    Likes Received:
    0
    GPU:
    AMD Radeon R9 280
    The point is it should work if the option is enabled. Does it work if you turn it on or is it only my PC?
    (Hmm with the 14.4 DLL it didn't work.)

    PS. on the i3 integrated graphics the motion blur works.
     
  19. Valken

    Valken Ancient Guru

    Messages:
    2,421
    Likes Received:
    623
    GPU:
    Forsa 1060 3GB Temp GPU
    Update to my feedback... I dropped in 14.4 and 15.4/15.5 OGL DLLs to use QEffectsGL with GZdoom and Half-Life 1 and my performance is back. Something has changed with 15.6 and newer OGL.

    It works if I don't use any OGL injectors but I won't give up mods for now.
     
  20. MatrixNetrunner

    MatrixNetrunner Member Guru

    Messages:
    125
    Likes Received:
    0
    GPU:
    Powercolor PCS+ R9 270X
    Did some testing and motion blur works on 15.7. You just need to strangle the frame rate to below 30 fps. Here's what I used:
    - RTSS: framerate limit = 30 (this was probably enough to make the motion blur observable)
    - VSR: 2560x1440
    - Ultimate preset + Ultra Shadows + 4xSSAA

    TL;DR - It's working, but because it's a relatively well optimized game we can't notice the difference when we are running on > 60Hz constant. You need to run it on poor hardware to perceive the effect.
     

Share This Page