AMD Catalyst 15.7 WHQL Driver - Download & Discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by LtMatt81, Jul 8, 2015.

  1. heroxoot

    heroxoot Master Guru

    Messages:
    442
    Likes Received:
    0
    GPU:
    EVGA 1080ti SC2
    So one glitch I found is this driver will set my memory clock to idle 150mhz with dual monitors. At first I had no issues and then my monitors started freaking with what looked similar to frame tears. Rebooting fixed it the one time and it has not happened since. I loved how low my temps were though since my 290X was not clocking 1250memory the whole time.
     
  2. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,620
    Likes Received:
    257
    GPU:
    RX 580 8GB
    Would have been easier to just try install it and see what happens :)
     
  3. Jackalito

    Jackalito Master Guru

    Messages:
    583
    Likes Received:
    100
    GPU:
    Radeon RX 5700 XT
    I can't play Team Fortress 2 with these drivers :(
    The game crashes and I have to end the process through Task Manager.

    Here's hope for a future driver without this particular issue.

    Cheers!
     
  4. Dr451

    Dr451 Active Member

    Messages:
    87
    Likes Received:
    4
    GPU:
    Gigabyte AMD R9 270X 2GB


    SRY not for me, I have AMD R9 270X
     

  5. brightbule3921

    brightbule3921 Active Member

    Messages:
    62
    Likes Received:
    0
    GPU:
    PowerColor AXRX460 2G/OC
    Ok , today I noticed my first TDR crash in this driver(15.7,win8.1x64).

    It seems only happen when I am watching Twitch on Firefox.I tried twice and same result.
    [​IMG]

    Twitch is still a flash base stream site, and the Adobe Flash version(for firefox) is latest 18.0.0.209.

    But I did not experience TDR when I am watching HTML5 video or gaming,So it maybe only affect adobe flash.I just turn H/W off in flash since I do not use it often.

    As for dxva/dxva2 playback(potplayer),they are fine since I installed 15.7.

    EDIT :HTML5+DXVA breaks in some case(but not TDR)
    I did a more deep testing with some tools like DXVAChecker/TaskManager/MSI Afterburner.

    And I found :
    IE+html5 : I am not sure now,need more test.

    Google Chrome+html5 : DXVA never works.I remembered it works with 14.12omega.(I found a way to fix this, install H264ify plugin)

    Firefox+html5 : DXVA unstable. It will broken and never work until I restart Firefox ,if I touched the control bar or change the resolution.Some video does(ex:60FPS) and some not and randomly.

    All latest version.

    So maybe DXVA issue is still there but since it sometimes broken and the browser use CPU automatically,I will never notice the TDR issue that happens in 15.3~15.6 on my card.
     
    Last edited: Jul 16, 2015
  6. Passus

    Passus Ancient Guru

    Messages:
    1,916
    Likes Received:
    594
    GPU:
    3060Ti GamingZ Trio
    why wont it work? it works for all cards

    even if your card is a hawai you can still run both reg files, same for tahiti
     
  7. MatrixNetrunner

    MatrixNetrunner Member Guru

    Messages:
    125
    Likes Received:
    0
    GPU:
    Powercolor PCS+ R9 270X
    How are you using Adobe Flash on Firefox? Didn't Mozilla ban Flash on Firefox for the time being (and maybe forever) yesterday?

    Update: I see you are using the latest version (http://gizmodo.com/firefox-now-blocks-flash-by-default-1717664482). I quit using Flash plugin 6 months ago (I use Chrome if I really need Flash).
     
    Last edited: Jul 15, 2015
  8. brightbule3921

    brightbule3921 Active Member

    Messages:
    62
    Likes Received:
    0
    GPU:
    PowerColor AXRX460 2G/OC
    In fact I do not know how Firefox can ban it without any upgrade data coming.(It still at 39.0)

    Maybe because I upgrade from old version so the setting is kept in plugins setting?

    Anyway You still can set it activate or not, I set it to Always ask though:
    [​IMG]

    There are still many flash sites out there,like Twitch.I doubt if Firefox will ban flash from program it self.Just like JAVA, you can still enable it in plugins setting tab.

    EDIT:
    And you still can install Flash plugin(for firefox) from Adobe Flash player download site.Just to browse flash player site with Firefox.
    https://get.adobe.com/flashplayer/
     
    Last edited: Jul 15, 2015
  9. GHAM1

    GHAM1 Active Member

    Messages:
    74
    Likes Received:
    0
    GPU:
    sapphireTRIXX R9 290x CF
    anybody know if there's a second review of fury with 15.7 drivers?
    would like to see if there's any difference in lower res
     
  10. Passus

    Passus Ancient Guru

    Messages:
    1,916
    Likes Received:
    594
    GPU:
    3060Ti GamingZ Trio
    have you googled it?
     

  11. Hana88

    Hana88 Member Guru

    Messages:
    157
    Likes Received:
    0
    GPU:
    Ati radeon 7970@ 1100/145
  12. MatrixNetrunner

    MatrixNetrunner Member Guru

    Messages:
    125
    Likes Received:
    0
    GPU:
    Powercolor PCS+ R9 270X
    I use Firefox and HTML5 video without any issue. I usually have Media Player
    Classic HC on pause while web video plays, with no problems.
    Did you uninstall the previous Catalyst and clean up with DDU?
     
  13. DM789

    DM789 Master Guru

    Messages:
    443
    Likes Received:
    2
    GPU:
    ???
    for peoples like me that is on win 7 x64,

    the installation file on AMD site is corrupted,
    and i tried redownloading it a lot (10-20x),

    i tried downloading from tech crunch, and the installation can now launch.

    really should have tried from other sites after that 3rd re-download still corrupted.

    :bang: :bang: :bang:
     
  14. flow

    flow Maha Guru

    Messages:
    1,011
    Likes Received:
    14
    GPU:
    Asus TUF RTX3080 oc
    These drivers installed fine for me on win7 x64.
    While I don't intend to use the frame limiter option, I'm certainly using the virtual resolution option.
    Performance thus far is fine also.
     
  15. drlobster

    drlobster Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    AMD 290 x2
    I'm not sure if it's these drivers or my new fsb overclock, but I'm getting 30-80 fps in the Witcher 3. Running at 3200x1800 with everything maxed, but hairworks/AA/HBAO+.
     

  16. MatrixNetrunner

    MatrixNetrunner Member Guru

    Messages:
    125
    Likes Received:
    0
    GPU:
    Powercolor PCS+ R9 270X
    I have just downloaded the win7 64bit 15.7 Catalyst from amd.com and unpacked it without problems. If I were you, I would check your RAM, HDD and Ethernet connection.
     
  17. brightbule3921

    brightbule3921 Active Member

    Messages:
    62
    Likes Received:
    0
    GPU:
    PowerColor AXRX460 2G/OC
    It turns out it is Firefox only issue when I installed H264ify on Chrome:
    [​IMG]
    VP9 is the reason that Chrome did not use DXVA on the HTML5 Video if the plugin H264ify is not installed.

    And before talking Firefox issue, to make it clear:
    1.HTML5 Video playback is smooth.
    2.I do not use DDU, but I uninstall and re-install by AMD catalyst install manager.
    3.Before I install 15.7, I always make sure that in the device manager in the display adapters only Microsoft Basic graphic driver there.
    4.Sometimes before install driver, I will delete this value from register to fix setting not been retained issue in CCC :
    /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0000
    5.I also delete AMD/ATI folder in c:\users\myname\appdata

    The issue of Firefox and what I called HTML5+DXVA broken is the following:
    1.When I open a video(mp4 decode just like the picture shows), Firefox uses DXVA normally at first,and CPU usage is very low(<10%).If you use DXVA Checker or any GPU monitor software,you can easy found that DXVA/GPU hardware accelerate is enabled.

    2.But if I move the HTML5 player control bar,or keep changing resolution from 720 to 1080 and 1080 to 720,then the issue will occur.
    It is randomly but easy to occur on some FPS60 videos.
    ex:https://www.youtube.com/watch?v=lfwjzNB--5k
    Or
    ex:https://www.youtube.com/watch?v=KffL9jZDZag

    3.When the issue occurs,video play is still smooth,but you will find that CPU usage(of firefox) grows to 20%~, GPU hardware accelerate/DXVA is not been used anymore.

    4.At this time Firefox is using mp4(h264) codec, but never use DXVA until I restart Firerfox.

    The same test on Chrome(+H264ify) or IE11 is fine,or be it hard to replicate the issue.

    If there is anyway to make default size of HTML5 video on youtube always 1080P(so I need not to change resolution manually) , maybe I can ignore this issue on Firefox but no way I can find to do it.

    You can see video/mp4 codec is used and GPU is in idle mode(300MHz instead of 450MHz),also CPU usage is up:
    [​IMG]

    I am not sure if this is only my case or not. If you are interesting in it you can do the test.

    But anyway maybe this is a Firefox issue ,not a driver issue.
     
    Last edited: Jul 16, 2015
  18. afx01

    afx01 Member

    Messages:
    19
    Likes Received:
    0
    GPU:
    MSI HD7870 OC 2GB/256bit
    display driver crashes while playing GTAV, no such issues with 15.6 :/

    HD7870...
     
  19. MatrixNetrunner

    MatrixNetrunner Member Guru

    Messages:
    125
    Likes Received:
    0
    GPU:
    Powercolor PCS+ R9 270X
    I think I have the same issue. I usually watch video in a tab, so it's usually 480p and the difference is not as noticeable. Sorry for writing a reply without doing a real test.

    After fiddling with the video resolution for a couple of times, CPU usage jumps from the relatively constant to CPU dependent (higher resolution->significantly higher CPU usage). Also, GPU-Z, for example, reports 0-2% GPU usage and 450/1425MHz when hardware acceleration is working. When it stops working, GPU usage bounces around 2-10% and the GPU frequency jumps between 300 and 450MHz constantly.

    The constant power state changes can explain problems with GPU video acceleration that someone else had (someone else had 'Display driver recovered' problems with video playback).
     
  20. iBen95111

    iBen95111 Active Member

    Messages:
    60
    Likes Received:
    0
    GPU:
    AMD RX 480 8GB
    same exact card. so far, so good with installing only the driver via Device Manager (no CCC). Ran BF4 for about half an hour and it seems fine now.
     

Share This Page