AMD Catalyst 15.6 Beta Driver for Windows OS out now

Discussion in 'Videocards - AMD Radeon Drivers Section' started by AMDMatt, Jun 22, 2015.

  1. MatrixNetrunner

    MatrixNetrunner Member Guru

    Messages:
    125
    Likes Received:
    0
    GPU:
    Powercolor PCS+ R9 270X
    I never had this problem. And then I switched from HDMI to DVI cable connection. Then it kept happening every now and again. OS keeps working, but it can't detect the monitor.

    I changed the CPU (replaced Athlon x4 750K with A10-7870K) and it has not happened again, but it's still too early to call (Kaveri has PCIe 3.0 support so it could have something to do with this)

    For me these things work:
    - restart (obvious)
    - re-connect the DVI cable (monitor is detected as a new device, desktop icons are messed up because it probably defaults to a lower resolution without a monitor)
    - blindly set another display configuration with Win+P (press Win+P, down arrow, Enter; display is on at this point, so just return to original configuration) - someone on this forum suggested this
     
    Last edited: Jul 8, 2015
  2. rafaelluik

    rafaelluik Active Member

    Messages:
    93
    Likes Received:
    0
    GPU:
    AMD Radeon R9 280
    Nope, I have Haswell Refresh with H97 chipset (PCIe 3.0) and still experienced this black screen bug...

    I even got a BSOD while turning on my monitor yesterday.
    SYSTEM_THREAD_EXCEPTION_NOT_HANDLED fault of atikmdag.sys according to the memdump reader.

    Thanks AMD! :bang:
     
    Last edited: Jul 8, 2015
  3. Espionage724

    Espionage724 Guest

    If it is a power bug, then it only seems tied to 7 or 8.1, and non-motherboard (had it happen on 3 different boards) and GPU (had a few different 7850 cards) specific.

    I'm not sure how to narrow down the problem at all at this point, but it does seem safe to say Windows 10 is unaffected, for me anyway.

    I had a H97 motherboard that had the issue present on it as well, so it doesn't seem to be PCI-e 3.0 specific either.
     
  4. The Mac

    The Mac Ancient Guru

    Messages:
    4,408
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    i had it with a 7970 and a P67, a mobo bios update fixed it for me.
     

  5. Vinnie

    Vinnie Ancient Guru

    Messages:
    7,688
    Likes Received:
    17
    GPU:
    2x AMD R9 290X
    This thread is still a sticky?
     

Share This Page