AMD Catalyst (15.200.1012.2 March 11) Win 8.1 Mod - VSR for HD7/R7/R9 & FPS limiter

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Mar 23, 2015.

Tags:
  1. asder00

    asder00 Don Di Driver Staff Member

    Messages:
    1,193
    Likes Received:
    1
    GPU:
    RX VEGA 64 Liquid
    I'm glad you guys figured it out, thanks!

    Hey i just packed a ready to go win 7 driver (with the 3 files already signed) it should work without test mode if i remember correctly how win 7 works with modified drivers:), so install normally with Setup.exe.
    Let me know if any problem arise, you might need to enabled test mode but first please try without it.
    The VSR checkbox is under: My Digital Flat-Panels > Properties (Digital Flat-Panel) > Enable virtual super resolution
    Download HERE
     
  2. fr33jack

    fr33jack Maha Guru

    Messages:
    1,153
    Likes Received:
    3
    GPU:
    1050Ti @1.9/ 9.0GHz
    Thanks, asder00. This works just fine w/o test mode in win7.

    Bummer tho that I can't pass above 2720x1530 even with your modded drivers :( I'm so hoped to get 3840...or at least 3200. Resolutions above 2720 not even shown in res list.
     
    Last edited: Mar 27, 2015
  3. Probotector

    Probotector Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    Crossfire 290 @ 1100/1400
    Nah, same bug, constant flickering in half frame rendering in crossfire mode...

    Thx anyways :)
     
  4. Dch48

    Dch48 Ancient Guru

    Messages:
    1,822
    Likes Received:
    1
    GPU:
    Sapphire Nitro+ RX 470 4g
    I don't get why you guys are seeing that it's the 15.3 beta driver. and only v 14.5 something. When I installed the first downloaded modded file. I did it over the top of 14.12 with signature enforcement off and I got the 15.200.1012.2 as reported in Device Manager and in CCC.
     

  5. jeckop

    jeckop Active Member

    Messages:
    72
    Likes Received:
    0
    GPU:
    2xR9-290-H2O@1100/1400
    1) Mod the 15.3 march 20 version with files given by asder then enable windows test mode
    2) Uninstall previous drivers, uninstaller + DDU
    3) Run cmd.exe as admin in a window and execute the following commands:
    bcdedit -set TESTSIGNING ON
    bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS
    4) Turn off Program Compatibility Assistant via gpedit.msc:
    from CMD or run: gpedit.msc
    Computer Configuration -> Administrative Templates -> Windows Components -> Application Compatibility, and then set "Turn Off Program Compatibility Assistant" to "Enabled".
    5)Install the modded drivers (be sure to click install this driver software anyway)
    6)After the restart sign this two files C:\WINDOWS\SYSTEM32\DRIVERS\atikmdag.sys and C:\WINDOWS\SYSTEM32\DRIVERS\atikmpag.sys
    using Driver Signature Enforcement Overrider 1.3b utility - then restart!!
    7) At this point you should have driver working with its VSR at 4K but only on desktop. In order to get VSR to work pretty much in every game you should open you registry and then find every key containing this command "UserForceModeSupport_DVI_Conn_XXXX" (XXX stands for some numbers). These keys are conteined in various EDID_AC_XXXX like folders that you should export manually (they could be 7 or 8 I don't remember).
    8)Every key you exported should look like this:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Video\{CF5612AA-E23C-4282-A920-5C48E75FDD92}\0000\DAL2_DATA__2_0\Common\EDID_AC10_4072]
    "default"=hex:64
    "All_nodes"=hex:55,73,65,72,46,6f,72,63,65,4d,6f,64,65,53,75,70,70,6f,72,74,5f,\
    44,56,49,5f,43,6f,6e,6e,31,32,38,30,34,00
    "UserForceModeSupport_DVI_Conn12804"=hex:00,00,00,00,00,00,00,00

    Your numbers could differ (so change them accordingly) anyway you just need to add this code to every key exported:

    "ModeTimingOverrides_DVI_Conn12804"=hex:00,00,00,00,00,0f,00,00,70,08,00,00,3c,\
    00,00,00,0f,00,00,00,02,00,00,00,00,00,00,00,00,00,00,00,98,08,00,00,00,00,\
    00,00,80,07,00,00,00,00,00,00,58,00,00,00,2c,00,00,00,65,04,00,00,00,00,00,\
    00,38,04,00,00,00,00,00,00,04,00,00,00,05,00,00,00,7e,43,02,00,00,00,00,00,\
    00,00,00,00,00,00,00,00,00,00,00,00,02,00,00,00,01,00,00,00,00,00,00,00,80,00,00,00,a0,\
    0a,00,00,fa,05,00,00,3c,00,00,00,0f,00,00,00,02,00,00,00,00,00,00,00,00,00,\
    00,00,98,08,00,00,00,00,00,00,80,07,00,00,00,00,00,00,58,00,00,00,2c,00,00,\
    00,65,04,00,00,00,00,00,00,38,04,00,00,00,00,00,00,04,00,00,00,05,00,00,00,\
    7e,43,02,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,02,00,00,00,01,\
    00,00,00,00,00,00,00,80,00,00,00,48,0d,00,00,79,07,00,00,3c,00,00,00,0f,00,00,00,02,00,\
    00,00,00,00,00,00,00,00,00,00,98,08,00,00,00,00,00,00,80,07,00,00,00,00,00,\
    00,58,00,00,00,2c,00,00,00,65,04,00,00,00,00,00,00,38,04,00,00,00,00,00,00,\
    04,00,00,00,05,00,00,00,7e,43,02,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
    00,00,00,02,00,00,00,01,00,00,00,00,00,00,00,80,00,00,00,80,0c,00,00,08,07,00,00,3c,00,\
    00,00,0f,00,00,00,02,00,00,00,00,00,00,00,00,00,00,00,98,08,00,00,00,00,00,\
    00,80,07,00,00,00,00,00,00,58,00,00,00,2c,00,00,00,65,04,00,00,00,00,00,00,\
    38,04,00,00,00,00,00,00,04,00,00,00,05,00,00,00,7e,43,02,00,00,00,00,00,00,\
    00,00,00,00,00,00,00,00,00,00,00,02,00,00,00,01,00,00,00,00,00,00,00,80,00,00,00

    now update your registry with all the modded keys and restart and it should work!!!

    9)Last if you have far cry 4 just test it, working great at 4k and 60 frame with forced bf4 rofile!!! :)
     
    Last edited: Mar 27, 2015
  6. Probotector

    Probotector Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    Crossfire 290 @ 1100/1400
    And the flickering in crossfire mode is fixed?
     
  7. jeckop

    jeckop Active Member

    Messages:
    72
    Likes Received:
    0
    GPU:
    2xR9-290-H2O@1100/1400
    I don't have flickering at 4k, haven't tried other resolutions yet
     
  8. Probotector

    Probotector Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    Crossfire 290 @ 1100/1400
    Strange... I have two R9 290 like you and I have flickering in half of the screen with the modded drivers for win 7 by asder00

    And yes, forcing 4K resolution
     
  9. jeckop

    jeckop Active Member

    Messages:
    72
    Likes Received:
    0
    GPU:
    2xR9-290-H2O@1100/1400
    I'm on windows 8.1
     
  10. Probotector

    Probotector Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    Crossfire 290 @ 1100/1400
    And you use a DVI cable, right?

    I'm trying to find any string in regedit and not found anything....
     

  11. asder00

    asder00 Don Di Driver Staff Member

    Messages:
    1,193
    Likes Received:
    1
    GPU:
    RX VEGA 64 Liquid
    Last edited: Mar 27, 2015
  12. jeckop

    jeckop Active Member

    Messages:
    72
    Likes Received:
    0
    GPU:
    2xR9-290-H2O@1100/1400
    Working via Dvi with my monitor and also via HDMI on my plasma tv
     
  13. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    Sorry man i don't get it and can't "play" with right now, it's my turn to work, night shift here. :(

    Is this line:

    "UserForceModeSupport_DVI_Conn12804"=hex:00,00,00,00,00

    Replaced by this line?:

    "ModeTimingOverrides_DVI_Conn12804"=hex:00,00,00,00,00

    and the following hex codes starting with ",0f,...................................."?????

    I guess siimilar keys must be present under DAL2_DATA__2_0 for Dp or HDMI.
     
  14. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    asder00 thank you very much for your time! :)

    Is there any way to boot in normal mode after having 4K VSR working in 8.1 on test mode (290X here) and still have the drivers signed?
     
  15. razorbackdb

    razorbackdb Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    AMD R7 260x 2GB
    hey asder00 will these files work with the proper W10 driver?, I tried with the registry keys but it only works with 15.3 for me.
     

  16. Probotector

    Probotector Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    Crossfire 290 @ 1100/1400
    You are tested any game with crossfire enabled?

    Thanks
     
  17. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    He said:

    I think this mean:

    far cry 4 just test it, working great at 4k and 60 frame with forced bf4 crossfire profile!!! :)

    Could be wrong but i hope not. :)
     
    Last edited: Mar 27, 2015
  18. jeckop

    jeckop Active Member

    Messages:
    72
    Likes Received:
    0
    GPU:
    2xR9-290-H2O@1100/1400
    don't replace just add. In few words export all EDID folders from any DAL2_DATA you have in txt files on you desktop and then add to each one the code posted just after "UserForceModeSupport_DVI_Conn12804.........." <<< your number could differ. Then update your register with modded keys
     
  19. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    Is not only the number who differs, the sufix also could differs.

    It could be "DVI" for DVI monitor copnnection or "DP" for DisplayPort monitor connection and maybe (i'm not sure) Hdmi (or HDMI) for HDMI monitor connection.

    I searched the registry starting from the beginning the keys starting EDID_.

    The keys ending in _FF doesn't contain UserForceModeSupport_ so they don't count.

    I exported each key with name EDID_E305_2752 who contains UserForceModeSupport_DP_Conn12563 i.e my first one:

    ------------------------------------------------------------------

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000\DAL2_DATA__2_0\Common\EDID_E305_2752]
    "default"=hex:64
    "All_nodes"=hex:55,73,65,72,46,6f,72,63,65,4d,6f,64,65,53,75,70,70,6f,72,74,5f,\
    44,50,5f,43,6f,6e,6e,31,32,35,36,33,00
    "UserForceModeSupport_DP_Conn12563"=hex:00,00,00,00,00,00,00,00
    ------------------------------------------------------------------


    When this is finished i backup all exported keys (in my case 14!) and work only in the copies adding the "ModeTimingOverrides_ with my own sufix:


    DP_Conn12563

    As is:

    --------------------------------------------------------------

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000\DAL2_DATA__2_0\Common\EDID_E305_2752]
    "default"=hex:64
    "All_nodes"=hex:55,73,65,72,46,6f,72,63,65,4d,6f,64,65,53,75,70,70,6f,72,74,5f,\
    44,50,5f,43,6f,6e,6e,31,32,35,36,33,00
    "UserForceModeSupport_DP_Conn12563"=hex:00,00,00,00,00,00,00,00
    "ModeTimingOverrides_DP_Conn12563"=hex:00,00,00,0 0,00,0f,00,00,70,08,00,00,3c,\
    00,00,00,0f,00,00,00,02,00,00,00,00,00,00,00,00,00,00,00,98,08,00,00,00,00,\
    00,00,80,07,00,00,00,00,00,00,58,00,00,00,2c,00,00,00,65,04,00,00,00,00,00,\
    00,38,04,00,00,00,00,00,00,04,00,00,00,05,00,00,00,7e,43,02,00,00,00,00,00,\
    00,00,00,00,00,00,00,00,00,00,00,00,02,00,00,00,01,00,00,00,00,00,00,00,80,00,00,00,a0,\
    0a,00,00,fa,05,00,00,3c,00,00,00,0f,00,00,00,02,00,00,00,00,00,00,00,00,00,\
    00,00,98,08,00,00,00,00,00,00,80,07,00,00,00,00,00,00,58,00,00,00,2c,00,00,\
    00,65,04,00,00,00,00,00,00,38,04,00,00,00,00,00,00,04,00,00,00,05,00,00,00,\
    7e,43,02,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,02,00,00,00,01,\
    00,00,00,00,00,00,00,80,00,00,00,48,0d,00,00,79,07,00,00,3c,00,00,00,0f,00,00,00,02,00,\
    00,00,00,00,00,00,00,00,00,00,98,08,00,00,00,00,00,00,80,07,00,00,00,00,00,\
    00,58,00,00,00,2c,00,00,00,65,04,00,00,00,00,00,00,38,04,00,00,00,00,00,00,\
    04,00,00,00,05,00,00,00,7e,43,02,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
    00,00,00,02,00,00,00,01,00,00,00,00,00,00,00,80,00,00,00,80,0c,00,00,08,07,00,00,3c,00,\
    00,00,0f,00,00,00,02,00,00,00,00,00,00,00,00,00,00,00,98,08,00,00,00,00,00,\
    00,80,07,00,00,00,00,00,00,58,00,00,00,2c,00,00,00,65,04,00,00,00,00,00,00,\
    38,04,00,00,00,00,00,00,04,00,00,00,05,00,00,00,7e,43,02,00,00,00,00,00,00,\
    00,00,00,00,00,00,00,00,00,00,00,02,00,00,00,01,00,00,00,00,00,00,00,80,00,00,00

    ------------------------------------------------------

    I double checked looking for empty spaces in the hex code spaces like :00 ,00.

    The keys were added correctly to the registry but the flickering is still there.

    I guess the timings are GPU model related.

    :(
     
  20. xx4L0Mxx

    xx4L0Mxx Member

    Messages:
    44
    Likes Received:
    0
    GPU:
    2 x MSI 970GTX 4G
    I attempted the Crossfire flickering fix last night too sammarbella.

    Didn't work for me either, I still get flickering after adding the code to my registry keys.
     

Share This Page