AMD Catalyst 14.9 WHQL (14.301.1001.0 September 15)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Rich_Guy, Sep 29, 2014.

  1. mahmoud elfar

    mahmoud elfar Banned

    Messages:
    292
    Likes Received:
    0
    GPU:
    Radeon HD6750M OC 775 950
    yes it's working now

    [​IMG]
     
  2. Lokenall

    Lokenall Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    2xASUS Matrix 7970GHz P
    I wanted to try this driver out since I do play Lichdom Battlemage too. Also, I like trying out new drivers.
     
  3. Lokenall

    Lokenall Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    2xASUS Matrix 7970GHz P
    I think in the driver notes it says TDR is a known issue for this driver.
     
  4. shankly1985

    shankly1985 Master Guru

    Messages:
    502
    Likes Received:
    1
    GPU:
    RX VEGA 64
    We using different GPU's maybe the reduced temps is only for the R9 series.
     

  5. ClockClocker

    ClockClocker Master Guru

    Messages:
    408
    Likes Received:
    1
    GPU:
    970 gtx
    Nobody has a issue with that? Im afraid installing this drivers for that reason.
     
  6. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,434
    Likes Received:
    1,489
    GPU:
    GTX980 SLI
    Early days, but I can stress my card to max, stop, let the clocks drop to idle, stress it again and clocks jump back to full 3D clocks fine
     
  7. Ironjer

    Ironjer Active Member

    Messages:
    66
    Likes Received:
    0
    GPU:
    2x AMD 295X2 CrossfireX
    Maybe the ULPS is causing that. Disable it.
     
  8. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,313
    Likes Received:
    462
    GPU:
    MSI 2070S X-Trio
    Same, but im using Afterburner to switch clocks.
     
  9. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,434
    Likes Received:
    1,489
    GPU:
    GTX980 SLI
    I'm using AB, but only have a 3D OC profile, I just let idle do it's own thing and it clocks down nicely
     
  10. madorax

    madorax Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    Jetstream 970
    I'm currently using XFX R7 260X.
    in this driver, and 2 other driver before by Asder, i can't control my fan speed.
    it's just gone... in CCC the sensor is disappear, in afterburner it only display 0 without any slider.
    with GPUZ, the fan are actually running 20% on idle, and 45% on full load which is a little hot (47c on idle & 69c on load).

    BUT... if i'm using any driver below Asder release the fan are detecting fine both on CCC and afterburner.

    Anybody got this problem like me?
     

  11. sidspacewalker

    sidspacewalker New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Gigabyte Windforce R9280X
    Hi all, just wanted to let you know that these have been the best drivers I have seen from AMD in a while. Many issues have been resolved and now I can finally play State of Decay.
     
  12. wrobles3D

    wrobles3D Member

    Messages:
    36
    Likes Received:
    0
    GPU:
    HD7950-DC2T-3GD5-V2
    Thanks for the Mega link :)

    As a 7950 user stuck on 13.12 this is the first 14.x driver that has been usable for me. I had horrible lag/stutter on all the prev 14.x drivers in KCP (mpc+madvr) all of which is now fine in this WHQL release.

    I have the colour/video sections blacking out again as well ... feels more like a feature now than an issue :)

    Heat and DX9 corruption issues are also not present is this driver that I had with the other 14.x builds so for me this driver is fine.
     
  13. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,434
    Likes Received:
    1,489
    GPU:
    GTX980 SLI
    Grrr, Win key & P is still broken, STILL! After literally 15 million bug reports, and they claim they read them? Yea, ok AMD
     
  14. Seren

    Seren Master Guru

    Messages:
    297
    Likes Received:
    16
    GPU:
    Asus Strix RX570
    Why would that be a driver issue?
     
  15. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,434
    Likes Received:
    1,489
    GPU:
    GTX980 SLI
    Because it works fine in all drivers 14.4 and older, but none newer
     

  16. ckleuser

    ckleuser Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    EVGA GeForce GTX 980 Ti
    Why I can't see Mantle in BF4 ?? I did a clean install of the driver (removed old in control panel and DDU for the rest) and clean install of BF4 and update 4.... ?!?!?!!!
     
  17. S_Snake

    S_Snake New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    270x + 7870
    Thanks!
     
  18. evasiondutch

    evasiondutch Banned

    Messages:
    207
    Likes Received:
    0
    GPU:
    2x-MSI gaming 290x 4gb OC
    Removed the 14.9(unstable black screens) and back to 14.7 rc3 beta(stable no black screen).

    Ive send full report to AMD hope they do something with it?
     
  19. Kruse

    Kruse Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    XFX R9 290X 4GB
    Is it just me, or did the beta download option from the AMD site disappear? I only see the 9/29 14.9 driver available to download.
     
  20. Nymphie

    Nymphie Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    ASUS R9 290 DCU2

Share This Page