AMD Catalyst 14.9.2 BETA (14.301.1006.0 October 9)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by garikfox, Oct 24, 2014.

  1. Seth-01

    Seth-01 Active Member

    Messages:
    63
    Likes Received:
    1
    GPU:
    VTX3D R9 290 947/1250
    I have a R9 290 X Edition (not a 290x it's a 290 from VTX3D) and i tried to downclock the GPU to 800/1250 with voltage at -44 in MSI AB.

    It's a test !!!

    I locked the game at 61 fps and in very intensive MP playing never the framrate droped. Rockstable at 61 fps.
     
  2. rock1m1

    rock1m1 Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    Sapphire Trix R9 290
    Ok, I am downloading it myself. Have you tried the Siege of Shanghai map with 64 players conquest? That is when I see the biggest frame drops. Unbelievable as the game was at the very least, hardly dropped below 60 for me, but now it drops as low as 35fps at times with the 14.9 and 14.9.1
     
  3. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    MSI 980 TI Gaming
    Excellent drivers !!! I am going to keep testing.
     
  4. Seth-01

    Seth-01 Active Member

    Messages:
    63
    Likes Received:
    1
    GPU:
    VTX3D R9 290 947/1250
    you can try to delete the Mantle Cache after installing this new drivers. Maybe it can help.
     

  5. MacT

    MacT Member Guru

    Messages:
    184
    Likes Received:
    0
    GPU:
    2 x Sapphire HD 7970 OC
    What? Drops from 100 avg to 45 fps average? Or drops down occasionally to 45 fps from the 100 avg?

    Either case, I think it is not the drivers but some other issue. I only have 7970s and I don't get any sort of drops like that in DX. Unless it is a R 290 specific bug (which would see a whole lot others complaining about). Try a repair game and a re-install of the DX distributable that came with game, in case some file got corrupted.

    And curious why you would be running DX anyways? (Unless you like to record I guess.) Mantle gives a better experience.
     
  6. AmD6000

    AmD6000 Master Guru

    Messages:
    232
    Likes Received:
    0
    GPU:
    Evga GTX 960
    Thanks. that was the issue, but now i have another issue... when driver installing it gave me BSOD :bang:
     
  7. Seren

    Seren Master Guru

    Messages:
    297
    Likes Received:
    16
    GPU:
    Asus Strix RX570
    Pretty poor drivers for me, on monitor idle the screen stays black (doesn't completely lose the connection like it's done in previous drivers. This happens EVERY time. I have to disconnect and re-connect the DVI cable.
    Driver has ~"use alternate dvi method" ticked by default (will test later if turning off fixes it).
    CCC crashed on start-up (first time in a year I think) and text is extremely blurry.

    Wish I stayed on the OpenCL 2 driver modded by Asder, I only got the black screen bug every 5 or so days on that one.

    EDIT: Un-ticking "use alternate dvi method" doesn't seem to do anything.
     
    Last edited: Oct 26, 2014
  8. Trevonn

    Trevonn Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    HD 7790 2GB @ 1.2/1.6 GHz
    Both of my monitors sometimes go completely black when I use the Windows Extend Display Function to enable the second monitor. After this there's nothing I can do but restart the computer. It doesn't happen all the time maybe 10% of the time I use the Extend Display Function. This problem has plagued me since the very of the 14.X series I think. Has anyone else experienced this?
     
  9. Nurmi

    Nurmi Member Guru

    Messages:
    140
    Likes Received:
    0
    GPU:
    R9 Fury Tri-X
    I have both the Hynix and the other R9 290's and I haven't had any real issues with either of the cards, and the only driver what has caused me any issues is the very first one from the last March, which caused me to get same performance with my earlier HD 5850 Toxic 1GB.

    Battlefield 4 has seriously degraded to the point where its not anymore possible to play it with my older 5850, even though I used to run it at medium 30fps. Not to mention about the Mantle leak around third or fourth match, which causes my rig to take 100fps sinks and at that point its not anymore even possible to fire any of the weapons.

    ..lastly, I did give my little brother BF4+Premium as an Xmas gift, and then few months later the older 5850. But now the whole gift combo feels so stupid joke that I'm not even sure that should I laugh or be angry about the whole thing, because he haven't even been able to actually play the game for most of the year. :bang:
     
  10. rock1m1

    rock1m1 Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    Sapphire Trix R9 290
    Yes, the performance drop is really bad. Mantle gives better performance though I don't want to use it because: I can't record, and I can't use SweetFX. The Catalyst 14.4 drivers gives much better performance in Battlefield 4.
     

  11. rock1m1

    rock1m1 Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    Sapphire Trix R9 290
    @Seren and @Trevonn, the display going black being idle is a known issue. Just out 14.9 release notes and check the 'known issues' list. Over there it is written:

    [404660]: GPU gets stuck in a low power state after it was previously stressed to max power

    So it happens if the GPU is previously stressed to max power, like playing a game. It should not happen if you didn't play any game.
     
  12. boombastik

    boombastik Master Guru

    Messages:
    346
    Likes Received:
    62
    GPU:
    rx580 Pulse 8Gb
    Can anyone confirm this ? (only with cards gc 1.1 architecture 7790 or 260x)
    With theese drivers if i have in cod ghosts v sync on, every time multiplayer changes a map i crash with this error:
    [​IMG]
     
  13. Octopuss

    Octopuss Master Guru

    Messages:
    860
    Likes Received:
    71
    GPU:
    -
    Why are you guys talking about BF4 when nothing even remotely related to it is mentioned in the changelog?
     
  14. rock1m1

    rock1m1 Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    Sapphire Trix R9 290
    Ok, I tried the drivers with BF4. The DX performance is the same, however, the Mantle performance improved a lot. I am reaching the ceiling FPS of 120 most the time, amazing. Wish DX was close to this, right now there is a huge gulf of difference between DX and Mantle for my card.

    I think Nvidia cards perform much better in DX mode for BF4.
     
  15. Eesi

    Eesi Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    Gtx 1080 H2O
    I've got 2x 480 rads and my load temps are always in the area of about 50c and have always been. For me oc didn't change with 14.9.2
     

  16. Tronman

    Tronman Member Guru

    Messages:
    102
    Likes Received:
    0
    GPU:
    XFX 295x2
    Hey mate check what DM789 said.. the drivers are actually separated even though from the main page if you select win 7 the download will be for 8.1. Same thing happened to me accidentally installed win 8.1 drivers which then don't show up in the install.

    Seriously AMD wtf :bang:
     
  17. velocityx

    velocityx Master Guru

    Messages:
    310
    Likes Received:
    0
    GPU:
    EVGA 1080 Ti FE - EK FCB
    because since july, mantle multi gpu in bf4 is broken. overall performance of the game both dx11 and mantle is bad and driver picky since july.
     
  18. Seren

    Seren Master Guru

    Messages:
    297
    Likes Received:
    16
    GPU:
    Asus Strix RX570
    This happens EVERY time. Doesn't matter if I idle or not. In-fact it happened straight after booting up the first time after installing the driver where it was just left idle...
     
  19. thesheriff

    thesheriff New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    AMD HD6630M
    May this be an offtopic but still missing fix for Diablo 3 crash? Blizzard admin suggests reverting to 13.x drivers which is no a reasonable option.

    More info: eu.battle.net/d3/en/forum/topic/9887929133
     
  20. rock1m1

    rock1m1 Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    Sapphire Trix R9 290
    Do you use have Windows 8/8.1 by any chance? I used to have black screen right after booting from proper shutdown, it was related to Fastboot. I went to the Windows power options and disabled fastboot, after that I no longer have this issue.
     

Share This Page