AMD Catalyst 14.9.2 BETA (14.301.1006.0 October 9)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by garikfox, Oct 24, 2014.

  1. hallryu

    hallryu Don Altobello

    Messages:
    11,386
    Likes Received:
    14
    GPU:
    2x HD7970
    Enough.
     
  2. Seren

    Seren Master Guru

    Messages:
    297
    Likes Received:
    16
    GPU:
    Asus Strix RX570
    Hmm... When I set power options to balanced, I haven't got any black screens. I just set it to performance when I go to game, beats having to replug the cord every-time I want to use the computer after a break.
     
  3. PhoenixRed

    PhoenixRed Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    Asus GTX 980 Strix
    Could the black screen issues be something to do with pci-e power savings?
     
    Last edited: Oct 31, 2014
  4. sekta

    sekta Master Guru

    Messages:
    200
    Likes Received:
    0
    GPU:
    Nvidia GTX 1080
    Never had any problems in about a year. Don't know what's wrong with you guys getting freezes, black screens, etc. Every driver this far has ran fine, no different than the last.
     

  5. Octopuss

    Octopuss Master Guru

    Messages:
    863
    Likes Received:
    71
    GPU:
    -
    That's what I was thinking for the past ten years. Until now.
     
  6. reinaldocfilho

    reinaldocfilho New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    R9 280x 3GB
    I can't install this driver, I always do the DDU steps perfectly to uninstall a driver before installing a new one, the last one that worked it the 14.9.1 BETA, the 14.9.2 BETA simply doesn't install the driver, it starts the install, the green bard fills up, but no driver is installed, it doesn't ask for reboot and it clearly tell me that the installation was succesful.

    Tried without the DDU too, no deal.

    Is it really compatible to R9 280x?
     
  7. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    ditto.
     
  8. tiptop

    tiptop Member

    Messages:
    19
    Likes Received:
    1
    GPU:
    Sappire RX Vega 56
    reinaldocfilho, the drivers are different for Win 7 and Win 8.1. Are you sure you're using the proper installer?
     
  9. Gapster

    Gapster Active Member

    Messages:
    75
    Likes Received:
    0
    GPU:
    2xSapphire R9 290x Tri-x
    I do not have a check in the CrossfireX tab that disables Crossfire in not supported applications. So for every game that have no CFX profile I need to create my own profile to disable CFX. Is there a bug or everyone do not have that check?
     
  10. caleb59

    caleb59 Member Guru

    Messages:
    164
    Likes Received:
    6
    GPU:
    MSI GTX 1070 X 8GB
    Evolve Big Alpha low performance on 1680x1050, high details, AA off, Tessellation off, vsync off...

    Maybe it's not optimized yet but on the other hand Crysis 3 runs smooth like hell on high details!
     

  11. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,562
    Likes Received:
    1,629
    GPU:
    ROG Strix 1080 OC
    Maxed out, Evolve ate all my vRAM and still stuttered, it needs a lot of work
     
  12. freeman94

    freeman94 Master Guru

    Messages:
    309
    Likes Received:
    5
    GPU:
    MSI GTX 1070 ARMOR
    Hymm, maxed, with SMAA 1TX and it sometimes it stutter, but overall it's very playable. I suppose the game stutters because my VRAM is filled up.
    But, the game isn't for me, I don't like it so, I won't be playing it. Just for testing...
     
  13. kakarot

    kakarot Maha Guru

    Messages:
    1,108
    Likes Received:
    0
    GPU:
    evga 980ti sc+
    Hey guys, has anyone ever run in to a cfx issue that when you enable it, it kills one of the hd audio devices? I am on a clean install of 8.1 and when I enable cfx one of the high def audio controllers pops an error 10 (device cannot start) and goes away the second i disable cfx..
    Any ideas? I haven't run cfx since the 5970 days
     
  14. PhoenixRed

    PhoenixRed Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    Asus GTX 980 Strix
    Yep happens to me unless I disable ULPS, then it starts just fine.
     
  15. kakarot

    kakarot Maha Guru

    Messages:
    1,108
    Likes Received:
    0
    GPU:
    evga 980ti sc+
    Thanks, that did the trick
     

  16. PhoenixRed

    PhoenixRed Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    Asus GTX 980 Strix
    No worries :)
     
  17. PNeV

    PNeV Ancient Guru

    Messages:
    2,069
    Likes Received:
    2
    GPU:
    MSI GTX 1070 Armor
    Every driver since 14.4 WHQL gives me an issue where my monitor does not wake up from sleep. I have to hard reset it everytime because the monitor does not wake up. Going back to 14.4 and the problem goes away. Guess I am staying put, does anyone else have this happen?

    Perhaps its just a niggle in my setup somewhere (I run the default "Balanced" power options in Windows).
     
  18. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,562
    Likes Received:
    1,629
    GPU:
    ROG Strix 1080 OC
    iirc it will wake up, but it takes a stupidly long time, according to AMDs driver issues notes a while ago for one of the betas

    I just disable PC sleep and monitor sleep
     
  19. caleb59

    caleb59 Member Guru

    Messages:
    164
    Likes Received:
    6
    GPU:
    MSI GTX 1070 X 8GB
    I've noticed massive random flickering in Condemned Criminal Origins...
     
  20. Leito360

    Leito360 Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    Sapphire RX480 Nitro+
    I just had the same issue for the first time... I don't know if roll back to 14.4 or to the goode olde 13.12
     

Share This Page