1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AMD Catalyst 14.7 RC3 (14.200.1004.0 August 11)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Aug 14, 2014.

  1. kpo6969

    kpo6969 Master Guru

    Messages:
    587
    Likes Received:
    0
    GPU:
    MSI GTX 1070 Gaming
    same here


    try these (I'm satisfied):

    http://forums.creative.com/showthread.php?t=709286&
     
  2. Romulus_ut3

    Romulus_ut3 Master Guru

    Messages:
    668
    Likes Received:
    138
    GPU:
    AMD RX 570 4GB
    I don't have one single issue and I am using two different AMD video cards on the same pc.

    I haven't had the BSOD that some of you mention while browsing and keeping the hardware acceleration on, same goes for flash videos.

    I don't have any DX9 corruption whatsoever, maybe if some of you pirated game junkies (if you own the legit games then I apologize) bothered to download the patch that got released after the game, you may not have to face such issues. And also, any customized global settings made to the game profiles like forcing certain AA methods, or just setting the texture filtering manually from CCC can produce such bugs.

    I don't have any of these overclocking utilities installed on my PC. I had Sapphire TriXX installed, and it caused a driver crash immediately. I set my PowerTune and Engine Clocks from CCC and it does the trick for me. I had this friend who had random driver crashes and it turns out, ASUS' GPU Tweak utility was causing problems at his end. Once it was removed, no problems whatsoever. I would also like to mention that my HD 7850 is either mining constantly @1100/1250 and HD 7950 is mining @1150/1250/20 and when a card is not mining, it's being used for gaming. I haven't faced the temperature increase as some of you have mentioned whatsoever. I am not saying the problems don't exist, what I am saying is the problem lies somewhere else and it just isn't the drivers.
     
  3. DM789

    DM789 Master Guru

    Messages:
    435
    Likes Received:
    0
    GPU:
    ???
    i'm guessing you are noobs,

    PC Gaming Rules :
    1. if an issue happens to you, it doesn't meant it happens to others.
    2. if you don't have an issue, it doesn't meant that others doesn't have it.
    additional rule : never accused someone you don't know of pirating.

    besides the DX9 corruption doesn't happens to all DX9 games.

    and i'm guessing you really are a newb, because it seems you can't read that by reverting to previous driver (ex : 14.4), the texture corruption dissapear.

    and the temporary workaround is by using a certain DLL files, from 14.4, by copying it to the folder where the exe is, and then run the game, then the textures corruption will be gone.

    i think my post have prove that its not about piracy, but its about lately AMD drivers S.U.C.K.S.

    heck my idle temp even raised from 29C @14.4 to 32-33C @14.7 RC3.

    so far i've tried ETS 2, and there is no DX9 corruption in it,

    but the artifact is still happening on Flatout.

    haven't tried other games yet.
     
  4. BoobZ

    BoobZ Active Member

    Messages:
    51
    Likes Received:
    0
    GPU:
    XFX r9 290 DD
    Heat mainly affects R9 290 cards
     

  5. DM789

    DM789 Master Guru

    Messages:
    435
    Likes Received:
    0
    GPU:
    ???
    well, it affected me,

    i only mentioned idle temp, because i only pay attention to idle temp,

    and higher idle temp = higher load temp.

    and i didn't know how much it affected my load temp, because when i'm in the middle of gaming, i didn't pay any attention to my temp.
     
  6. Valagard

    Valagard Maha Guru

    Messages:
    1,181
    Likes Received:
    0
    GPU:
    EVGA GTX 1080 FE
    With my 7970, I've gone from 52c average with my card to 44C average idle, same overclocking settings.

    Wattage draw from the wall is also down 14 watts, I'd measure games but right now I'm encoding something.
     
  7. yelsewshane

    yelsewshane Banned

    Messages:
    1,591
    Likes Received:
    0
    GPU:
    Sapphire VaporX 290
    Honestly I don't get thou problems! I have many games from dx9 to dx11 all run perfectly. I also have many movies I link via to my TV and all works perfect. I never have issues with either of my machines which one has a amd 290 and another NVidia 780ti. Obviously from my point I think you guys that complain simply don't know how to install/uninstall drivers correctly. Anyways had to say this again something is wrong with you people either don't know how to install drivers correctly or you are overclocking and getting errors etc. I don't know wtf you guys doing but for most users everything is good I think you need to look into the mirror and go I am a DUM* A**
     
  8. b2rdark

    b2rdark Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    7870 XT
    Teach me master...
     
  9. MacT

    MacT Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    2 x Sapphire HD 7970 OC
    F*** consoles. I hope it is the case that all of the AMD driver team are over at EA fixing the BF4 Mantle crossfire that the Dice Tossers (see what I did there?) broke last patch!! I mean, flagship Mantle showcase broke for crossfire power users for month now. Way to go.

    Have to give these RC3 a go. Hope that temp issue is not with 7970 cards. Tropics + no air conditioning means even normal temps can become an issue.

    Side note, would be fun to watch Sony implement Mantle and M$ cringe cause they won't/can't touch Mantle (with their DX12 round the corner).
     
  10. snip3r_3

    snip3r_3 Ancient Guru

    Messages:
    2,985
    Likes Received:
    0
    GPU:
    1070
    There is a list of affected DX9 games, most of them are running on some sort of CryEngine (1,2,3 are all affected). Other than CE games, GTA series (3, VC, SA, 4), NFS Shift 2, Max Payne 2, TDU 2 are the ones reported so far in the forums. Why is this a driver issue 100%? Because you can fix it by adding in two dlls from older drivers, or you know, roll back to pre 14.4.
    http://forums.guru3d.com/showthread.php?t=391527

    Please don't label your thoughts onto other people just because your system doesn't have any problems. No one claims that ALL DX9 games are broken, just a pretty decent number of them are, and as you may not know, people actually play different games than you from time to time.

    There are plenty of usage scenarios that can result in bugs that another user may never encounter, it all depends on the system configuration as well as the rest of the hardware. I personally have black screen bugs on both 7950s since I had them, it persisted through clean installations and even an entirely different platform (Intel X58/AMD A85X). There are simply just flaws in both hardware and software that exist (DVI issue with 7 series and Zerocore if rumors are correct). Saying all the problems reside in the users is as ignorant as blaming every world issue on the president. It isn't if there was a magical driver installation method other than clicking next during a clean install of Windows now is it?
     
    Last edited: Aug 16, 2014

  11. undeadpolice

    undeadpolice Master Guru

    Messages:
    203
    Likes Received:
    0
    GPU:
    EVGA GTX980 K|NGP|N (SLI)
    Well about 100 years ago there were voodoo cards and it has close to prefect drivers
     
  12. pato9

    pato9 Member

    Messages:
    41
    Likes Received:
    8
    GPU:
    GTX 1070
    Can anyone tell if the black screen bug has been fixed? worth upgrading to this?
     
  13. Octopuss

    Octopuss Master Guru

    Messages:
    876
    Likes Received:
    53
    GPU:
    -
    What black screen bug?
     
  14. DM789

    DM789 Master Guru

    Messages:
    435
    Likes Received:
    0
    GPU:
    ???
    i still remember my voodoo 2 card, it was awesome at the time,

    too bad voodoo is gone for good.
     
  15. Anonizer

    Anonizer New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    AMD R9-270X
    I think so, left my computer idle for 2 hours straight, usually when I get back I experience that problem where I can't make my monitor "wake up" by pressing buttons/moving my mouse.

    Or you're talking about other black screen bug?
     

  16. kidsafe

    kidsafe Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970 3GB
    With all these RC drivers, I have some sort of display sleep bug where if Windows decides to put the monitor to sleep, the monitor is no longer detected at all via DisplayPort until I turn the monitor off and on again. When I do this, all the contents of my display shift over to the top left corner because it has switched to presumable 800x600 while the display was undetectable. I don't have other cable types to test, but this doesn't happen at all with the official release drivers.
     
  17. Octopuss

    Octopuss Master Guru

    Messages:
    876
    Likes Received:
    53
    GPU:
    -
    I am using 14.4 and this was happening to me all the time with Displayport. Had to switch to DVI. Now it only takes 2 years for the monitor to wake up. Is that the bug everyone is talking about? If yes, it's probably a lot older than 14.7 betas.
     
  18. waltc3

    waltc3 Maha Guru

    Messages:
    1,001
    Likes Received:
    294
    GPU:
    AMD 50th Ann 5700XT
    Finally! I've been reading through this thread chuckling because everyone bitching about it failed to notice AMD had screwed up the links and only the July driver was still up!...;) My post about that is waaaa-a-a-a-ay back in the thread--but you saw it was last month's driver, too! Heh...;)

    This morning (Saturday) everything had been straightened out and the August RC3 driver is actually up, now, and I just finished installing it. According to the custom install information, the only file differences between the 14.7RC1 and the newer 14.7RC3 are the transcoding and the CCC version numbers--everything else reads, "Already installed and up-to-date," including the gpu driver.

    So, even though the number has been correctly changed, this is still mostly RC1, anyway, it would appear...

    Sometimes I think I might be the only guy who uses the custom install routine and actually looks at the files before installing them to see what's new and what's not...;)
     
  19. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,364
    Likes Received:
    1,438
    GPU:
    GTX980 SLI
    The new driver always worked from the same link my end, never took me to the old one even when people were saying it did
     
  20. waltc3

    waltc3 Maha Guru

    Messages:
    1,001
    Likes Received:
    294
    GPU:
    AMD 50th Ann 5700XT
    I don't have the problem with display port (mini 1.2)--I don't think. I'm going to check it again, however.

    It's fine...just took it in and out of sleep three times without a problem. You using any kind of adapter of any sort? (probably not, but that's all I could think of that might cause a problem in that regard.)
     
    Last edited: Aug 16, 2014

Share This Page