AMD Catalyst 14.6 RC2 (14.200.1004.0 June 20)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Jun 24, 2014.

Tags:
  1. Soldaten

    Soldaten Master Guru

    Messages:
    416
    Likes Received:
    0
    GPU:
    eVGA GTX 960
    Last driver update before I upgrade my card. works fine
     
  2. Valagard

    Valagard Maha Guru

    Messages:
    1,181
    Likes Received:
    0
    GPU:
    EVGA GTX 1080 FE
    State of Decay, various emulators etc all have problems with this driver, same as the last one

    Amazing how so many people report problems with the last drivers, they take over a month, and then not fix them

    Even I'm at a loss for words here
     
    Last edited: Jun 25, 2014
  3. Plug2k

    Plug2k Maha Guru

    Messages:
    1,491
    Likes Received:
    8
    GPU:
    2x Gigabyte Fe 1080TI +WB
    i got that very same BSOD LOL
     
  4. risemix

    risemix New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    ATI 6550M HD 1g
    Has anyone managed to make these install on laptops that use switchable graphics? I play Wildstar and I've been waiting for these improvements for a while...

    Cheers.
     

  5. ToBbErT

    ToBbErT Member Guru

    Messages:
    154
    Likes Received:
    0
    GPU:
    2x sapphire 7870
    Still no cf profile for wildstar.....
     
  6. Espionage724

    Espionage724 Guest

    Works fine on my 7660G + 7670M dual graphics laptop; I hear 6xxx hardware is usually problematic though...
     
  7. WolfPT

    WolfPT Active Member

    Messages:
    96
    Likes Received:
    0
    GPU:
    ROG-STRIX 1080Ti
    I am STILL getting BSOD's when using HTML5 player or flash videos, god damnit AMD, even after a clean install so it's not the unnistall of the previous drivers that is screwing it up. Get your sh*t together AMD.
     
  8. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,381
    Likes Received:
    493
    GPU:
    MSI 2070S X-Trio
    Haha :D

    Im back on the Beta 1s, as lost about 20/30 frames on the minimums with these, not good.
     
    Last edited: Jun 25, 2014
  9. Turban

    Turban Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    Gb R9 290 OC
    Hey guys...

    I'm having the black screen problem.. only 13.12 seem to "work" (still get "driver stopped working" once in a while)

    Currently running 14.6 beta with a 520/625 profil on Afterburner only way to have it "stable"... any chance these RC2 solved the black screen issue ?

    Otherwise I'm thinking of RMAing my card... althought that s*cks .. don't think it's fair to pay that amount of money to have a half working GPU ...

    Was hoping those black screens were driver related, but since AMD isn't coming with a fix..I'm getting tired of waiting..

    So.. any improvement with the RC2 ?

    Cheers ;)
     
  10. Corthalis

    Corthalis New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    2x 980Ti Lightning
    if you're getting "driver stopped working" throughout different driver versions it's generally a GPU problem or RAM.
     

  11. Felix

    Felix Member Guru

    Messages:
    189
    Likes Received:
    0
    GPU:
    AMD 280X
    Are you uninstalling you drivers correctly before instaling the next one?
     
  12. Turban

    Turban Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    Gb R9 290 OC
    Yep... I've tried everything... DDU in safe mode, all of that...

    As last resort I'll try the AHCI driver thing, but as someone noted in another thread, you can't go from AHCI to IDE if Windows was installed that way..so .. not an easy fix..

    Was really hoping the a solution would come from AMD.. call me lazy :p
     
  13. Felix

    Felix Member Guru

    Messages:
    189
    Likes Received:
    0
    GPU:
    AMD 280X
    Because it's just extremely weird that only the 13.12 works. Every driver forward should work with your card. Do you have a friend or a contact nearby with a similar card? Try swapping them and see if it still doesn't work. If it still happens, it's a problem somewhere else, a conflict in your build. (Which still, doesn't make sense at all)

    14.6 RC2 working smoothly here so far.
     
  14. Turban

    Turban Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    Gb R9 290 OC
    Drivers after 13.12 "work", but then I get heaps of black screens, freezes and such, always end up doing hard-resets , it's extremely annoying.

    Under full load everything is totally stable. When I create an Afterburner profile to lock the frequencies, everything is stable. (Except on cold boot when Afterburner doesn't start).

    As soon as I leave the card on it's own, it ends up crashing. Extremely annoying.

    I just reverted the AHCI driver, still no improvement.

    I don't know anyone with the same card/config, so can't try. But without the card, just on the APU, system works great.

    It's very frustrating as it is hard to decide if I should RMA or not. Not clearty a faulty card, but not clearly a working one either...

    Damn it...
     
  15. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,381
    Likes Received:
    493
    GPU:
    MSI 2070S X-Trio
    They'll be in the next Beta id have thought, as the next official build will be the 14.9s, as don't they now do the WHQLs every 3 months ?
     

  16. Romulus_ut3

    Romulus_ut3 Master Guru

    Messages:
    670
    Likes Received:
    138
    GPU:
    AMD RX 570 4GB
    If the specs on your profile is correct, your PSU is insufficient for the R9 290.
     
  17. The Mac

    The Mac Ancient Guru

    Messages:
    4,408
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    Whenever they feel like it, its been every 3 months latelty but it doesnt have to be.

    I would guess they will do a WHQL for 14.7 as this is an RC
     
  18. Espionage724

    Espionage724 Guest

    I have a 7850, and haven't had a BSoD with browser video playback since some earlier 14.* beta; RC1 was fine, haven't tested these drivers.

    Do you have the R7850 Power Edition 2GD5/OC?
     
  19. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,381
    Likes Received:
    493
    GPU:
    MSI 2070S X-Trio
    This one will be re-upped again, but with the WHQL certificate once it comes back though won't it ?
     
    Last edited: Jun 25, 2014
  20. The Mac

    The Mac Ancient Guru

    Messages:
    4,408
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    thats what im implying.

    They could release a RC3 before they send it in for certification however, but id guess it would be a 14.7 RC1
     

Share This Page