AMD Catalyst 14.4 WHQL (14.100.0.0 April 17)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Apr 25, 2014.

Tags:
  1. Derko1

    Derko1 Master Guru

    Messages:
    408
    Likes Received:
    0
    GPU:
    2x1080s
    Anyone have Dead Island or Riptide and can confirm that they get very bad performance? I am only getting around 30-40 fps with my system. I remember getting in the 100s before.
     
  2. Dch48

    Dch48 Ancient Guru

    Messages:
    1,822
    Likes Received:
    1
    GPU:
    Sapphire Nitro+ RX 470 4g
    I always do the custom install but wind up letting most , if not all, things install. I decided to install the Gaming Evolved app this time because I figured it would have benefits for my new R9 GPU. Well, after installing and opening it up, I found that none of my games had available settings and some weren't even supported at all. I uninstalled it and will never try it again. I did not get the AHCI issue but maybe I got the package that already had removed it.
     
  3. Dch48

    Dch48 Ancient Guru

    Messages:
    1,822
    Likes Received:
    1
    GPU:
    Sapphire Nitro+ RX 470 4g
    Hmmm. Device manager says my driver version is 14.100.0.0 with the 4/17 date but CCC reports it as 14.10.1006. Curioser and curioser.
     
  4. N0bodyOfTheGoat

    N0bodyOfTheGoat Member Guru

    Messages:
    192
    Likes Received:
    0
    GPU:
    Sapphire Nitro R9 390 8GB
    I don't think I have ever installed AMD drivers through Device Manager before, but I will give it a go.

    Do I need to turn signature enforcement off and then try to install the drivers, or should I be able to install and then turn enforcement on future boot ups?

    This will only be a quick proof of concept test on my pc, the 7850OC I would like to try a 14.x driver with is on my better half's older and weaker pc.
     

  5. Espionage724

    Espionage724 Guest

    I'd just try installing it without messing with signature enforcement, but if it complains about lack-of signing, then disable it and then try it again.

    I think once the driver is installed, you don't have to disable enforcement again, but I could be wrong.
     
  6. NiColaoS

    NiColaoS Master Guru

    Messages:
    631
    Likes Received:
    44
    GPU:
    GTX 1660 SUPER
    I've miss a lot of reading of this topic. I've been meaning to ask, sometimes the monitor goes off for a split second... It's not usually a problem.

    Are the 14.4 drivers the culprit? Anyone else with same symptoms?
     
  7. MacT

    MacT Member Guru

    Messages:
    184
    Likes Received:
    0
    GPU:
    2 x Sapphire HD 7970 OC
    Espionage724,
    The whole point I am trying to make is MOST peeps have no idea. They think they are updating graphics drivers ONLY because that is where they are directed to when searching for AMD Display Drivers. They don't read the release notes to check for extraneous material included in the package. They express install because that is the easy way. And then sh*t happens that is unrelated to graphics driver issues and they have no clue what to do.

    Just saying AMD should have kept this Catalyst Software Suite for their display driver updates (which is all it was a long time ago).
     
  8. BugMeister

    BugMeister Member Guru

    Messages:
    166
    Likes Received:
    1
    GPU:
    2x RX480 NITRO+OC(8G)
    I have to agree with MacT on this one..
    AMD should have posted much clearer guidance..
     
  9. MaidenFred

    MaidenFred Active Member

    Messages:
    85
    Likes Received:
    1
    GPU:
    980ti GE Lightning mod
    too many problems with 14.4

    With this new driver, BF4 crashes also for me with Mantle activated.

    Moreover, I don't know why but my config now takes a minute to shutdown or restart.

    Rolled back to 14.3 beta 1 and no more issue...

    Very strange !

    Edit: slowdowns with 14.3, no problem with 14.2 beta 1.3
     
    Last edited: May 5, 2014
  10. NiColaoS

    NiColaoS Master Guru

    Messages:
    631
    Likes Received:
    44
    GPU:
    GTX 1660 SUPER
    Set it once at Full RGB and immediately do a reboot. Only with this way it will keep the settings. This bug is at least 2 years old. And at the end of the day, since we use monitors, why is being set to YCBCR crap in the first place... As it seems can't even distinguish a monitor to a TV.
     
    Last edited: May 5, 2014

  11. Coldblackice

    Coldblackice Member Guru

    Messages:
    125
    Likes Received:
    0
    GPU:
    Sapphire 290X
    Does anyone know the logistics of how it works between AMD's refinement of Mantle vs. refinement of DirectX support?

    It was my understanding that the DirectX module of the drivers has basically stayed the same since the first Mantle driver, with AMD obviously not giving it any focus because of the Mantle-love. TheMac said otherwise, however.

    So is DX support getting improved with each Mantle-driver release, or no?

    Interesting. Never knew that. Thanks!
     
  12. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,492
    Likes Received:
    1,541
    GPU:
    ROG Strix 1080 OC
    Ah ok thanks, I`ll give that a shot, yea its a PITA
     
  13. Espionage724

    Espionage724 Guest

    All anyone else can do is speculate at this point... but I'm pretty sure AMD isn't going to abandon DirectX (nor OpenGL) updates.

    Mantle is meant to be a companion graphics API, not to be exclusively used (although it could be). Thus, there needs to be a main renderer still, either DirectX (most likely choice), or OpenGL.

    Also, although I can't confirm it, didn't both the DX and OGL .dll libraries get their versions changed with each (or at least with certain) beta driver update(s)? I know OGL got a version update between 14.4 and 14.4 RC1.
     
    Last edited by a moderator: May 6, 2014
  14. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,586
    Likes Received:
    604
    GPU:
    MSI 2070S X-Trio
    Just a heads up. :)

    They got pulled and then re-upped, faulty chipset drivers.

    http://forums.guru3d.com/showthread.php?t=388932
     
  15. Felix

    Felix Member Guru

    Messages:
    189
    Likes Received:
    0
    GPU:
    AMD 280X
    How did that pass through WHQL is beyond me.
     

  16. Espionage724

    Espionage724 Guest

    WHQL doesn't mean rock-solid stability across all platforms, it's just a way for Microsoft to get some extra money from OEMs, along with causing hassle for power-users. Although I guess it could legitimately help in-regards to security if anything.

    Generally speaking though, this was a pretty harmless driver mishap. It affected a small amount of older chipsets, and didn't go off destroying hardware.
     
    Last edited by a moderator: May 6, 2014
  17. DiceAir

    DiceAir Maha Guru

    Messages:
    1,351
    Likes Received:
    14
    GPU:
    Galax 980 ti HOF
    Yeah and one of my clan mates trying to argue installing beta is always a problem. They would rather wait 5 months to a year for new drivers. He think BETA is more buggy than WHQL yet WHQL can also have issues. So be it at least I'm happy with beta drivers so far. I'm not even running this whql cause it's the same as 14.4 RC1 and so makes it useless having to overclock my monitor again and so on when there is like 0 difference as far as I know
     
  18. kcuestag

    kcuestag Master Guru

    Messages:
    904
    Likes Received:
    0
    GPU:
    Gigabyte GTX980Ti G1
    I get a BSOD on these when I'm gaming and I minimize (Or change window in windowed mode) and open a youtube video from Twitter, happened twice already.

    I'll roll back to 13.12 WHQL and wait for more stable drivers, these are not good at all.

    [​IMG]
     
  19. sapo_joe

    sapo_joe Master Guru

    Messages:
    586
    Likes Received:
    20
    GPU:
    EVGA GTX1070FTW 8GB
    Since BIOS update and I'm not messing with the video quality page on CCC, my system is rock-stable with these drivers.

    But it's time to release 14.5 already!!! C'mon AMD!!
     
  20. JaxMacFL

    JaxMacFL Ancient Guru

    Messages:
    1,708
    Likes Received:
    1,061
    GPU:
    EVGA 3090 FTW3 ULTR
    Just installed the 14.4 WHQL and was having a rough time with them. I originally installed everything but the gaming app. They just wouldn't take. Keep getting a CLIStart.exe error about an ati driver that wasn't right for my os. Finally did another clean uninstall with ddu. This last time along with not installing the gaming app I didn't install the acp app either. Everything went smooth as butter.:)
     

Share This Page