AMD Catalyst 14.4 (14.100.0.0 March 27)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by CPC_RedDawn, Apr 11, 2014.

  1. undeadpolice

    undeadpolice Master Guru

    Messages:
    203
    Likes Received:
    0
    GPU:
    EVGA GTX980 K|NGP|N (SLI)
    its not about whether you are having issue or not alone, its about everyone else as well, dun try to cover AMD.
    As the more you try to cover "Ohhh this is user problem nothing gonna do with the driver and hardware" the more AMD overlook the issue. And the more whatever bugs remains = more pissed off AMD users and they will jump ship.

    This drivers are unstable & they ever never mean to release to the public, not even for testing. I try it on titanfall and the flicking issue got worst
     
    Last edited: Apr 16, 2014
  2. KBDE

    KBDE Master Guru

    Messages:
    217
    Likes Received:
    26
    GPU:
    R290 4gb
    Yes and i can add the following games:

    NFS rivals (with 60fps)
    FarCry 3 (dx9 and dx11 exe)
    FarCry 3 Blood Dragon
    Shadow warrior
    Simcity
    State of Decay
    Thief
    GTA IV
    and there are more i've tried to play recently but ended up disabling crossfire.

    But it has to be said that some run good:
    Bioshock Infinite
    Battlefield 4 with mantle + framepacing console tweaks
    Battlefield 3
    Tombraider
    Metro Last Light



    The thing i noticed is that the 290's are very PCI-E bandwidth/latency sensitive. Very noticable in farcry3 dx9 , nfs rivals
     
  3. Noisiv

    Noisiv Ancient Guru

    Messages:
    8,186
    Likes Received:
    1,453
    GPU:
    2070 Super
    what the heck... 14.3 is still the latest driver on AMD driver download page

    I purposely waited for things to calm down, but 14.4 is still a no go according to AMD
     
  4. signex

    signex Ancient Guru

    Messages:
    8,823
    Likes Received:
    176
    GPU:
    Asus TUF RTX 3080
    I get BSOD's when using YouTube on Chrome, and texture corruption.

    BSOD's don't happen often though.
     

  5. windrunnerxj

    windrunnerxj Master Guru

    Messages:
    439
    Likes Received:
    97
    GPU:
    MSI Gaming 1060 6G
    Are you using Windows 8.1 Update 1 by any chance?
     
  6. xxela

    xxela Master Guru

    Messages:
    231
    Likes Received:
    8
    GPU:
    RX6800 XT Red Devil
    This is strange. I had that kind of problems but they disappeared after some chrome/flash updates.I thought that they fixed this problem for all configuration. Now I have Chrome beta version ( 35.0.1916.27 ) with PPAPI flash 13.0.0.182 enabled ( no flash player plugin installed). Also I run W8 update1. Try with this chrome version maybe you have more luck.
     
  7. Espionage724

    Espionage724 Guest

    This isn't a AMD report thread... I'd almost even question if AMD bothered to read feedback on this forum. If a user really wants their bug report heard, they would've reported it on the beta report form AMD has (but since these drivers aren't actually released, you're likely on your own).

    If one person has a problem, and another doesn't with a similar setup, it can be seen as an issue that's isolated to something specific to that system (either a legitimate bug, or something silly that user did). Regardless, all feedback is welcome; it's not about "sticking up for AMD".

    Also, these drivers are pretty flawless for me. Haven't even had any BSoD so far, and I've played plenty of videos in Chrome (had 2 BSoD on 14.3). Using the dev branch with PPAPI flash.
     
    Last edited by a moderator: Apr 16, 2014
  8. signex

    signex Ancient Guru

    Messages:
    8,823
    Likes Received:
    176
    GPU:
    Asus TUF RTX 3080
    Could be only related to the new R9 290/x cards.
     
  9. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    These are leaked press drivers, they will NEVER be posted on AMDs site..
     
  10. Chabi79

    Chabi79 Member

    Messages:
    35
    Likes Received:
    0
    GPU:
    MSI R6850 OC Cyclone 1GB
    new beta driver

    AMD Catalyst 14.4 (14.200.0.0 Beta Apr 9)

    1404091520-14.20-140408a-170576E
    DriverVer=04/08/2014, 14.200.0.0000

    OpenGL 4.3.12959
    OpenCL 1.2 AMD-APP (1497.3)
    Khronos OpenCL 2.01 ICD
     
    Last edited by a moderator: Apr 17, 2014

  11. kd7

    kd7 Member Guru

    Messages:
    151
    Likes Received:
    4
    GPU:
    7970m
  12. SlackerITGuy

    SlackerITGuy Master Guru

    Messages:
    393
    Likes Received:
    1
    GPU:
    SAPPHIRE Radeon R9 Fury
  13. KBDE

    KBDE Master Guru

    Messages:
    217
    Likes Received:
    26
    GPU:
    R290 4gb
  14. SlackerITGuy

    SlackerITGuy Master Guru

    Messages:
    393
    Likes Received:
    1
    GPU:
    SAPPHIRE Radeon R9 Fury
  15. freeman94

    freeman94 Master Guru

    Messages:
    316
    Likes Received:
    5
    GPU:
    MSI GTX 1070 ARMOR
    It's for APU, ehhhh... You gave me false hope :bang:
     

  16. fabiovtec

    fabiovtec Member

    Messages:
    33
    Likes Received:
    2
    GPU:
    ASUS R9 270X @1270
    maybe for desktop is coming soon
     
  17. KissSh0t

    KissSh0t Ancient Guru

    Messages:
    11,213
    Likes Received:
    4,918
    GPU:
    ASUS RX 470 Strix
    When will there be a new WHQL driver for GPU's?

    It has been months since the last WHQL...
     
  18. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,825
    Likes Received:
    711
    GPU:
    AsRock RX 6700XT
    This drivers are working great for me.
    The clocks don't stick anymore.
    CCC opens WAY faster.
    The bug in the video colour/filter etc in CCC where it would turn black is solved.
    I didn't notice any performance improvement in games.

    All around I'm happy. I hope they make another PUBLIC beta with this CCC and set of drivers, but, improved even further.

    Thanks to the original leaker.
     
  19. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,785
    Likes Received:
    758
    GPU:
    MSI 2070S X-Trio
    Its coming this month.

    EDIT: Nobody tried those APU drivers, as they may install for cards as well.
     
    Last edited: Apr 17, 2014
  20. MacT

    MacT Member Guru

    Messages:
    184
    Likes Received:
    0
    GPU:
    2 x Sapphire HD 7970 OC
    I am not sticking up for AMD. I was replying to posts by theoneofgod that stated (unequivocally) that the GPU2 99% bug was back. I made a simple reply to that statement that I don't have a 99% bug problem. His retort was that I was mistaken and that I didn't even understand what the 99% bug was! So this is why I included graphs, so theoneofgod could see for himself that my system was not displaying any sign of the 99% bug.

    Does this mean that I think there is no 99% bug? No, I have experienced it before. Just that my system does not currently have that issue with these 14.4. Does this mean it is user error? Maybe. But it may also indicate other issues are at play and to not just outright blame this particular driver.

    I wouldn't have cared less if theoneofgod had stated that "GPU2 running at 99% all the time bug is back on his system." I was only trying to point out that his assumption that if he has the bug then everyone will have the bug, was incorrect.
     

Share This Page