AMD Catalyst 14.2 BETA 1.3 (13.350.1005.0 February 23)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Feb 25, 2014.

Tags:
  1. dirtula

    dirtula Member

    Messages:
    16
    Likes Received:
    1
    GPU:
    Asus RX580 8gb
    the highest texture quality on all maps i found that is usable without stuttering is medium with 2gb of video memory, everything else can be on ultra less aa.

    also anybody with more than 6 cores try limiting this Thread.MaxProcessorCount 6 to 6 or lower. this fixes the infrequent stuttering i was getting.

    mantle is now really smooth for me and my friends, just sucks you can't yet turn up the textures yet on the 7800/270's

    the mouse is tighter in mantle compared to dx11 as well. it feels quake-like in its responsiveness :).
     
  2. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,836
    Likes Received:
    235
    GPU:
    EVGA GTX 1080Ti SC
    Let me repeat, it is working for many of us with 7000 series cards.
     
  3. psychok9

    psychok9 Master Guru

    Messages:
    319
    Likes Received:
    0
    GPU:
    MSI GTX 980TI Gaming 6G
    I still have flickering problem when I switch to clone mode... (1360x768x60Hz, DVI monitor and HDMI TV)
     
  4. onlytanmoy

    onlytanmoy Active Member

    Messages:
    60
    Likes Received:
    0
    GPU:
    SAPPHIRE HD 7950 3GB
    thank you so much.
     

  5. dampflokfreund

    dampflokfreund Member Guru

    Messages:
    168
    Likes Received:
    4
    GPU:
    8600/8700M Series
    Pls don't complain. AMD said you will get it in the next beta release. What should I say with my mobility support? I can't even try Mantle because I have switchable graphics...
     
  6. freeman94

    freeman94 Master Guru

    Messages:
    307
    Likes Received:
    5
    GPU:
    MSI GTX 1070 ARMOR
    Yes Mantle works for me, but the problem is how it works. If it needs to work like this then better is not have it at all. (at least at this time)
    There is so much stuttering, CPU spikes, 60fps then 10,20-30 and 60 again., it jumps like hell + random freezes (2-3sec) and it doesn't matter if I set low settings or ultra.

    Someone quote me, that It works good on HD7000, please tell me how you do this? How you make it works correctly. Hymm? I'm very curious.
     
  7. japamd

    japamd Ancient Guru

    Messages:
    2,448
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970Ghz
    Delete Mantle cache files and try again. You'll find them at %userprofile%\Documents\Battlefield 4\cache
     
  8. Ltmatt

    Ltmatt Member Guru

    Messages:
    118
    Likes Received:
    0
    GPU:
    HIS Ice-Q 7950 Crossfire
    What are those files for? I noticed them the other day. Mantle works wonderfully for me on 290 crossfire. The only issue i have is when playing online every 5 minutes or so there is a massive cpu spike. It literally pauses the game for 1 whole second, then it carries on perfectly. Will this help with that?
     
  9. BenYeeHua

    BenYeeHua Ancient Guru

    Messages:
    1,515
    Likes Received:
    0
    GPU:
    Asus 650M D3
    I guess this cache file is the GPU compiled code, so they don't need compile again to reduce the CPU load.
     
  10. japamd

    japamd Ancient Guru

    Messages:
    2,448
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970Ghz
    Probably precompiled stuff generated once to speed up load time thereafter. For people with lots of issues like freeman94 and others it might be worth try deleting those cached files and see if it helps.
     

  11. Sobe

    Sobe Member Guru

    Messages:
    198
    Likes Received:
    0
    GPU:
    EVGA GTX 1060 6GB
    Smooth here with the beta drivers and my 280x
     
  12. CybrSage

    CybrSage Member Guru

    Messages:
    197
    Likes Received:
    0
    GPU:
    ASUS 560Ti
    Bye bye.
     
  13. inouext

    inouext Member Guru

    Messages:
    137
    Likes Received:
    13
    GPU:
    RX 580
    Hi.
    I got a 4250/6550 AMD on my HP.

    The latest driver that worked great for me was 13.11 beta 9.5, after that 13.12 WHQL. 14.1 and now 14.2 beta 1.3 is missing the panels on catalyst.
    I always use DDU to install a new driver but this doesn't seem to help.
    Also tried LeekM 14.2 fix with no results :(
    Here is my catalyst with 14.2
    http://i.imgur.com/Yo0OzZi.jpg

    Anyone ?
     
  14. dirtula

    dirtula Member

    Messages:
    16
    Likes Received:
    1
    GPU:
    Asus RX580 8gb
    i just did a few posts up, not sure why yours doesn't work, try reinstalling? how much vram is getting used when it stutters?
     
  15. 7stars

    7stars Member Guru

    Messages:
    107
    Likes Received:
    0
    GPU:
    Sapphire R9 290 Tri-x OC
    7000 is not optimized yet... i can guarantee :)
    for 2GB cards that's a vram issue, for "playability" you have to use textures medium or high (not ultra) and MSAA off (not directly ingame, you have to set, leave and restart...) and even this couldn't ensure absence of weird fps drops ATM...

    they say that with Mantle more vram will be used BUT IMO this still is an aspect of coding that they will need to improve... a lot :)
    if you can use ultra settings in D3D with no major issues (2GB 1080p) but you can't compare the same settings in Mantle, this is definitely wrong ;)
     
    Last edited: Mar 3, 2014

  16. shankly1985

    shankly1985 Master Guru

    Messages:
    502
    Likes Received:
    1
    GPU:
    RX VEGA 64
  17. 7stars

    7stars Member Guru

    Messages:
    107
    Likes Received:
    0
    GPU:
    Sapphire R9 290 Tri-x OC
    yes, 290 works good (until you turn on Vsync...they say it will be fixed on the next beta driver this month)
     
  18. Espionage724

    Espionage724 Guest

    Star Swarm on my 7850 (2GB) works pretty well, and even better than the DX renderer. Can't speak for BF4 though.
     
  19. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,419
    Likes Received:
    182
    GPU:
    RX 580 8GB
    It's supposed to be. Mantle is much better here.
     
  20. dell7520user

    dell7520user Banned

    Messages:
    216
    Likes Received:
    0
    GPU:
    hd4000+hd7730m
    there is something about catalyst driver. weird-strange situations.

    enduro notebooks have dx9 issues. im searched lots of radeon inf regedit option. something founded they are effected good but not satisfied.

    vendor driver is v13.151 based catalyst and its old now. not compatible with hawken.

    there is new dated driver 13.251.3 for alienware 17.

    im modded their inf ( driver also include r576 settingns ) its perfectly fit my machine.

    result great. im added LeeKM fixes. more good.

    after im released this fix on dells support forum. they are closed free access to product drivers! now everyone need product serial for founding their driver.

    im not angry to catalyst makers like my old situation. there is problem more complicated. they are building catalyst with most options. but who work for customized builds last work. there is problem.
     
    Last edited: Mar 3, 2014

Share This Page