AMD Catalyst 14.12 Omega WHQL (14.501.1003.0 November 20)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by shadow_craft, Dec 9, 2014.

  1. red6joker

    red6joker Master Guru

    Messages:
    572
    Likes Received:
    0
    GPU:
    MSI GTX 980TI Gaming
    The first few results where for that res. But I still think that my problem is a driver problem since when I up the res to 1440 or 1800 the borders appear.
     
  2. Pill Monster

    Pill Monster Banned

    Messages:
    25,216
    Likes Received:
    8
    GPU:
    7950 Vapor-X 1100/1500
    Can't say for sure, but knowing how this forum operates if it was drivers 590 of the last 600 posts would be from people complaining.. :p
     
  3. jamek

    jamek Banned

    Messages:
    88
    Likes Received:
    0
    GPU:
    R9 270x Gaming
    i had the same probleme with some of precedent drivers, but with omega no probleme for now
     
  4. xxela

    xxela Master Guru

    Messages:
    223
    Likes Received:
    6
    GPU:
    Sapphire Vega64 Nit
    I had one random driver crash with this driver. It happened when I close chrome with a flash tab. Also this happened some hours after PC wake up from sleep. Beside this this is a very good driver.
     

  5. AsiJu

    AsiJu Ancient Guru

    Messages:
    6,764
    Likes Received:
    1,829
    GPU:
    MSI RTX 2070 Armor
    I too am experiencing intermittent crashes on Max Payne 3 with this driver (VSR on or off). Everything else is working flawless atm.

    It seems when the game is trying to enter a loading screen mid-play (the one with the "comic" strips), there's a black screen crash and Windows states "MaxPayne3.exe has stopped responding".

    The only driver for me so far which crashes Max Payne 3 (including both NVIDIA and AMD hardware).
     
    Last edited: Dec 23, 2014
  6. Alpha_Tay

    Alpha_Tay Active Member

    Messages:
    58
    Likes Received:
    0
    GPU:
    -
    i upgrade from catalyst 13.4 to this 14.12, with radeon 6650A ddr3, basically a 6650m for all in one desktop. i didnt upgrade to other version due to stutter issues as mention by other but i didnt test it myself to see if it happen to me too.

    this 14.12 has some bug, at first, i took it was my setting, then i reset default ccc setting, it still happen, when i play dota 2, full screen without sync on, sometimes when big 5vs5 war happen, or sometimes it just happen without big war, the fps would drop to 20fps, then 99% of sound would disappear or broken sound.

    i play facebook tetris battle with chrome when dota 2 loading at hero selection screen, sometimes it would drop to 9fps.

    both issues i just disconnect and reconnect again the issues would gone, without needed to restart the dota 2 exe, but it may appear again.
     
  7. FunkyMike

    FunkyMike Master Guru

    Messages:
    539
    Likes Received:
    0
    GPU:
    ATI 6850m /Intel HD3000
    Stutter solution is to set EnableUlps to 0
     
  8. bokloz

    bokloz Master Guru

    Messages:
    584
    Likes Received:
    0
    GPU:
    EVGA GTX 980Ti
    Great driver solved resume from sleep problem for me
     
  9. Alpha_Tay

    Alpha_Tay Active Member

    Messages:
    58
    Likes Received:
    0
    GPU:
    -
    i tried it before along with Profiles.xml CatalystAI disable, stutter still happen, it would try it again, with only EnableUlps 0, thx.
     
  10. FunkyMike

    FunkyMike Master Guru

    Messages:
    539
    Likes Received:
    0
    GPU:
    ATI 6850m /Intel HD3000
    That is a shame!
     

  11. Alpha_Tay

    Alpha_Tay Active Member

    Messages:
    58
    Likes Received:
    0
    GPU:
    -
    i tried it again just now, with only EnableUlps 0, all other setting default, stutter still happen.
     
  12. CodyPredy

    CodyPredy Active Member

    Messages:
    68
    Likes Received:
    0
    GPU:
    Saphire ATI R270X 2GB
    I've been having a similar issue with every AMD driver but usually it showed up as a video hardware error.

    Not so sure since I deleted the last logs but it happened only once with the Omega drivers. I use WOL and Remote desktop from time to time and that's when it usually happens.
     
  13. SlayeurX

    SlayeurX New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    AMD Radeon R9 280X 3GB
    Hello , Catalyst 14.12 Omega broks my FIFA 15 , Now when fifa 15 start i have D3D9 Error Direct3Dcreate9Ex not found .

    The games start but V-Sync is not active and Radeon Pro settings are not applyed.

    Thanks. Sorry for bad english
     
  14. RzrTrek

    RzrTrek Ancient Guru

    Messages:
    2,525
    Likes Received:
    725
    GPU:
    RX 580 ❤ MESA 20.3
    I don't know whether this is related, or not, how could it, but ever since I installed this driver, my audio have been acting strange (muted) from time to time?
     
  15. Alpha_Tay

    Alpha_Tay Active Member

    Messages:
    58
    Likes Received:
    0
    GPU:
    -
    i switched back to 13.4, the games was much smoother with
    Profiles.xml CatalystAI disable
    EnableUlps 0
    Texture Filtering Quality High Quality
    Surface Format Optimization Off
    Tessellation Mode: Use application settings

    not stutter like what i mention at previous post with 14.12.
     

  16. Alpha_Tay

    Alpha_Tay Active Member

    Messages:
    58
    Likes Received:
    0
    GPU:
    -
    my result with 13.4 was it would still stutter during heavy fight, but it would back in normal after that without the need to disconnect/reconnect.

    i suspect that Profiles.xml CatalystAI shouldnt be Disable, due to newer catalyst architecture changed? that is why ccc dont have CatalystAI Disable options anymore. if Profiles.xml CatalystAI Disable, running some games that use high gpu usage, it would cause some unusual stutter.
     
  17. shimyns

    shimyns Ancient Guru

    Messages:
    1,657
    Likes Received:
    0
    GPU:
    SAPPHIRE r9 290x Tri-X OC
    I installed these drivers and saw 100% GPU usage. I uninstalled, went back to the 14.9's (?) and now my monitor won't wake up after it "sleeps". Great...
     
  18. Pill Monster

    Pill Monster Banned

    Messages:
    25,216
    Likes Received:
    8
    GPU:
    7950 Vapor-X 1100/1500
    Higher GPU usage is prob because Texture Filtering optimizations aren't being used, that's mostly what Cat AI does.

    It's still there, just been removed from the GUI making it harder to disable.

    Then again I could be completely wrong since I know nothing about your system specs. lol
     
    Last edited: Dec 24, 2014
  19. Alpha_Tay

    Alpha_Tay Active Member

    Messages:
    58
    Likes Received:
    0
    GPU:
    -
    intel i5-2500s, radeon 6650A
     
  20. Alpha_Tay

    Alpha_Tay Active Member

    Messages:
    58
    Likes Received:
    0
    GPU:
    -
    it still sutter 13.4 when /i play facebook tetris battle (run with flash) with chrome when dota 2 loading at hero selection screen, sometimes it would drop to 9fps./

    maybe lastest chrome, flash, dota 2 compatibility issues.

    Profiles.xml CatalystAI Enable
    EnableUlps 0
    Texture Filtering Quality Standard
    Surface Format Optimization Off
    Tessellation Mode: Use application settings
     

Share This Page