AMD Catalyst 14.12 Omega WHQL (14.501.1003.0 November 20)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by shadow_craft, Dec 9, 2014.

  1. cod6da

    cod6da Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    powercolor rx 480 8gb
    I returned 14.9.Omega not for bf4 mp mantle :frown:
     
  2. MacT

    MacT Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    2 x Sapphire HD 7970 OC
    Why? BF4 mantle works fine for my setup - 2 x 7970 crossfire with the Omega. Can't see why one 280X would be a problem then. Have you ever deleted the MantlePipelinecache files between driver updates? I know this can cause problems in Mantle with driver updates.
     
  3. Despoiler

    Despoiler Master Guru

    Messages:
    244
    Likes Received:
    0
    GPU:
    Sapphire TRI-X R9 Fury
    Zero issues from this driver, once again. BF4(Mantle), WoT, LoL, D3, CivBE(Mantle), DoW2 all flawless. Star Citizen seems to hang a bit longer when loading graphics. No issues during gameplay.
     
    Last edited: Dec 17, 2014
  4. big ROBOT bill

    big ROBOT bill Maha Guru

    Messages:
    1,440
    Likes Received:
    675
    GPU:
    ROG Strix 1660Ti
    I love Mantle with BF4, runs sweet on my R280 with these drivers.
     

  5. elMARIACHI

    elMARIACHI Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    3x Sapphire R290x
    Can someone confirm if NNEDI3 works in MadVr? I'm stuck using 13.12 given it's the only build it works on and I've tried up the 14.9 branch. I've simply got too much at stake @ the moment to test them myself.

    Much appreciated!
     
  6. Bucephallus

    Bucephallus New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Asus R9290 DirectCU II OC
    How do you connect to the monitor?

    Mine is connected through a DisplayPort. The monitor is a Dell 3008WFP running at 2560 x 1600
     
  7. Despoiler

    Despoiler Master Guru

    Messages:
    244
    Likes Received:
    0
    GPU:
    Sapphire TRI-X R9 Fury
    Just tried. It works fine. NNEDI3 128 neurons, image upscaling handled by DXVA2. Smooth, sharp, looks glorious.
     
  8. Ryu5uzaku

    Ryu5uzaku Ancient Guru

    Messages:
    6,803
    Likes Received:
    120
    GPU:
    5700 XT UV 1950~
    I had it like the before these drivers :eek: tho it doesn't hinder the performance so I didn't care. :D
     
  9. mortis

    mortis New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    R9 280
    Rolled back to 14.11.2beta from omega, artifacts/flickering crashing games dissapears.
    card - r9 280 gigabyte wind force.
     
  10. elMARIACHI

    elMARIACHI Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    3x Sapphire R290x
    I just attempted to launch a 1080p video and NNEDI3 doesn't work whatsoever using any amount of neurons on my r290x.

    On another note, I launched sgminer on a previously working config and that simply crashes my system...what a complete disappointment.
     

  11. Octopuss

    Octopuss Master Guru

    Messages:
    885
    Likes Received:
    56
    GPU:
    -
    DVI. Displayport doesn't work too well with my monitor.
     
  12. cod6da

    cod6da Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    powercolor rx 480 8gb
    The game(bf4) on mantle is stopped after 20 minutes on omega:bang:.I kill the process via task manager.idk why,but on 14.9 this does not happen.wind8.1 64
     
  13. millibyte

    millibyte Maha Guru

    Messages:
    1,152
    Likes Received:
    79
    GPU:
    2070 subpar RTX OFF
    @AMDMatt,

    Would it be possible for AMD to implement a backup of game profiles in the 3D Application Settings tab of CCC similar to what's available in RadeonPro? When you do a clean uninstall of new drivers, these custom profiles get wiped out and it can get a bit tedious to redo them every time. It'd be nice to be able to export them to xml and then just restore them once you install a new driver set.
     
  14. Despoiler

    Despoiler Master Guru

    Messages:
    244
    Likes Received:
    0
    GPU:
    Sapphire TRI-X R9 Fury
    I don't what to tell you man. It works on my rig. I'm positive it's actually kicking in because if I goto 256 neurons it starts to get unsmooth. I'm using MPC-HC 1.7.7 32bit. LAV 0.63.0.0. Reclock 1.8.8.4. Tried 720p and 1080p. .mkv, .mpg, and .mp4 files. Everything just works.
     
  15. johnslash

    johnslash Active Member

    Messages:
    62
    Likes Received:
    0
    GPU:
    ASUS R9 290
    I can say that is working on mine as well, however I don't use it, because it is pretty heavy and doesn't work well with SVP.
     

  16. Nymphie

    Nymphie Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    ASUS R9 290 DCU2
    Still get intermittent black screens while just surfing the web.
    Only happened 2 times while gaming.

    WHY isn't this getting fixed?! :bang:
     
    Last edited: Dec 17, 2014
  17. AnthonX

    AnthonX New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Sapphire HD 6970 2GB
    Ok, so if I understand correctly the game should utilize those 'specific' fixes within the drivers and not the drivers having to locate where the game is installed in order to 'patch' it the way the updates do? So in that case it does not matter where the game is installed?

    Has anyone else with an HD 6970 (win 7 64bit) seen any performance gain in FC4 with these drivers? It's interesting to note that although they state HD 6000 & 5000 series are supported, there's no option to choose those cards if you 'Manually Select Your Driver'

    Just saying......
     
  18. Despoiler

    Despoiler Master Guru

    Messages:
    244
    Likes Received:
    0
    GPU:
    Sapphire TRI-X R9 Fury
    Black screens are usually related to the GPU's memory. Drivers aren't going to fix it. Google card model + black screens. Lots of threads.
     
  19. gexxy lord

    gexxy lord Member

    Messages:
    33
    Likes Received:
    0
    GPU:
    r9 280x
    i used to get black screeens also then i changed refresh rate on my monitur from 72 to 60 and the black screens are gone ,,,used to play farcry4 then boom black screen then ok then again,,so far after changing to 60hz refresh rate its ok
     
  20. elMARIACHI

    elMARIACHI Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    3x Sapphire R290x
    I'm also using the same software on a clean WlN 7 installation. I've tried on WlN 8.1 and results are identical. The r290x also struggles with Jinc @ 8 Taps which my GTX580 can do just fine with a 15% OC on the core. I've got no idea what the problem can be although if I were to guess, it must have something to do with OpenCl. It would put a smile on my face from ear to ear if someone can get to the bottom of this because I've exhausted every possible solution as well as dozens of hours of testing.
     

Share This Page