AMD Catalyst 14.1 BETA 1.6 (13.350.1005.0 January 31)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Feb 2, 2014.

Tags:
  1. psyside

    psyside Master Guru

    Messages:
    351
    Likes Received:
    0
    GPU:
    7950 @1150/6000
    Any news on Beta 14.7, when>?
     
    Last edited: Feb 24, 2014
  2. Vinnie

    Vinnie Ancient Guru

    Messages:
    7,688
    Likes Received:
    17
    GPU:
    2x AMD R9 290X
    I was wondering the same thing! AMD's driver team is slowing down, it seems.
     
  3. danfim

    danfim Master Guru

    Messages:
    394
    Likes Received:
    0
    GPU:
    MSI GTX 980
    I have to admit I was very disappointed to see no proper Mantle support for my cards.
     
  4. Skinner

    Skinner Master Guru

    Messages:
    427
    Likes Received:
    20
    GPU:
    2x 2080Ti Sli
    It's allmost march, still waiting for a proper driver for my R290X's to operate without v-sync issues, without blackscreens, without BSOD's in mantle. How long this is gonna take, for mantle I make an excption, this offcourse takes time, but the other issues should have been cleared by now! I'm starting to lose faith in AMD adressing these issue's. They seem to be unreachable for every common communication (support forum).

    It would surprice me if these issue's are fixed within the next driver. This is by far the worsed experience I've ever had with computerhardware :(
     

  5. 7stars

    7stars Member Guru

    Messages:
    107
    Likes Received:
    0
    GPU:
    Sapphire R9 290 Tri-x OC
    whenever you encounter a bug, you have to reach them here
    http://www.amd.com/report
    OR for beta
    http://www.amd.com/betareport
    and try to be as accurate as possible
    not forum... :) that is, on the forum you can talk about it for sure and share your experience...but can't expect that the issues will be fixed without reporting...and everyone should report bugs or issues by the report form
    if you do that, you just have to wait...
     
    Last edited: Feb 24, 2014
  6. onemoar

    onemoar Master Guru

    Messages:
    294
    Likes Received:
    0
    GPU:
    GTX 1060SC @2250/4550
    what part of beta-driver is so hard to understand...
    mantle is BETA if you don't wanna have issues don't ****ing use it :bang:
     
  7. 7stars

    7stars Member Guru

    Messages:
    107
    Likes Received:
    0
    GPU:
    Sapphire R9 290 Tri-x OC
    agree with you... but beta is good to report bugs, not only to say that something doesn't work as expected...so don't write on the forum only but rather report them ;) this is the main indication
     
  8. Skinner

    Skinner Master Guru

    Messages:
    427
    Likes Received:
    20
    GPU:
    2x 2080Ti Sli
    Thanx, but I've also gone that route several times. For example I have reported the v-sync issue in november.
     
  9. jaju123

    jaju123 Master Guru

    Messages:
    356
    Likes Received:
    3
    GPU:
    2x AMD R9 290 Crossfire
  10. Skinner

    Skinner Master Guru

    Messages:
    427
    Likes Received:
    20
    GPU:
    2x 2080Ti Sli
    Last edited: Feb 24, 2014

  11. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,292
    Likes Received:
    455
    GPU:
    MSI 2070S X-Trio
    If the're owt like the 14.1's, then i don't agree :D
     
  12. Alph4Dawg

    Alph4Dawg Member Guru

    Messages:
    109
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor OC
    Hopefully v2 drivers will fix random crashing and freezing (Battlefield 4 has stopped working) on 7x series.
     
  13. SlackerITGuy

    SlackerITGuy Master Guru

    Messages:
    392
    Likes Received:
    0
    GPU:
    SAPPHIRE Radeon R9 Fury
    AFAIK that's up to DICE, not AMD, it's happening to a large part of gamers since the Feb 13th patch (Direct3D users as well).

    Supposedly, there's a new server patch going live later tonight (1am PST), so maybe there's a chance for a client update as well.

    If AMD managed to include the GCN 1.0 performance increases in 14.2, along with mobility/CrossFire support (Mantle), and DICE releases a new client update fixing all the crashing that's going on, it will be a day to remember lol.
     
    Last edited: Feb 25, 2014
  14. Slikar

    Slikar Master Guru

    Messages:
    368
    Likes Received:
    0
    GPU:
    GTX970 WF3
    Hope mantle support for older cards is better , and that bf4 stuttering with mantle , which is btw using 2500mb VRAM on my card is fixed.. Also maybe some thief 4 speed up?
     
  15. elijah47

    elijah47 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    ATI Mobility 5650/4GB
    Is this compatible to ATI Mobility Radeon Hd 5650?
    Thanks!
     

  16. pato

    pato Member Guru

    Messages:
    150
    Likes Received:
    4
    GPU:
    EVGA Geforce GTX-970
    Should be compatible, but you won't gain much. Mantle is not available for the HD5xxx series.
     
  17. The Creator

    The Creator Member Guru

    Messages:
    132
    Likes Received:
    0
    GPU:
    Sapphire R9 290X
    I hope that new driver will be usable in opposite to current 14.1 beta. After first reboot after installation of the drivers, my card works very slow. I have less than half of usual FPS in 3D applications.
    I tried a brand new installation of Windows but the issue remain. No such problem with 13.12 driver.
     
  18. Elite3540

    Elite3540 Master Guru

    Messages:
    668
    Likes Received:
    0
    GPU:
    MSI GTX 970 GAMING 4G OC
    These drivers should normally work for your videocard.

    If you are not sure next time, you could always try to go to the AMD site:

    http://support.amd.com/en-us/download

    just pick your AMD videocard and on what system and after that you will see the latest drivers available for your videocard.
     
  19. Hugin

    Hugin New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Sapphire 7870 OC 2GB
    AMD Catalyst 14.2 Beta for Windows is now live!
     
  20. tp2west21

    tp2west21 New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Gigabyte G1 Sniper b5
    Fail install of 14.1 driver for Sapphire r7 260x 2gb OC 2x Dvi

    Hi guys, i kinda need help with my PC, a week ago, i downloaded the new beta driver Catalyst 14.1, did a full driver sweep, and installed it, some how it fails to install the driver for the card but install everything else, now i went back to the 13.2 WHQL version for my card and since then, i started to experience flickering lines now and then on my PC, white or black lines.

    Seemed to notice that it only does the flickering thing whenever i'm idling or just doing web browsing or watching videos/YouTube and such.

    And whenever i'm playing a game, running a game on idle on the background, alt tabbing etc... the issue doesn't seem to happen.

    Here is what i already tested,

    tried using the processor's Intel HD 4600, flickering doesn't happen, using the same HDMI cable.

    Tried connecting my phone, a galaxy note 3 into the monitor thru the HDMI port and hadn't had flickers while playing a game or playing a video.
    temperatures are good,

    Run a 24 hour stress test on MSI Kombustor, results are normal, dint notice anything odd, no flickering lines.

    Been playing HD games on High settings or even Ultra settings and flickering nor any other video problems don't appear.

    Examples of the games i play are Dota2, LoL, BF4, AC4, Prototype2, CS Go, Total War II Rome, and as i said, doing games it doesn't happen.

    Only started after failing to install the 14.1 beta driver and going back to 13.2 driver.

    Already tried re-downloading and re-installing drivers both the 14.1 beta and the current 13.2. but same thing. Flickering lines appear when idling or just web browsing or just going thru pictures or files.

    Its not a big deal since it doesn't crash my games or anythings, i just wanna know what seems to be happening, so i don't get paranoid about the components of my PC going out.

    Any help would be great.
    Went back to a clean wipe and reinstalled 13.10,
    haven't had any flickers since then.

    But still failing when installing 14.1 and believe me, i searched and tried every possible way to install it.
     

Share This Page