AMD Catalyst 13.8 BETA2 (13.200.11.0 August 14)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by sunn, Aug 19, 2013.

  1. COOPOD

    COOPOD Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    HIS HD7970 IceQ X 3GB
    Should I prescribe Disable Driver Signature Enforcement to install this driver for windows 8?
     
  2. grufferator

    grufferator Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    Sapphire Radeon HD7850 1G
    I did not check it. Maybe because I did not get any errors while installing the driver. Does the 8.1 Preview Driver come with Windows 8.1 RTM? Or maybe I got it automatically by windows update. I'll check it in a few hours.
     
  3. 7stars

    7stars Member Guru

    Messages:
    107
    Likes Received:
    0
    GPU:
    Sapphire R9 290 Tri-x OC
    it's not true 'cause i have a 7850 2GB crossfire and can use ultra details in every game, single and crossfire both...in single i don't always have 60+ for every game but it's really playable and smooth..that's not the problem
    the problem is that crossfire is not yet perfect :3eyes:, i still notice a difference in smoothness...single gpu is the best without any doubt despite cross in some games indicates a clear framerate improvement. But i prefer smoothness, not only high fps.
    e.g. saints row 4 sometimes in crossfire has a microstutter...never in single rig.
    splinter cell BL CF ultra+texellation+field ao, no vsync: sam fisher movements are unwieldy, random crash during a mission, not smooth as it should be...
    splinter cell BL single, same settings: smooth, no problem, no crash...
    IMHO games still suffer about frame time with Crossfire, while improved. It can be noticed when the protagonist runs or walks through the scenarios or little mouse lag, also think about a "memory management issue" when entering new scenes... The fix is not completely done yet...
     
    Last edited: Aug 31, 2013
  4. Krelianz

    Krelianz Member Guru

    Messages:
    112
    Likes Received:
    0
    GPU:
    Sapphire R9 290x
    im getting the same problem anyone knows if they fixed it yet? i dont want to disable the driver signature thingy.
     

  5. Espionage724

    Espionage724 Guest

    If I understand right, if you just install this driver as-is with a Express setup (or Custom with everything checked), the Display driver shouldn't be offered at all (NT6.3 isn't a supported OS in the inf), so you probably wouldn't get any error at all.

    I don't think 8.1 RTM comes with any driver (both my desktop and dual graphics laptop started on the Basic driver). There's 3 choices for a display driver for 8.1 that I'm aware of though, other than Windows Update drivers (not sure what version that is).

    - Windows 8.1 Preview Driver
    - OpenGL 4.3 Beta Driver (a V2 of the Windows 8.1 Preview Driver)
    - A slightly-updated OpenGL 4.3 Beta Driver (this one is WHQL-signed; latest driver for 8.1 currently)

    Here's the line of text that determines what OSes the driver supports in the driver inf:
    Supported OSes get their own individual sections full of text. The Windows 8 inf supports only [ATI.Mfg.NTamd64.6.2] and the Windows 7 inf only supports [ATI.Mfg.NTamd64.6.1]

    All other unsupported OSes just get tossed to the bottom of the inf with no information. The Windows 8 inf for 13.8 beta 2 specifically has:

    Code:
    [ATI.Mfg.NTamd64.6.0]
    
    [ATI.Mfg.NTamd64.6.1]
    
    [ATI.Mfg.NTamd64.6.3]
    6.3 = Windows 8.1
    6.2 = Windows 8
    6.1 = Windows 7
    6.0 = Vista

    So pretty much... these drivers can't be installed on any OS other than Windows 7 or 8, by default. Editing the inf causes the driver to be unsigned, and I'm not aware if even then these drivers install (I got a complaint about a hash not verifying or something).

    A pretty desperate course of action would be to change the OS version from System properties I guess but that might cause some important stuff to break (in other words, not worth the attempt).
     
    Last edited by a moderator: Sep 3, 2013
  6. nikescomputers

    nikescomputers Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    Radeon HD 290x 2 of them
    Problem with mass effect 3

    After updating to Catalyst version 3.8 beta 2 mass effect 3 wont work gets in the game too the press any key to begin then hangs any one have the same issue ?
     
  7. grufferator

    grufferator Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    Sapphire Radeon HD7850 1G
    Espionage724

    You were right. Only the CCC was installed: http://s51.radikal.ru/i133/1309/d8/ff7443439e38.png
    I guess I got it via windows update. Geez, how could I not notice?

    Maybe this driver is old but it works pretty good. I get decent FPS in BF3. Radeon Pro and Afterburner work with no problem.
     
  8. blood_sam

    blood_sam Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    Sapphire Tri-X R9 290 OC
    I'm running an HP laptop with Intel HD4000 + 7670M.

    Latest Intel drivers (3165) and Catalyst (13.8 b2) works fine, except sometimes games run on the IGP instead of the GPU despite they are running in "High Performance" mode in CCC. It happened with Splinter Cell Blacklist, BulletStorm and CSGO.
    I have to set them to "Based on power plan" to run them on the GPU again.

    Moreover, Blacklist DX11 executable doesn't keep showing in the switchable graphics applications list. If I had it, and apply the settings, it is removed from the list, but it still be configured.
    And often, games are not displayed in the "Recent applications" list.
     
  9. Undying

    Undying Ancient Guru

    Messages:
    13,097
    Likes Received:
    2,353
    GPU:
    Aorus RX580 XTR 8GB
    You tried PX - Enduro fix drivers from LeeKM?
    http://forums.guru3d.com/showthread.php?t=380915
     
  10. peitro

    peitro Member Guru

    Messages:
    138
    Likes Received:
    0
    GPU:
    ATI 5870 m
    wrong ,windows 8.1 boot up with the standard drive ,but than it instal a 150.... clas drive
     

  11. blood_sam

    blood_sam Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    Sapphire Tri-X R9 290 OC
    Not yet. I tried a similar fix once, they are essentially made to optimize performances, and it didn't seem to work for me. (this one http://forum.notebookreview.com/sag...7800-7900-8500-8600-8700-8800-8900m-gpus.html)
    And looks like there are some fans problems with the LeekM one.

    Edit: I played Hitman Absolution a bit and noticed low FPS in areas where I had 30+ with my previous processor and AMD drivers. I rolled back to 13.4 and don't have FPS problems anymore... I'll wait for the next WHQL drivers :/
     
    Last edited: Sep 1, 2013
  12. PieEyedPiper

    PieEyedPiper Master Guru

    Messages:
    610
    Likes Received:
    1
    GPU:
    MSi HD7950 Twin Frozr/3GB
    I'm currently experiencing this right now. It's a complete PITA.
    I'll try the tesselation settings in CCC.
     
  13. randalmcdaniels

    randalmcdaniels Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    Sapphire 7950 3072mb
    I've been using the 13.6beta2 drivers for a really long time and i just upgraded to these 13.8beta2 drivers. I have a sapphire 7950 (3gb) and instantly minutes after installing updates i saw a square box about 1/16th the size of my monitor just appear on my screen for about .01 seconds while gaming. I ignored it and than today i saw it again for another millisecond.. Its really nothing that is a game breaker but i can definately notice it sometimes. It only happens like once every hour. And yeah i always have temp check going it averages at 56-62 celcius which has always been fine for me
     
  14. signex

    signex Ancient Guru

    Messages:
    8,751
    Likes Received:
    145
    GPU:
    AMD FirePro M6100
    Have you done a clean install or just installed the new driver over you're old one?
     
  15. Coldblackice

    Coldblackice Member Guru

    Messages:
    122
    Likes Received:
    0
    GPU:
    Sapphire 290X
    I was about to ask the same. There's a pretty high correlation between people having problems with these drivers and people who haven't done a full, deep cleaning of previous drivers.

    In my experience, Atiman Uninstaller can do no wrong! :)

    (...and before someone tries to jump me for that statement -- I'm aware of the hiccups it's had in the past. Those have long been ironed out, and I've never experienced any issue)
     

  16. randalmcdaniels

    randalmcdaniels Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    Sapphire 7950 3072mb
    The regular ati driver uninstaller does the same thing as the standalone atiman uninstaller. The only difference is that the atiman uninstaller shows you a log file at the end. If you do an express uninstall of your installed ATI drivers than there should be no reason to have to run the atiman uninstall as well. But i guess if it makes you feel better you can do them both
     
  17. Espionage724

    Espionage724 Guest

    I can't speak for atiman, but Wagnard's uninstaller definitely does more, and is probably lighter too.

    You want to find out how well AMD's CIM removes files? Get a laptop with switchable graphics and have fun trying to install newer drivers after removing most of the previous driver with only CIM...
     
  18. krishnarama108

    krishnarama108 Master Guru

    Messages:
    288
    Likes Received:
    0
    GPU:
    asus ati 5850 1gb 850mhz
    i installed those fine on apu c50/6250 and now on desktop rig with asus 5850 for BF3. all is working but with degraded performance by 15-20percent which is at laugh..
    i also installed all Netframew. 4.5 updates.
    i hope ati will make some cool bf4 driver pretty soon..this one missed it a lot
    i was using 8.93-111118a as cool bf3 driver as reference from year 2011 :) which is also laughable
    can someone sugest last stable and fast driver for ati 5850 ?
    thanks :)
     
  19. BravoFxTrt

    BravoFxTrt Member Guru

    Messages:
    168
    Likes Received:
    0
    GPU:
    2X MSI R9 280X 6GB
    I use amd_cleanup_util_1.2.1.0 and it seems to do a really good job, Iv not encountered any probs with it.:)
     
  20. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,332
    Likes Received:
    237
    GPU:
    RX VEGA 56
    Clean.
    Newly installed Win 7 x64 + All Updates + .net 4.5 and updates.
     

Share This Page