AMD Catalyst 13.5 B2 (12.102.3.0 April 16)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by stasio, Apr 24, 2013.

  1. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    Working fine for me however as usual I did not install CCC or the CAP's.


    Edit; I see AMD still likes to mislead users with these ridiculous graphs....:wanker:

    [​IMG]
     
    Last edited: Apr 26, 2013
  2. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
  3. paleh0rse

    paleh0rse Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    2 x Powercolor 7870XT
    Jesus, the scaling on that graph is ridiculous... wow.:thumbdown
     
  4. warlord

    warlord Ancient Guru

    Messages:
    2,761
    Likes Received:
    927
    GPU:
    Null
    Nah, graphs are ok, so the driver, everything is fast and smooth.! :) 13.5b2 with 13.4cap1 + 13.4 hydravision, no CCC problems or anything, all are working. Give some respect, because some have faulty systems with broken registry and entries, that doesn't mean AMD has anything to do with it, learn to live with that. It's never too late starting debugging your personal errors, cheers.! :D
     

  5. Espionage724

    Espionage724 Guest

    People having issues on their own system? Pure blasphemy! Any and all issues related to anything graphics is AMD's fault and AMD's only, we all know this :banana:

    Joking aside, I do agree people should check their own system for faults :)
     
  6. paleh0rse

    paleh0rse Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    2 x Powercolor 7870XT
    I agree with everything you wrote except that the above graph is NOT "ok."

    The graph's Y-axis begins at 90%, therefore making anyone who looks at it believe, at least initially, that the performance increases are MUCH larger than their actual 4 to 18% values. Hell, just look at the bars for Borderlands 2. Visually, the graph tells your brain that there's a 175% increase in performance, while in reality it's only around 18%! :banana:

    It's a visual lie... a trick... a marketing gimmick. Sadly, it's also Marketing 101. :(
     
    Last edited: Apr 26, 2013
  7. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    Fixed :p
     
  8. temo

    temo Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    GTX 1070
    Ditto. Same card and problem.
     
  9. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,856
    Likes Received:
    246
    GPU:
    EVGA GTX 1080Ti SC
    Meh...both AMD and Nvidia do this...it's deception either way. As soon as I take a look at it, I perform some cerebral cleansing and forget that graph ever existed. I just keep the values I have read off the graph in my mind if anything.
     
  10. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,690
    Likes Received:
    671
    GPU:
    MSI 2070S X-Trio
    Agreed, even Nvidia's problems are AMDs fault! :D
     

  11. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    MSI 980 TI Gaming
    While I agree it is not always driver's fault, my system has a fresh windows installation. I am not complaining though.

    I ll give it another try later.
     
  12. paleh0rse

    paleh0rse Active Member

    Messages:
    61
    Likes Received:
    0
    GPU:
    2 x Powercolor 7870XT
    LOL, fair enough! Did I mention that the font used in the graph sucks too? Perhaps they intentionally made the text difficult to read? hmmm... I bet they did.
     
  13. randalmcdaniels

    randalmcdaniels Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    Sapphire 7950 3072mb
    Artifacts? weird

    So i installed the 13.4 drivers and in black ops 1 i right away started noticing artifacts.. Very very fast flashes of what seemed to be black areas. So i went ahead and recorded it with fraps and i was really confused by my findings. It took me a while to pause the video i made on the perfect spot where it occured but after a while i finally got it.

    Here is a picture of what i found
    http://i1324.photobucket.com/albums/u607/RandalMcdaniels/trees_zpscc2c3436.jpg

    Here is another screenshot of 1 frame before that you can see its just normal
    http://i1324.photobucket.com/albums/u607/RandalMcdaniels/trees0_zps837a8247.jpg

    Trees? wtf? Could there be a cache problem or something where there are models left over in the gpu frame buffer? I find this so strange.

    Here is another example

    Normal
    http://i1324.photobucket.com/albums/u607/RandalMcdaniels/trees4_zps58556339.jpg

    1frame later
    http://i1324.photobucket.com/albums/u607/RandalMcdaniels/trees3_zps0a670d51.jpg

    freakin weird huh

    After reading what i posted i realized people might think i faked this so i will eventually upload a clip of this happening on my youtube channel (scalz420) but right now i need to shrink the file size as it is nearly 2gb from recording with fraps
     
    Last edited: Apr 26, 2013
  14. juntulis

    juntulis Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    Gigabyte GTX 980 G1
    For me this new beta seems best drivers till now. 7970m. AC3 stoped crashing. It always crashed 10-50 min. now I played 3 hours straight. Duno if it added any fps. AC3 fps is very jumpy.

    I hope that from now AMD drivers is going to get better and batter
     
  15. Cold_Burn

    Cold_Burn Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    CF Sapphire 2x6870 1GB
    My experience with this driver:
    Works very well for about 30-40 minutes and then I start to notice some slight micro-stutter.

    Nevertheless I'm very happy. Much better than 13.3 that were unstable for me.
     

  16. kyzhuchan

    kyzhuchan New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ATI 7870
    13.5b2 is a keeper for me

    Bioshock infinite benchmark comparison for me @ 1080p gigabyte 7870 1ghz edi
    LVL 7 bench:
    [​IMG]
    LVL 6 bench:
    [​IMG]
     
  17. Scerate

    Scerate Maha Guru

    Messages:
    1,042
    Likes Received:
    0
    GPU:
    2080@2.1/1070N@2.0
    they working really great on my 7970m as well, GW2 at least felt much smoother than before, TERA too didn't gained fps but smoothness overall increased, keeper
     
  18. xacid0

    xacid0 Master Guru

    Messages:
    443
    Likes Received:
    3
    GPU:
    Zotac GTX980Ti AMP! Omega
    Had a couple of TDR event with 13.4 but not with this one. Everything work and perform as it should.

    Now i can't wait for the prototype driver and get another 7950. :p
     
  19. sivis

    sivis Member

    Messages:
    34
    Likes Received:
    0
    GPU:
    Sapphire 7950 (950 Mhz)
    Exactly same here. I hope in the future SLI and Crossfire won't bring so many issues with them.
     
    Last edited: Apr 27, 2013
  20. seb4771

    seb4771 Guest

    Arg,

    Choosing to test 13.5b2 + 13.4 cap 1 with my 5970 = last game crashing many time, losing +25 fps with all games, unigine heaven losing 1000 pts and all my games are "visual deformation" with all texture... :(

    Update 1 : Just 13.4 + caps 1 : lost 10% any games, unigine heaven -250 pts.

    Update 2 : return too 13.5b2 : lost Unigine heaven -150 pts but Dead island riptide gain +40% (!!!).

    "Mars war log pc game" crashing for me with 13.5b2 driver :(
     
    Last edited by a moderator: Apr 27, 2013

Share This Page