1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AMD Catalyst 13.2 BETA 5 (12.100.17.0 February 2)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Feb 5, 2013.

Tags:
  1. warlord

    warlord Ancient Guru

    Messages:
    2,379
    Likes Received:
    781
    GPU:
    Null
    skyrim is smooth as butter with these and i have 23 mods installed...it's heavy as hell and i still enjoy epic smoothness...finally after months amd did something right, amateurs...latest version here, with dragonborn dlc :)
     
  2. slikrick211

    slikrick211 New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    GB HD 7950 @ 1100/1575
    Hitman: Absolution runs nice with these :)
     
  3. Zemial

    Zemial Member Guru

    Messages:
    120
    Likes Received:
    0
    GPU:
    Sapphire Radeon 7970 @ CF
    I had issues with my Sapphire Radeon HD 7970 Dual-x OC card. The 13.2beta caused black screen of death, sound stutter and fan hitting 100% and then hole system freeze. Only thing helped was hard reset. I did fresh install of Windows 7 64bit, drivers and everything possible that I could think of, always the same problem.

    I was going to RMA my card, but final thing what I did was fresh install of windows 7, install Catalyst 12.10 driver and switch BIOS 2(Sapphires OC profile bios 1000MHz/1450MHZ) to BIOS 1(clocks 950MHz/1425MHz). Everything worked fine with catalyst 12.10, I ranned furmark, OCCT GPU, Sisoft GPU tests without a single error.

    Today I maked system restore point to my Windows 7 and then install Catalyst 13.2beta5 top over catalyst 12.10. I runned new 3dmark test, furmark etc, everything seems to work like it should. Now I've been playing games like Skyrim, BF3 and The walking dead and no problems what so ever. I think the problem was related somehow into BIOS 2 settings in my card..?

    I'll keep testing, if there comes some problems I'll report back!
     
  4. djsebfr

    djsebfr Member Guru

    Messages:
    132
    Likes Received:
    0
    GPU:
    Nvidia GeForce GTX 950
    small question for you Z :

    do u use HMDI output ?
    If yes, can u test with DVI ?

    Because i have the same poblem in HMDI, but not in DVI...
     

  5. Zemial

    Zemial Member Guru

    Messages:
    120
    Likes Received:
    0
    GPU:
    Sapphire Radeon 7970 @ CF
    I use displayport @ 120HZ. I don't have a DVI cable here, sorry.

    Edit. I also disabled CCC, because it causing my ACEEventlog at least 10 errors if I start it up. This happens cat 12.10 and 13.2beta. Don't know what's wrong with it, but I just ignore it because I don't need it.
     
    Last edited: Feb 7, 2013
  6. Lane

    Lane Ancient Guru

    Messages:
    6,361
    Likes Received:
    3
    GPU:
    2x HD7970 - EK Waterblock
    Anyway i confirm the fps gain on Crysis3 MP beta... hunter map 1920x1080 4xMSAA or 8xMSAA all VeryHigh ( include textures ) .. effectively scaling is much much better .. ( the 40% gain look totally right )

    No problem of smoothness anyway. for peoples with smoothness problem, try maybe 4MSAA or 2x SMAA and see if its the same. ( i use mostly 4xMSAA with it ) .
     
    Last edited: Feb 7, 2013
  7. Tyestor

    Tyestor Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    Gigabyte 6950 2GB
  8. usoldier

    usoldier Member

    Messages:
    41
    Likes Received:
    1
    GPU:
    Asus 970 Strix OC
    Well ive been in contact with catalist staff because of that and been running tests for them for 2 weeks now they reply to my every sugestion/question.

    So yeah i would use it.
     
  9. lmlim

    lmlim Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    AMD RX 480 @1.4Ghz
    HDMI audio is broken... !!! Arggh... going back to WHQL...13.1..
     
  10. w0mbat

    w0mbat Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    Sapphire HD7870
    I think it's cute that you have no idea what you're talking about.
     

  11. kazama

    kazama Master Guru

    Messages:
    309
    Likes Received:
    0
    GPU:
    MSI GTX 1080 X
    any download mirror? both seems down.
     
  12. Ppzek

    Ppzek Member

    Messages:
    34
    Likes Received:
    0
    GPU:
    MSI 6870
    Any Photoshop user, im currently using windos8 pro x64 and Photoshop keeps flickering, ive set it to basic mode etc and still have this annoying problem.im using 13.2 beta2 and had the same problem with 13.1.

    Cheers
     
  13. Dalton Sleeper

    Dalton Sleeper Member Guru

    Messages:
    116
    Likes Received:
    0
    GPU:
    2 x GTX 1080 8GB
    Link is down, did they pull it?
     
  14. teppic

    teppic Active Member

    Messages:
    92
    Likes Received:
    0
    GPU:
    MSI GTX 980
    b5 broke HDMI for me too, so I went back to b4.

    Maybe they're uploading a new beta, and have taken the link for 5 down for that reason.
     
  15. Dalton Sleeper

    Dalton Sleeper Member Guru

    Messages:
    116
    Likes Received:
    0
    GPU:
    2 x GTX 1080 8GB
    What kind of HDMI issues are you experiencing with B5? Completely unusable?
    If the sound is stuttering you can change the reg key "PP_SclkDeepSleepDisable" to 1...
     

  16. V1tol

    V1tol Master Guru

    Messages:
    284
    Likes Received:
    0
    GPU:
    MSI 1070 Gaming X
    Even on my card I noticed the difference between b5 and b4. Games are smoother now.

    Man, please use punctuation marks in your posts, because it's hardly readable.
    Why do you guys even touch that drivers? If they are working good, why you need to update them? And how audio driver depends on video driver? Why do you rollback video driver because of the problems with audio? I just don't get it. Are you afraid of using Device Manager to rollback just the HDMI driver? And then we are reading posts from trolls, that say AMD videocards are complete crap, and crapVidia just the best. :bang:
     
  17. mkh

    mkh Member Guru

    Messages:
    116
    Likes Received:
    2
    GPU:
    Asus 2080 Dual O8G
    hdmi audio driver doesn't start with the ones in beta 5 package. so i unistalled hdmi audio driver and manually installed audio driver from beta 4 package through device manager and now it's working just fine.
     
  18. kazama

    kazama Master Guru

    Messages:
    309
    Likes Received:
    0
    GPU:
    MSI GTX 1080 X
    I dont use hdmi so no problem for me, any dl link for beta 5?
     
  19. Dalton Sleeper

    Dalton Sleeper Member Guru

    Messages:
    116
    Likes Received:
    0
    GPU:
    2 x GTX 1080 8GB
    Is there any kind person in this thread who would like to waste a few minutes of their life to help another forum member, to upload the W7x64 driver to some accessible place that is? :)
     
  20. AbjectBlitz

    AbjectBlitz Ancient Guru

    Messages:
    3,462
    Likes Received:
    2
    GPU:
    R390 1200/1720
    Anyone have a mirror for these? official links are down atm.
     

Share This Page