AMD Catalyst 13.12 WHQL (13.251.0.0 December 18)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by MoKiChU, Dec 18, 2013.

  1. NJCermak

    NJCermak Member

    Messages:
    34
    Likes Received:
    0
    GPU:
    2x MSI GTX970
    I have a pair of Gigabyte WF3 HD7950 cards in crossfire (@ stock clocks of 1000/1250). I've also noticed the "screen jumping" while browsing the web. No difference whether or not hardware acceleration is enabled/disabled. However, I've also noticed an increasing frequency of this screen jumping glitch during main menus and FMVs in certain games. Most noticeably Rage and Civilization V. Plus many others that aren't quite as bad. Does anybody else get this? I remember older drivers not being nearly as bad in Civ V, alas, the problem has always been there since I've had the cards.
     
    Last edited: Dec 31, 2013
  2. ALPINEST4RS

    ALPINEST4RS Member Guru

    Messages:
    141
    Likes Received:
    0
    GPU:
    Gbyte 7970 GHZ 3GB
    Bad news... Stock clocks on the card, 13.9 drivers, screen glitching. I'm going to attempt DDU.

    Shame on me I use amd cleanup. :(

    EDIT: didn't fix it. RMA time??

    EDIT2: Moved clocks to 875/1000. Glitching gone..

    Is my card eating itself? I mean I should be good with 1100/1500, thats what I got it for lol.. ugh..

    I don't understand. Temps are fine under load (youtube, gaming, ect.) 60C.. I highly doubt its my psu failing. hmmm.
     
    Last edited: Jan 1, 2014
  3. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,864
    Likes Received:
    250
    GPU:
    EVGA GTX 1080Ti SC
    Troubleshooting at its best! :nerd:
     
  4. ALPINEST4RS

    ALPINEST4RS Member Guru

    Messages:
    141
    Likes Received:
    0
    GPU:
    Gbyte 7970 GHZ 3GB
    I got it. I was using CCC for clocking. I set a profile in afterburner 1200/1600. No glitching at all. I used afterburner for verifying clocks changed. If it was going to happen it would of started soon as I got on youtube. I don't know why it happened like that, but whatever it fixed it.

    Ya'll may flame away at me haha.:knock:

    Lesson learned.

    EDIT: F***. Oh well it seems everyone with GB cards got it. Hopefully something will magically happen.

    I did submit a report on behalf of us.... the GB 7970 users. :)
     
    Last edited: Jan 1, 2014

  5. ciastek164

    ciastek164 Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    Ati Radeon 8870 M / 2gb
    Hi everyone,

    I installed 13.12. Enduro (switchable graphics) works ok with my radeon 8870M.
    The problem is with preformance in some games. Every driver after 13.5. beta3 (works perfect) has poor performance in Medal of Honor Warfighter.
    13.12 have the same.
    For example in MOHW (first mission) : 13.5.b3 - around 47 fps
    13.12. - around 35 fps
    The same drop of performance is in multiplayer.

    Maybe someone have similar problem with games performance , or know what amd ati had changed in drivers?

    Regards,
     
  6. Elite3540

    Elite3540 Master Guru

    Messages:
    668
    Likes Received:
    0
    GPU:
    MSI GTX 970 GAMING 4G OC
    Try LeekM's driver:

    http://forums.guru3d.com/showthread.php?t=384844

    AMD Catalyst 13.12 Mobility WHQL SG Fix Driver (INTEL & APU)
    ____________________________________________________^
    ____________________________________________________(AMD CPU)
     
  7. ciastek164

    ciastek164 Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    Ati Radeon 8870 M / 2gb
    I've tested LeekM's drivers and Leshcat's . It's the same as Ati 13.12. poor performance in Medal of Honor Warfighter. Checked today one more time- last working perfect driver was 13.5.beta 3 for my 8870M.
    Every driver after it like 13.6. beta has poor performance. It looks like Ati have changed something in display driver ( maybe with clock gpu ) I didn't notice any big changes in realase notes between 13.5.beta3 and 13.6 I don't know what's happening.

    Maybe something wrong with game profiles or CAP ? Someone have an idea ?
     
    Last edited: Jan 2, 2014
  8. kevnb

    kevnb Master Guru

    Messages:
    365
    Likes Received:
    11
    GPU:
    Zotac 1070
    sometimes older games work better with older drivers.
     
  9. Elite3540

    Elite3540 Master Guru

    Messages:
    668
    Likes Received:
    0
    GPU:
    MSI GTX 970 GAMING 4G OC
    Well every card and set-up is DIFFERENT, you can't expect to always have the best results/improvements/tweaks/fixes/performance.

    If those drivers work the best for you, then stay with them.

    Maybe there will be improvements in the newer drivers, but we'll see about that.
     
  10. ciastek164

    ciastek164 Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    Ati Radeon 8870 M / 2gb
    I agree with you but it's very weird that every driver from 13.6 to 13.12 have the same fps around 35 and earlier driver 13.5.beta3 have 48-49 fps. The difference is ~27%. I've never met such a large difference in performance between drivers.
    For info - 13.5.beta3 was the first driver who officially supported 8870M
    (perhaps because of that had the best performance)
     

  11. Vinnie

    Vinnie Ancient Guru

    Messages:
    7,682
    Likes Received:
    18
    GPU:
    AMD R9 290X
    Anyone else having crackling sounds in games when having CFX enabled?
     
  12. ToBbErT

    ToBbErT Member Guru

    Messages:
    154
    Likes Received:
    0
    GPU:
    2x sapphire 7870
    Nope
     
  13. Elite3540

    Elite3540 Master Guru

    Messages:
    668
    Likes Received:
    0
    GPU:
    MSI GTX 970 GAMING 4G OC
    Indeed, then that is the best driver for the 8xxxM series video-cards.

    Also, I don't see/hear anything about the 8xxxM series that much, so maybe they likely are not supported that thoroughly.
     
  14. atoneapone

    atoneapone Active Member

    Messages:
    86
    Likes Received:
    0
    GPU:
    Radeon 6650M +6520g/ 1GB
    Also try Leekm 13.11b9.2 or 13.11b9.4 since I'm certain those were good for switchable gfx performance (but I have 6xxx series and not 8xxx series & don't have MOHW game; do other games also drop fps?)
     
  15. jaju123

    jaju123 Master Guru

    Messages:
    355
    Likes Received:
    3
    GPU:
    2x AMD R9 290 Crossfire
    Yes, it happens to those of us with crossfire in games with vsync enabled with r9 290 series cards.
     

  16. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,767
    Likes Received:
    734
    GPU:
    MSI 2070S X-Trio
    Yeah its normal, AMD forgot to update the Catalyst Version string, so it shows the previous drivers version you had on.
     
  17. Elite3540

    Elite3540 Master Guru

    Messages:
    668
    Likes Received:
    0
    GPU:
    MSI GTX 970 GAMING 4G OC
    Hmm but still, maybe try it with DDU (Display Driver Uninstaller)?:

    Link: http://forums.guru3d.com/showthread.php?t=379505
     
  18. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    MSI 980 TI Gaming
    Yes. Go back to 9.2 Beta and that problem will disappear.
     
  19. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    AMD left the string out of the install.

    supposedly they fixed over the holiday

    redownload the driver direcly from amd.
     
  20. Elite3540

    Elite3540 Master Guru

    Messages:
    668
    Likes Received:
    0
    GPU:
    MSI GTX 970 GAMING 4G OC
    Or you can just edit the number via the registry.
     

Share This Page