AMD Catalyst 13.12 WHQL (13.251.0.0 December 18)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by MoKiChU, Dec 18, 2013.

  1. ClockClocker

    ClockClocker Master Guru

    Messages:
    436
    Likes Received:
    7
    GPU:
    970 gtx
    Guess it's the game. I didn't install a new driver (still 13.11 b9.4)never had issues before and since the patch it crashed once when creating a lobby and join a game with a friend.
     
  2. shankly1985

    shankly1985 Master Guru

    Messages:
    503
    Likes Received:
    1
    GPU:
    RX VEGA 64
    Can Anyone confirm Vsync is fixed on this?
     
  3. NumB

    NumB New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    ATI Mobility Radeo HD5650
    Hi!

    A quick question: can I install the 13.12 mobility driver package for an ATI Mobility Radeon HD5650 gpu?

    I'm asking this because i see a note on the amd website:

    " ***Important!***

    Please note, that the AMD Catalyst Mobility driver package can only be installed on specific AMD Enduro platforms, that are second generation AMD A-series APU, or third generation Intel Core family based.

    Please note that all other platforms that do not include support for AMD Enduro Technology are supported through AMD Catalyst Mobility."

    Thanks in advance.
     
  4. djsebfr

    djsebfr Member Guru

    Messages:
    132
    Likes Received:
    0
    GPU:
    Nvidia GeForce GTX 950
    Fiiiiiiiiiiiiiiiiiiiiiixed !!!!!!
     

  5. shankly1985

    shankly1985 Master Guru

    Messages:
    503
    Likes Received:
    1
    GPU:
    RX VEGA 64
    Thanks
     
  6. Yopfraise

    Yopfraise Member Guru

    Messages:
    110
    Likes Received:
    0
    GPU:
    Aorus Ext 1080ti
    Nope.
     
  7. signex

    signex Ancient Guru

    Messages:
    8,803
    Likes Received:
    159
    GPU:
    NVIDIA RTX 3050 Ti
    Fixed.
     
  8. Elite3540

    Elite3540 Master Guru

    Messages:
    668
    Likes Received:
    0
    GPU:
    MSI GTX 970 GAMING 4G OC
    Sure, try and test them out.

    Code:
    AMD689C.3 = "AMD Radeon HD 5900 Series"
    AMD689E.1 = "AMD Radeon HD 5800 Series"
    AMD68B8.1 = "AMD Radeon HD 6700 Series"
    AMD68B8.2 = "AMD Radeon HD 5700 Series"
    AMD68B9.1 = "[U][COLOR="DarkRed"]AMD Radeon HD 5600/5700[/COLOR][/U]"

    Code:
    AMD68DA.11 = "AMD Radeon HD 5500 Series"
    AMD68E1.8 = "ATI Mobility Radeon HD 5000 Series"
     
    Last edited: Dec 22, 2013
  9. dizzin9

    dizzin9 Master Guru

    Messages:
    222
    Likes Received:
    14
    GPU:
    EVGA GTX 1080 Ti FE
    [​IMG]

    uninstalled beta 9.5 with DDU 9.90

    not really a big deal just wondering why the version # is not showing
     
  10. fredhayes

    fredhayes Member

    Messages:
    35
    Likes Received:
    0
    GPU:
    Powercolor 7950 x2
    I installed these drivers yesterday and have had nothing but problems with them.
    Ive had multiple BSOD during boot up and even trying to start MS Word.
    Ive uninstalled the old drivers and cleaned out the registry settings and old directories and then reinstalled them but the problem remains. Im rolling back to 13.11 Beta 4 (which I never had a problem with).
     

  11. primetime^

    primetime^ Master Guru

    Messages:
    909
    Likes Received:
    17
    GPU:
    Sapphire RX Vega 64
    Multiple bsod's duing bootup...lol i have never got a bsod form a graphics driver weather amd or nvidia...i wonder if there could be other issues:puke2:
     
  12. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,514
    Likes Received:
    2,912
    GPU:
    MSI 6800 "Vanilla"
    The version string is probably missing from these drivers so it's not added to the registry, I noticed mine says 13.11 which means it carried over from the registry info from the previous drivers and no new entry was provided. :)
    (Whereas if you do a clean install there won't be anything available so it turns up blank.)

    It's not really a issue as such, I guess AMD forgot it when they did these WHQL drivers.
    (Which seem to be just the latest 13.11 betas but certified.)
     
  13. NumB

    NumB New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    ATI Mobility Radeo HD5650
    I've installed the driver (seems the hardware id is 68C1) and it works pretty good, however in-game the 13.9 driver worked better, or so at least i think. :(
     
  14. Elite3540

    Elite3540 Master Guru

    Messages:
    668
    Likes Received:
    0
    GPU:
    MSI GTX 970 GAMING 4G OC
    Yeah that can be,

    it's different for all users.

    But I'm glad it works on your laptop, some drivers don't even work on the most laptops/(PCs). :3eyes:

    Have fun playing!
     
  15. k37chup

    k37chup Member Guru

    Messages:
    113
    Likes Received:
    4
    GPU:
    MSI 2080 Ti XTrio

    Looks like it be a year before they fix this, just like with mouse lag :mad:
     

  16. jaju123

    jaju123 Master Guru

    Messages:
    355
    Likes Received:
    3
    GPU:
    2x AMD R9 290 Crossfire
    What's the mouse lag problem? :O First I heard about this!
     
  17. Dch48

    Dch48 Ancient Guru

    Messages:
    1,822
    Likes Received:
    1
    GPU:
    Sapphire Nitro+ RX 470 4g
    I had the 13.11 9.5 beta installed and just used the Catalyst Install manager to uninstall everything but my chipset and USB drivers. I rebooted and the machine loaded up the original driver that came pre-installed on it. It was 11.9 without the CCC. I then installed 13.12 over that without a hitch. I checked the registry and there were no issues. I usually just install a newer driver over the top of the old one and have never had a problem doing it that way. (I installed the 13.11 beta over 13.4) I only uninstalled 13.11 before going to 13.12 because it was a beta. I will also uninstall if I'm going back from a newer driver to an older one like when I reverted from 13.9 back to 13.4. I have never seen a need for any driver removal utilities.

    The one thing I notice is that I now have the regular CCC instead of the Vision Control Center that I had with all of the mobility driver sets up to and including 13.4. I wonder if AMD has done away with Vision or just forgot to add it in to the newer mobility packages.
     
    Last edited: Dec 23, 2013
  18. mux

    mux Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    GTX 1070
    I'm having somethings the same issue with AMD_Catalyst_13.11_BetaV9.5. I guess then, it is yet not fixed. (BSOD without a crash dump)
     
  19. OldMX

    OldMX Member

    Messages:
    46
    Likes Received:
    3
    GPU:
    PNY GTX 1660
    Microsoft just pushed this release on Windows Update.
     
  20. Coldblackice

    Coldblackice Member Guru

    Messages:
    127
    Likes Received:
    0
    GPU:
    EVGA 3080 FTW3
    What does the BSOD say? Like the name of the fault and the error code?
     

Share This Page