AMD Catalyst 13.1 (9.012.0 December 19) AMD Official WHQL

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Jan 17, 2013.

Tags:
  1. delhan

    delhan Member Guru

    Messages:
    164
    Likes Received:
    0
    GPU:
    VTX 3D HD 7870
    I have been always had "the graphics card driver crashed" ("and recovered") with AMD/ATi since i built this PC, starting with 5850, now 7870 and all intermediate drivers and clean uninstalls / installs. But with 13.1 its more often than ever before (since 2009). and half the times is not "recovered" happening in middle of gaming totally ruining it.

    Win7 64
     
  2. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    Try without using CCC (Catalyst Control Center), if continues, try to update drivers for chipset etc, it's strange it happens on all drivers, and you always have that problem, it suggest is something else, not driver itself.
     
  3. delhan

    delhan Member Guru

    Messages:
    164
    Likes Received:
    0
    GPU:
    VTX 3D HD 7870
    Thanks. It would happen even by just browsing, crashing the flash in Chrome. It hadn't happened though for some time in gaming until it made its presence more frequent with 7870 and 12.xx and got worse with 13.1 which 13.1 also made video playback having some issues, choppy full screen .ogm playing, momentary youtube freezes. P55 chipset has latest drivers for ...some time now :p lol

    when i will find the time and patience will try memtest
     
  4. tweakpower

    tweakpower Banned

    Messages:
    932
    Likes Received:
    0
    GPU:
    MSI HD 6770
    Yeah, you should try memtest, but other than that, it can be that GPU have some problems, you should also test GPU for errors (I don't know how to do it, programs for artifacts etc, not sure, someone here knows it for sure).
     

  5. BravoFxTrt

    BravoFxTrt Member Guru

    Messages:
    168
    Likes Received:
    0
    GPU:
    2X MSI R9 280X 6GB
    I play IL2 1946 and CloD, These drivers are working spot on! Thanks for posting them! :)
     
  6. delhan

    delhan Member Guru

    Messages:
    164
    Likes Received:
    0
    GPU:
    VTX 3D HD 7870
    I got hickups and stutters on CloD with these ...
     
  7. Vengeful#1

    Vengeful#1 Member Guru

    Messages:
    169
    Likes Received:
    0
    GPU:
    Sapphire HD7970 OC 3GB
    I got stutters and slow downs in GW2 with these, am now switching to 13.2 Beta 3 to test.
     
  8. Daoer

    Daoer New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ATI Mobility Radeon5650HD
    Hey, thank you for your work. Can i assume the Mobility 5650 HD is not supported by anyone anymore? Can't find it neither in these releases, neither in the legacy releases.

    Thank you for the info, in advance, cheers,

    Daoer
     
  9. Daoer

    Daoer New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ATI Mobility Radeon5650HD
    Please do report how it goes. Playing it currently.
     
  10. hispanico

    hispanico Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    HD 5870
    I installed these drivers and now chrome and coolnovo (chrome plus) after a while stopped to load pages.
    I comeback to drivers 12.11 beta 6 and the problem desappeard...

    Hispa
     

  11. slickboy

    slickboy New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ATI MobilityRadeon HD3470
    Hi!

    Is it possible to add support manually to this driver of the ATI Radeon Mobility HD 3400 series? I would like to install it because damned firefox requires this version for GPU acceleration... but natively this driver doesnt support my card... thank is advance.
     
  12. MrDiligent

    MrDiligent New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Corsair Vengence
    This driver is a Disaster for me. I get total display corruption on Carrier Command Gaea Mission using Crossfire. This is using xfx 6950's.
     
  13. Deathchild

    Deathchild Ancient Guru

    Messages:
    3,970
    Likes Received:
    2
    GPU:
    -
    Hey nice videocard you got there man.
     
  14. lothyr

    lothyr Member

    Messages:
    24
    Likes Received:
    0
    GPU:
    EAH 6850 DC
    13.1 CCC & Vision O/C

    Hey Guys,

    Thanks so much for providing drivers and info.

    After months of problems with various games {BF3/Tribes/Metro} it would seem my old PC is finally working great!

    I'll admit most of the problems were results of my attempts to tweak & O/C it would seem.

    Got to the point where BSODs were just another chance to tweak BIOS settings.

    Other day I finally got tired of wondering if my dubious {ok, hacked} Win 7 install was causing issues due to selective Microsoft update choices.

    Ebayed a product key for $25 {haha - there ya go Bill G., after 10+ years you finally got some of my money} and after conquering the "No CD/DVD driver" problem installed a legal copy of Win 7 via USB thumb drive.

    Installed 13.1 and o/c'd via Vision. Not a huge bump, but 3.4 Ghz to 4.1 Ghz on CPU and 790 Ghz to 900 Ghz on GPU is not too shabby.

    Downloaded BF3 and was really surprised. It basically ran with no tweaks/fixes/workarounds/configs/head banging/PunkBuster error, etc. etc.

    Am seeing very tight perfOverlay and FPS in the 80-90 range.

    Next up is Metro 2033 & Tribes Ascend w/ a SSD upgrade. Is it just me or has life just gotten a lot less stressful :)
     
  15. Giana

    Giana New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ATI Radeon 3100 32 bit
    I am getting this from 13-1-legacy_vista_win7_win8_32_dd_ccc update and don't know
    how to fix it i have already done the new install and i get the same thing.
    ati radon 3100 32 bit

    <error><MSG>Driver Install: the driver package does not specify a hardware identifier</MSG></error></monetreport>
     
    Last edited: Apr 10, 2013

  16. campcreekdude

    campcreekdude Master Guru

    Messages:
    247
    Likes Received:
    0
    GPU:
    Radeon 7970 crossfire
    Installed 13.12 in windows XP

    Installed the windows XP version of the 13.12 drivers and they are not certified. As the pop-up says.

    Installed them anyways and it runs fine... so far!

    The only reason I upgraded from 13.9 is because I got a 'atiman" blue screen of DEATH in windows XP.

    After updating drivers I have not come across Blue Screen of Death yet. But I was running 13.9 for so long without BSOD... oh well.

    Radeon 7970 Windows XP 32-bit.
     

Share This Page