AMD Catalyst 12.8 (8.982.0 July 27) AMD Official WHQL

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Aug 15, 2012.

Tags:
  1. k1net1cs

    k1net1cs Ancient Guru

    Messages:
    3,783
    Likes Received:
    0
    GPU:
    Radeon HD 5650m (550/800)
    Still downloading it.
    I'll get back here after I test things out.
     
  2. Prasad1337

    Prasad1337 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970M
    Thanks! :) And yes, I'm getting a 404 on the release notes as well..
     
  3. zer0_c0ol

    zer0_c0ol Ancient Guru

    Messages:
    2,976
    Likes Received:
    0
    GPU:
    FuryX cf
    i have no mozzila rendering problem

    could it be maybe some problems with flash?
     
  4. AbjectBlitz

    AbjectBlitz Ancient Guru

    Messages:
    3,462
    Likes Received:
    2
    GPU:
    R390 1200/1720
    Crossfire does not work in Rage with these.
     

  5. The Goose

    The Goose Ancient Guru

    Messages:
    2,348
    Likes Received:
    56
    GPU:
    MSIrtx2080 superXS
    spoiler working fine and fast d/l
    will report my findings
     
  6. Xman01

    Xman01 Active Member

    Messages:
    78
    Likes Received:
    3
    GPU:
    Gigabyte 1070 Mini
    I hope that you have a tent handy :)
     
  7. clexzor

    clexzor Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    7870
    Just installed on 7 64bit 7870msi oc bf3 playing same as previous drivers everything seems ok so far no black screen yet. ;]
     
  8. deathfrag

    deathfrag Master Guru

    Messages:
    301
    Likes Received:
    0
    GPU:
    R9 Fury Strix(Unlocked)
    black screen with diablo 3 after 5mn !!!!
     
  9. Simkin84

    Simkin84 Member Guru

    Messages:
    124
    Likes Received:
    0
    GPU:
    2X MSI HD 7970 @1150/1600
    Hm, Waterfox was new to me.. i'll try it out.
     
  10. patCRUZ

    patCRUZ New Member

    Messages:
    1
    Likes Received:
    0
    I Need some help here...
    I'm having some problems. I made all the habitual procedures...

    Uninstaled the older version - restarted - driver fusion - restart - install new drivers AMD Catalyst Mobility 12.8 Win 8 | Win 7 | Vista (64-bit)

    After the last boot when I try go to CCC pops up a error alert:

    [​IMG]

    Clevo P150EM + AMD 7970M.
    Any sugestions? AMD 7970M not supported? :bang:
     

  11. alphaproxima

    alphaproxima Active Member

    Messages:
    71
    Likes Received:
    0
    GPU:
    ATI 5850 @1040/1200
    Its so weird, I see people having flash problems in 2012. Flash is broken since more than a year now. I always have hardware accel disabled, and as far as that is concerned, I blame flash not ATI drivers. Flash player is the most buggy s/w Ive seen in my life, along with daggerfall and NWN.
     
  12. Gap51

    Gap51 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ASUS 5870 1Gb
    I started setup and nothing happen on Win8x64
     
  13. k1net1cs

    k1net1cs Ancient Guru

    Messages:
    3,783
    Likes Received:
    0
    GPU:
    Radeon HD 5650m (550/800)
    I just installed it, and it installs fine.
    I'm guessing your trouble is from the installer detecting an unsupported generation of GPU (4xxx) on your APU.
    Have you tried a manual update via Device Manager?


    Funny thing is, 11.11c works fine with Flash Player 11.2, 11.3, and 11.4 Betas when hardware acceleration is enabled.
    Any Catalyst after that is b0rking it, at least on video playback.


    So, my report.

    The driver doesn't crash WinSAT formal media test anymore; a step forward!
    Still f*cks up DXVA (blank video) and hardware-accelerated Flash video playback (green video), but at least it's getting there. Slowly.
    Since I use madVR and hardware acceleration on Flash video is a bit moot since my CPU can handle them just fine, I guess I'll keep this set.
    No crashes nor grey, black, or 50-shades-of-grey (wet?) screen with hardware acceleration on browsers, but that had never been a problem I have anyway.
     
  14. NiColaoS

    NiColaoS Master Guru

    Messages:
    598
    Likes Received:
    41
    GPU:
    GTX 1660 Super
    Flash on Firefox has known problems. Start by disabling Protected Mode.

    http://forums.adobe.com/thread/1018071 Go directly at the bottom: Last resort

    Also, I wouldn't trust as much Fx's HWA. If you get the same errors on IE9 with HWA enabled, then O.K. Otherwise, I'd blame Firefox firstly.

    By the way, with RC1 and this set, I don't have problem. I use Fx 14 and Nightly 17 ( with newer 'better' HWA ). No grey/black screens. I used to get grey with vertical stripes etc screens on Firefox with 25/26June beta drivers and mostly when my card was overclocked. Not anymore.

    Might be time for a 'Firefox Reset Profile' or even Windows clean installation for some.
     
    Last edited: Aug 15, 2012
  15. Bhudda

    Bhudda Master Guru

    Messages:
    207
    Likes Received:
    15
    GPU:
    Aorus 1080ti
    Why July 27th, we're in August :3eyes:

    Thanks as always op
     

  16. Simkin84

    Simkin84 Member Guru

    Messages:
    124
    Likes Received:
    0
    GPU:
    2X MSI HD 7970 @1150/1600
    No doubt Flash is garbage, but i dont blame flash for my games to freeze ;)
     
  17. k1net1cs

    k1net1cs Ancient Guru

    Messages:
    3,783
    Likes Received:
    0
    GPU:
    Radeon HD 5650m (550/800)
    IIRC, that has been fixed with subsequent releases after the first official 11.3.
    I don't really get those problems with 11.3 even though I use Waterfox daily and usually go to YouTube or Vimeo.
    Now I use the 11.4 beta, though.
     
  18. juzz

    juzz Member

    Messages:
    35
    Likes Received:
    0
    GPU:
    MSI 1080TI Sea Hawk EK X
    Thats WHQL for you. Takes bloody forever for MS to certificate the drivers :bang:

    Thats why I rarely even bother installing WHQLs as they have the old bugs you already seen with beta drivers earlier :puke2:


    As for flash problems with firefox I wouldn't touch 11.3.x builds. They all broken for me. Also the uninstaller in "uninstall programs" doesn't work properly (some crap gets left behind and new build installs get broken also) if your player gets broken. If you are having problems download flash uninstaller from adobe site and after that try either 11.4 betas or revert back to 11.2.x. Don't try installing 11.4 betas over 11.2 or 11.3 builds. It will most likely break the install.
     
    Last edited: Aug 15, 2012
  19. The Mac

    The Mac Ancient Guru

    Messages:
    4,408
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    just use revo uninstaller to get rid of it, much easier.
     
  20. Portman87

    Portman87 Member Guru

    Messages:
    125
    Likes Received:
    2
    GPU:
    HD 7950 1000/1425
    Will there be Beta and WHQL like last time ?
     

Share This Page