AMD Catalyst 12.4 (8.961 April 5) AMD Official WHQL

Discussion in 'Videocards - AMD Radeon Drivers Section' started by kyz, Apr 25, 2012.

  1. net.cat

    net.cat Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI
    since they are older ... are better than the 8.97 one?
     
  2. Saekerhett

    Saekerhett New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    MSI HD6850 1GB
    I saw them since yesterday and I see them now...
     
  3. Sharoth

    Sharoth Master Guru

    Messages:
    722
    Likes Received:
    3
    GPU:
    Aorus RTX 2080 OC
    Saints Row The Third runs great here, no issues at all.
     
  4. xacid0

    xacid0 Master Guru

    Messages:
    443
    Likes Received:
    1
    GPU:
    Zotac GTX980Ti AMP! Omega
    On 12.3 my GPU stucked at 3D mode and for 12.4 it stucked on IDLE mode.. i can guess which mode it will stuck for 12.5. :D
     

  5. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,717
    Likes Received:
    6
    GPU:
    GTX 1080 Amp!
    With february 24th drivers I get 100+ fps in BF3 @ 1080p (without Vsync, motion blur or AA, everything else on ultra, textures on high) in almost any map ... lowest fps I get is 70. for the sake of smoothness and lower temps and power consumption, I use Vsync, though.
    I still don't want to go above 12.3 drivers as they are rubbish.
    I want to hear more feedback from someone using 6000 series CF
    so, for now 8.95.5 drivers for me
     
  6. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,717
    Likes Received:
    6
    GPU:
    GTX 1080 Amp!
    you need to download a .DLL...

    The correct name of the .dll is "atipdlxx.dll". If you want, use mine, I uploaded the dll from 12.1 WHQL. http://www.mediafire.com/?eof9egy3374ytk2
    Just copy it to C:\Windows\SysWOW64 and Clocks should work again. I needed to do this for Trixx and Afterburner, they would not get my default clocks otherwise. After copying the dll it worked.
    This solved my problem.
     
  7. Ryu5uzaku

    Ryu5uzaku Ancient Guru

    Messages:
    7,026
    Likes Received:
    242
    GPU:
    6800 XT
    well for me install goes black i reboot and install again it goes w/o problems O_O :D
     
  8. Krogtheclown

    Krogtheclown Master Guru

    Messages:
    960
    Likes Received:
    0
    GPU:
    FuryXfire 3440x14freesync
    Thanks ya it figures......damn you AMD they should have just told us this and I wouldn't have wasted 2 months trying to fix ****!
    Now I'll will try and return as many cards as possible or wait till 12.5.
     
  9. Lane

    Lane Ancient Guru

    Messages:
    6,361
    Likes Received:
    3
    GPU:
    2x HD7970 - EK Waterblock
    What card are you using ? .. I remember have got this, reinstall windows and was perfect then, i suspect something with my registry was broken somewhere.
     
  10. BenchAndGames

    BenchAndGames Member Guru

    Messages:
    188
    Likes Received:
    7
    GPU:
    ASUS GTX 780

    It is very rare, I'm seeing in Google Chrome's 12.3, and the Internet Explores the 12.4

    I do not understand :)
     

  11. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,717
    Likes Received:
    6
    GPU:
    GTX 1080 Amp!
    the cherry of this thread :banana:
     
  12. Saekerhett

    Saekerhett New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    MSI HD6850 1GB
    I do, Chrome uses your internet cache instead of reloading a new page.
    Try to reload the page with Ctrl + F5.
     
  13. xacid0

    xacid0 Master Guru

    Messages:
    443
    Likes Received:
    1
    GPU:
    Zotac GTX980Ti AMP! Omega
    oh wow.. i'll try that next time. thank you very much. :nerd:
     
  14. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,717
    Likes Received:
    6
    GPU:
    GTX 1080 Amp!
    No problem. It seems that any AMD driver above 12.1 haven't got this crucial file for the video driver to detect correct clocks from VGA bios... so they get stuck at 3D or idle clock all the time...
    Hope it helps.
     
  15. Laykun

    Laykun Ancient Guru

    Messages:
    3,208
    Likes Received:
    0
    GPU:
    2 x EVGA GTX670 4GB
    No fix for trifire eyefinity. Currently using 11.12 as it's the only stable driver for my setup that allows me to launch games at 5760x1200 :S
     

  16. DethZero

    DethZero Active Member

    Messages:
    60
    Likes Received:
    2
    GPU:
    EVGA 1080Ti SC2
    I just ran Skyrim yesterday for a few hours and I'm playing Ultra settings. Initially with the 12.4, I had fps between 20 and 30. Then I went into the CCC and put everything on application. now it pretty much runs 60fps everywhere. Sometimes when I turn it will dip to 50fps but only for like a split second.
     
  17. Krogtheclown

    Krogtheclown Master Guru

    Messages:
    960
    Likes Received:
    0
    GPU:
    FuryXfire 3440x14freesync
  18. UZ7

    UZ7 Ancient Guru

    Messages:
    5,522
    Likes Received:
    66
    GPU:
    GB Vision 3080 10GB
    Actually I just booted my game and I was also getting low fps and when I alt tabbed into CCC and tabbed back the clocks kicked in and I got full fps after that. From 12.3WHQL to 12.4 I saw about a 3-4fps boost. (1920x1080/Whiterun/Ultra presets)
     
  19. masterchan777

    masterchan777 Master Guru

    Messages:
    261
    Likes Received:
    0
    GPU:
    GTX 1070 OC
    My routine check list with every new Catalyst :

    - 2D/3D clock bug with the 2nd GPU: check
    - Catalyst Control Center slow startup and randomly crashing : check
    - Random green screen when playing Flash content in web browsers : check
    - Latest AMD APP (a.k.a AVIVO) isn't compatible with GPGPU transcoding software : check
    - Choppy WMV-HD video playback with Windows Media Player : check

    But I have to say that I am having less BSODs with these, so don't say I am not trying to be positive about this new release of Catalyst drivers ...
     
  20. adrock311

    adrock311 Master Guru

    Messages:
    793
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 SC 8gb
    that is crazy if true, I mean how can they be that stupid? I've been having major problems with the clocks not returning to idle after exiting games!
     

Share This Page