AMD Catalyst 12.4 (8.961 April 5) AMD Official WHQL

Discussion in 'Videocards - AMD Radeon Drivers Section' started by kyz, Apr 25, 2012.

  1. Valagard

    Valagard Guest

    *Finally gets impatient waiting for new drivers*

    Jesus christ AMD, its been two freaking months and no new drivers. WTF is the god damn hold up?

    Not even leaked beta's, like WTF happened? AMD as I heard was dominating the market with the 7970 because Nvidia can't produce the 670 or 680 in anywhere near reliable numbers, yet driver support is lacking

    Waiting a month between driver releases? Fine, that's -STANDARED OPERATING CONSUMER ELECTRONIC AND SOFTWARE OPEARTING POLICY-, its to allow tech support time to train current support staff to handle new questions for new software updates etc. That's why Microsoft has "Patch Tuesday" where they wait the second tuesday of the month to issue all big updates.

    But its been TWO months now, and no new drivers. Yeah honestly this is pissing me off. My 7970 isn't having graphic glitches, but sometimes it has problems. Like Minecraft, can be staring off at the entire world at 500FPS and 40% GPU use, turn around and look through a small glass building, framerate drops to 90 and 100% GPU use
     
  2. Thalyn

    Thalyn Member Guru

    Messages:
    113
    Likes Received:
    7
    GPU:
    ASUS Strix GTX 980 DCU2
    Perhaps you've been in a time loop, Valgard, but 12.4 was released on April 25 - that's less than a month ago. Then there was 12.3 on March 28, which is also less than two months ago. That doesn't include hotfixes, release candidates and leaks.

    I'm sure they've had plenty of other beta/alpha versions which haven't been leaked in between.
     
  3. moheban79

    moheban79 Master Guru

    Messages:
    239
    Likes Received:
    1
    GPU:
    XFX 6970 - 2GB Trifire
    How right you are!

    I completely agree. Xfire is for the birds. Wont ever do that again!
     
  4. Valagard

    Valagard Guest

    They were released on April 25th, but they were made on April 5th
     

  5. Caenyss

    Caenyss Active Member

    Messages:
    71
    Likes Received:
    21
    GPU:
    RogStrix Vega 56 OC
    So? April is still April right? I really don't see the problem here. It's 1 driver release per month as it has been.
     
  6. chinex9a

    chinex9a New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    ATI Mobility Radeon 5870
    I have this issue with 12.4 too
     
  7. Thalyn

    Thalyn Member Guru

    Messages:
    113
    Likes Received:
    7
    GPU:
    ASUS Strix GTX 980 DCU2
    Which is still less than two months ago.

    Does it really matter all that much when a driver is made if we don't have access to it until it's released? Otherwise you could have made the argument with 12.4 that there hadn't been any new drivers for three weeks immediately after installing what is effectively a new set.
     
  8. Espionage724

    Espionage724 Guest

    Are these WDDM 1.2 compatible on Windows 8?

    Edit: They are
     
    Last edited by a moderator: May 24, 2012
  9. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    2
    GPU:
    570m / MSI 660 Gaming OC
    what a waste of power & heat... force vsync on, it's so much smoother even when it's loading parts of the map

    force AA & AF while you're at it

    & play with the advanced opengl option, it seems to lower fps for me, so i dont see the point of having it on

    i have the performance option set to 'balanced' for some reason too :program:
     
  10. Thalyn

    Thalyn Member Guru

    Messages:
    113
    Likes Received:
    7
    GPU:
    ASUS Strix GTX 980 DCU2
    Actually, forcing AA or AF in Minecraft is often what leads to the white lines being visible around non-block items. Perhaps not noticeable if you're using the default textures or a 32x32 pack, but very obvious if you're using 256x256.

    But it does work nicely using MLAA in conjunction with the Optifine mod.
     

  11. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    2
    GPU:
    570m / MSI 660 Gaming OC
    ya, i have to deal with those lines since i dont have MLAA, & there's no ogl injector

    you know what, someone must have made a shader mod by now... afterall, it's a simple post process
     
  12. janluk

    janluk New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Sapphire HD7970 OC dual-x
    Hello everyone!

    I have a problem with Eyefinity, (see video1, video 2).
    I changed cables, settings, etc..
    Drivers may be a problem?
    Thanks for the reply.
     
    Last edited: May 26, 2012
  13. moheban79

    moheban79 Master Guru

    Messages:
    239
    Likes Received:
    1
    GPU:
    XFX 6970 - 2GB Trifire
    12.4 caps work on 12.3 driver?

    Anyone know if its possible to install 12.4 caps over 12.3 driver?

    Thanks :)
     
  14. Ikyo

    Ikyo New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    6970 x 2
    I tried the 12.4b drivers and there is still the issue of the second card not running past idle clock speed.
     
  15. Ikyo

    Ikyo New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    6970 x 2
    I am checking a few things and might have noticed what is causing it. It is possibly an issue with disabling ULPS. I was testing the 12.4 driver after doing:

    1. Enabling ULPS
    2. Removing All ATI Drivers
    3. Booting into safe mode and running driver sweeper
    4. Installed 12.2
    5. Upgraded to 12.4
     

  16. Ikyo

    Ikyo New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    6970 x 2
    The issue is with disabling ULPS in the 12.4 driver. When I disabled it, my second card will stay at 250/150. Looks like ATI did a change to the way ULPS works.
     
  17. Babel-17

    Babel-17 Member Guru

    Messages:
    151
    Likes Received:
    14
    GPU:
    Gigabyte RTX 3080
    I have the same problem also. I logged the issue with AMD but I don't see anyone official confirming that they are on the case. That's annoying.
     
  18. PerfectCr

    PerfectCr Active Member

    Messages:
    82
    Likes Received:
    0
    GPU:
    MSI GTX 980 Gaming 4GB
    PCIE Link Speed 1x vs. 16x

    Ok, I was having FPS problems in Skyrim, but only at certain times. So I finally narrowed down the issue. With the 12.4 Drivers, with a brand new XFX 7850, the PCIE speed goes from 16x to 1x upon letting the monitor sleep. (verified with GPU-Z). The only way to fix it to get back to full speed is to either reboot, or change resolutions on your monitor (yep!).

    It was wired because I can play Skyrim on ULTRA at certain times but not others. I googled and found one thread over at [H] talking about the same issue. (http://hardforum.com/showthread.php?t=1684684). Seems like a driver issue. This is a brand new build on an ASUS P8Z77-V PRO. PCIE power saving features have been disabled in Windows, and PCIE is chosen as the primary GPU in the BIOS. GPU-Z still reports PCIE speed dropping to 1x (and not returning to 16x) after monitor sleep. Seems like a driver bug. Is there a way to report this to AMD/ATI? Anyone else seeing this and checking it in GPU-Z?
     
  19. BenchAndGames

    BenchAndGames Member Guru

    Messages:
    190
    Likes Received:
    9
    GPU:
    RTX 3070 SUPRIM X
    When relase 12.5 WHQL? It is the date ...
     
  20. Valagard

    Valagard Guest

    I love even if i don't install the HDMI audio drivers, I think it installs them anyways

    Cause after a reboot of drivers being installed, with my 7970 ASUS Direct CU II TOP edition I see -SIX- HDMI audio devices being installed since I have six outputs
     

Share This Page