AMD Catalyst 12.3 RC (8.950.0 February 14) AMD Official BETA

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Feb 15, 2012.

Tags:
  1. DStealth

    DStealth Master Guru

    Messages:
    323
    Likes Received:
    29
    GPU:
    MSI GX 1080Ti@2088/12000
    Workin fine here too, no probs at all.
    Benching 1300/1930 with AB and unofficial OC enabled :nerd:
     
  2. krishnarama108

    krishnarama108 Master Guru

    Messages:
    288
    Likes Received:
    0
    GPU:
    asus ati 5850 1gb 850mhz
    they change OC mechanics, so yu must wait for updated softies....
    msi ab oc also works only manualy, but works!
     
  3. V-FrIeNd

    V-FrIeNd Member Guru

    Messages:
    142
    Likes Received:
    0
    GPU:
    GTX 750Ti
    Last edited: Feb 16, 2012
  4. LBJM

    LBJM Member Guru

    Messages:
    104
    Likes Received:
    8
    GPU:
    latest green team
    @V-FrIeNd I get the same problem :(


    (I can't stress this enough) As always with video card drivers do a clean driver install...

    Here's how:

    Get the latest Driver Sweeper the guru3d version is out of date. AS of this post 3.2 is the latest. Guru3d is blocking


    LINK REMOVED - TAKE THE HINT WHEN SOMETHING IS BLOCKED PLEASE<-- newest version will always be there.


    And then DO this:


    1)Uninstall video card drivers in normal mode.
    2)Reboot into safe mode.
    3)run driver sweeper and clean the AMD - Display. If you are switching brands (uninstall Nvidia drivers in the first step) choose Nvidia - Display as well.
    4)Reboot in normal mode.
    5)Reinstall new video card drivers drivers.
    reboot->> If CCC doesn't load or acts funny reboot again.
     
    Last edited: Feb 16, 2012

  5. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    asder, if you got some spare time could you please re-upload this driver with a inf that supports 6900M Series cards?

    If that's the case, I hope he would have a look into the Skyrim face/yellow flickering issue introduced in the 11.11 driver. Just rolled back and the 11.10 driver has neither of those issues. I'd love to see a fix in the next set of drivers so I don't have to stick with the old ones :p
     
  6. gaul

    gaul Active Member

    Messages:
    80
    Likes Received:
    0
    GPU:
    6870
  7. JonnyCasino

    JonnyCasino Master Guru

    Messages:
    413
    Likes Received:
    0
    GPU:
    1GB ATI 5650 Mobility
    Also running a 5650m in a Sony Vaio E Series, currently running these 12.3 drivers, previously 12.1 and no issues with any video format or flash whatsoever, my install method was simply to uninstall previous driver, restart and install latest.
     
  8. Carbonic

    Carbonic Member

    Messages:
    41
    Likes Received:
    11
    GPU:
    1080ti
    Work in Skyrim, you little #"¤"%"¤%"#¤"! !

    So, these drivers causes heavy artifacting for me in Skyrim. Any with similar problems and have any solved it?

    However, best drivers I've had in BF3 :/ - oh the Dilemma!
     
    Last edited: Feb 16, 2012
  9. streakpt

    streakpt Master Guru

    Messages:
    277
    Likes Received:
    0
    GPU:
    Sapphire 290 Crossfire
    How are these drivers on BF3? I'm still at work...
     
  10. k1net1cs

    k1net1cs Ancient Guru

    Messages:
    3,783
    Likes Received:
    0
    GPU:
    Radeon HD 5650m (550/800)
    Been able to play that for ages...on 11.12 and under.
    On newer Catalyst versions, not so much; always the same blank video problem.


    Personally, I just don't call uninstalling with AMD's own uninstaller is a clean uninstallation.
    My definition of 'clean uninstallation' is to (express) uninstall normally and then using either Driver Sweeper or TwL's cleaner, but that's just my preference; you'd be surprised how many things are left lying around by AMD's uninstaller.

    But then again, it might be something worth pursuing.
    I'll try having a normal uninstallation without Driver Sweeper and/or TwL's cleaner, then just simply slap a newer one.
     

  11. Falkentyne

    Falkentyne Master Guru

    Messages:
    521
    Likes Received:
    60
    GPU:
    Sapphire HD 7970 Ghz Ed.
    Ok. Afterburner and Trixx are working. They *ONLY* work if you do an upgrade install (from the Supersampling dx10 driver). Doing an uninstall with ati's own installer and then using these drivers=no Trixx or AB overclocking and cards shown in ULP mode. Same thing for atiman uninstaller...

    But of course, if you use the uninstaller or atiman uninstaller and then install the supersampling drivers clean, that driver works perfectly with Trixx and AB unofficial mode....

    Spyre, you might want to report this... ;)
    (First time I've ever seen problems doing an uninstall install...:/)
     
  12. jazz9

    jazz9 Member

    Messages:
    22
    Likes Received:
    5
    GPU:
    RTX 2070
    Didn't try this driver yet but with the previous 12.3rc I couldn't set powertune at 20%.
    Everytime time I hit apply it would just reset to 0% (I'm using trixx to o/c my 6950@70).
    Any one experiencing the same thing wit this one?
     
  13. asder00

    asder00 Don Di Driver Staff Member

    Messages:
    1,193
    Likes Received:
    3
    GPU:
    RX VEGA 64 Liquid
    MobilityMod to the rescue!

    Supported Cards:
    AMD6741.1 = "AMD Radeon 6600M and 6700M Series"
    AMD6763.1 = "AMD Radeon E6460"
    AMD9803.1 = "AMD Radeon HD 6250 Graphics"
    AMD9805.1 = "AMD Radeon HD 6250 Graphics"
    AMD9807.1 = "AMD Radeon HD 6290 Graphics"
    AMD68E5.1 = "AMD Radeon HD 6300M Series"
    AMD68E4.1 = "AMD Radeon HD 6300M Series"
    AMD9802.1 = "AMD Radeon HD 6310 Graphics"
    AMD9804.1 = "AMD Radeon HD 6310 Graphics"
    AMD9806.1 = "AMD Radeon HD 6320 Graphics"
    AMD9643.1 = "AMD Radeon HD 6380G"
    AMD6760.1 = "AMD Radeon HD 6400M Series"
    AMD6761.1 = "AMD Radeon HD 6430M"
    AMD9648.1 = "AMD Radeon HD 6480G"
    AMD68C1.1 = "AMD Radeon HD 6500M/5600/5700 Series"
    AMD9647.1 = "AMD Radeon HD 6520G"
    AMD68C0.1 = "AMD Radeon HD 6570M/5700 Series"
    AMD6750.1 = "AMD Radeon HD 6600A Series"
    AMD9641.1 = "AMD Radeon HD 6620G"
    AMD6740.1 = "AMD Radeon HD 6700M Series"
    AMD68A8.1 = "AMD Radeon HD 6800M Series"
    AMD6720.1 = "AMD Radeon HD 6900M Series"
    AMD6742.1 = "AMD Radeon HD 7500/7600 Series"
    AMD9649.1 = "AMD Radeon(TM) HD 6480G"
    AMD9713.1 = "ATI Mobility Radeon 4100"
    AMD94C9.1 = "ATI Mobility Radeon HD 2400"
    AMD94C8.1 = "ATI Mobility Radeon HD 2400 XT"
    AMD9581.1 = "ATI Mobility Radeon HD 2600"
    AMD9583.1 = "ATI Mobility Radeon HD 2600 XT"
    AMD95C4.1 = "ATI Mobility Radeon HD 3400 Series"
    AMD95C2.1 = "ATI Mobility Radeon HD 3430"
    AMD9591.1 = "ATI Mobility Radeon HD 3650"
    AMD9593.1 = "ATI Mobility Radeon HD 3670"
    AMD9504.1 = "ATI Mobility Radeon HD 3850"
    AMD9506.1 = "ATI Mobility Radeon HD 3850 X2"
    AMD9508.1 = "ATI Mobility Radeon HD 3870"
    AMD9509.1 = "ATI Mobility Radeon HD 3870 X2"
    AMD9712.1 = "ATI Mobility Radeon HD 4200 Series"
    AMD9552.1 = "ATI Mobility Radeon HD 4300 Series"
    AMD9555.1 = "ATI Mobility Radeon HD 4300/4500 Series"
    AMD9553.1 = "ATI Mobility Radeon HD 4500/5100 Series"
    AMD9480.1 = "ATI Mobility Radeon HD 4650"
    AMD9488.1 = "ATI Mobility Radeon HD 4670"
    AMD94A0.1 = "ATI Mobility Radeon HD 4830"
    AMD944A.1 = "ATI Mobility Radeon HD 4850"
    AMD94A1.1 = "ATI Mobility Radeon HD 4860"
    AMD945A.1 = "ATI Mobility Radeon HD 4870"
    AMD68E0.1 = "ATI Mobility Radeon HD 5400 Series"
    AMD68E1.1 = "ATI Mobility Radeon HD 5400 Series"
    AMD68C7.1 = "ATI Mobility Radeon HD 5570"
    AMD68A0.1 = "ATI Mobility Radeon HD 5800 Series"
    AMD68A1.1 = "ATI Mobility Radeon HD 5800 Series"
    AMD9613.1 = "ATI Radeon 3100 Graphics"
    AMD9612.1 = "ATI Radeon HD 3200 Graphics"
     
  14. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,736
    Likes Received:
    716
    GPU:
    MSI 2070S X-Trio
    so are AMD going to put these up officially sometime today, so after the official 12.1's and 12.2's not being needed, the 12.3's are now not going to be needed either, what a farce monthly WHQL is eh :p

    Cheers asder, will give em a go :D
     
    Last edited: Feb 16, 2012
  15. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    Anyone know if powerplay is functioning correctly?

    on the previous RC, after some time, Voltage was not staying in sync with the clock levels causing GPU resets.

    I had to roll back to the 12.2 Preview, powerplay was working correctly again.
     
    Last edited: Feb 16, 2012

  16. AdamK47

    AdamK47 Banned

    Messages:
    207
    Likes Received:
    0
    GPU:
    Verite V1000 & Voodoo 4MB
    I removed the old drivers and installed these drivers. Afterburner is working fine with all three of my 7970s. The key is to delete the old Afterburner profiles for each card and disable ULPS through Saphire TRIXX. Once ULPS is disabled, start MSI Afterburner and it will say a reboot is required in order to detect the cards settings.
     
  17. V1tol

    V1tol Master Guru

    Messages:
    284
    Likes Received:
    0
    GPU:
    MSI 1070 Gaming X
    Looks like no-video problem affects only 5000 series of cards. Mine HD6790 and HD3650 along with HTPC HD3200 plays any video with or without DXVA. Brother's HD5670 don't. Mine computer has Win7 x64, others Win7 x32
     
  18. Falkentyne

    Falkentyne Master Guru

    Messages:
    521
    Likes Received:
    60
    GPU:
    Sapphire HD 7970 Ghz Ed.
    That wasnt the problem. I actually completely uninstalled AB to rule that out. It wasn't AB..it was a driver problem. GPU-Z was showing the current 3d clocks as 300/150, almost as if the ULP modes and 3D modes became the exact same. Trixx also showed the current clocks as 300/150 (which it again should show 925/1375). GPU-Z has not, and should NEVER show the current clocks (the front page is supposed to show the 3d clocks) as the ULP clocks. Only the sensors should show the idle clocks.

    It was the 3d clocks being 300/150 that was preventing AB And Trixx from working.

    When I clean installed the SSAA preview driver, and then upgrade installed to these, everything worked again, and GPU-Z showed the proper clocks at 925/1375 instea of 300/150.

    Maybe that DLL posted above might have fixed it.....I mean this could be something as simple as this driver missing a DLL file that the previous driver has....or who knows...at least everything works now....
     
  19. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    <3 4 chars
     
  20. Espionage724

    Espionage724 Guest

    2 days old lol :p
     

Share This Page