AMD Catalyst 12.11 (9.010.8 November 15) AMD Official BETA 11

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Oct 22, 2012.

Tags:
Thread Status:
Not open for further replies.
  1. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,586
    Likes Received:
    604
    GPU:
    MSI 2070S X-Trio
    Looks like im back in business with me 7970, not had a single crash with 100% fan yet with these drivers :D
     
  2. heroxoot

    heroxoot Master Guru

    Messages:
    442
    Likes Received:
    0
    GPU:
    EVGA 1080ti SC2
    Went back to w7 today. No flickers in games, just on my desktop once in a while. Feels good to be back. OC is stable as hell. This driver works a lot better on 7.
     
  3. hulawafu77

    hulawafu77 Member Guru

    Messages:
    191
    Likes Received:
    0
    GPU:
    7970M
    Disagree, this driver was made for Win 8, just so much more stable on Win 8.
     
  4. Alph4Dawg

    Alph4Dawg Member Guru

    Messages:
    108
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor OC
    Any 6xxx series GPU user can confirm these drivers are good and if they're worth switching from 12.9 to this BETA as 12.9 are working great on my 6xxx CFx setup?
     

  5. gihu

    gihu New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    AMD 6770M
    Same for me. I hope it gets fixed.
     
  6. Espionage724

    Espionage724 Guest

    +1 to this. I get artifacting while bitmining on Win7, but don't on Win8. Nexuiz BSoD's on Win7 in DX11 mode, whereas it just crashes on Win8.
     
  7. hulawafu77

    hulawafu77 Member Guru

    Messages:
    191
    Likes Received:
    0
    GPU:
    7970M
    Very doubtful to me. Your CPU is still very powerful. BF3 and other games aren't nearly as CPU intensive as some make em out to be. Even on my laptop, these games don't use 50% of CPU.
     
  8. Kushana

    Kushana New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    XFX 7870 2GB
    I have an XFX 2Gb 7870, and was having huge problems with the frozen system + sound loop problem in World of Warcraft. I eventually uninstalled the 7870 and went back to my 5850.

    With the new beta drivers I decided to have a new go at the 7870. I did a complete driver sweeper uninstall, a 12.11b4 install without the sound driver, disabled the AC97 and ASUS HDAudio in BIOS, and installed my old ASUS Xonar DX. And I now play WoW under DX9.

    The crashes seemed to be gone (none after about 16 hours of play) and the performance is better, but there are a few rendering artifacts. I got a couple of triangle sprays in WoW, and missing mob in Mass Effect 3. But that's way better than crashes.
     
  9. erocker

    erocker Master Guru

    Messages:
    212
    Likes Received:
    0
    GPU:
    Sapphire HD 7970
    Don't bother.

    1. These drivers are meant for the 7 series. You will not see the performance improvements.

    2. If things are working "great", there's no need to change.
     
  10. Alph4Dawg

    Alph4Dawg Member Guru

    Messages:
    108
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor OC
    My thought exactly. Even I wouldn't mind seeing performance improvement on 6xxx series though.
    Drivers are working great in term of stability. Performance wise...almost every driver I tried is meh.
     

  11. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,275
    Likes Received:
    657
    GPU:
    Zotac GTX1080Ti AMP
    Love how the 12.10 CAP's say they include a Crysis 2 profile that fixes crossfire performance when I am using them with 12.11 betas and still get horrid performance at max settings, with texture pack and dx11 installed? Around 50-60% usage on both GPU's and frame rates go from 30's to 50's with a turn of the mouse. Feels very strange.
     
  12. bummerman

    bummerman Master Guru

    Messages:
    329
    Likes Received:
    0
    GPU:
    7970 tri-crossfire
    Somethings wrong, I'm running a 2 monitor setup at 3840-1080-on Ultra and getting 60-100 fps-I'd fiddle withit some-these drivers are great- They make 7970s much stonger than the 680s
     
  13. bummerman

    bummerman Master Guru

    Messages:
    329
    Likes Received:
    0
    GPU:
    7970 tri-crossfire
    I am on a z77 motherboard though
     
  14. Wag

    Wag Member

    Messages:
    34
    Likes Received:
    0
    GPU:
    2GB 6950 Tri-Fire
    Installed Win8 with this driver and Rage crashes as soon as I run it. I assume it has something to do with the driver? Anyone else have this problem?
     
  15. Hippie Tech

    Hippie Tech Member

    Messages:
    48
    Likes Received:
    0
    GPU:
    MSI r7870 tf III/oc
    The 12.11's, when compared to the 12.7 beta set, added 800 to my P score and a whoopin 1200 to my graphics. wooot :)

    I really don't think the mobo upgrade had anything to do with it. lol
    [​IMG]
     

  16. jackliu913

    jackliu913 Master Guru

    Messages:
    574
    Likes Received:
    0
    GPU:
    GTX 980Ti AMP Extreme
    why is the idle temp so damn high? 53C? on my 7950 MSI Twin FrozrII

    voltage are 1081mv (which is only slightly high than stocks of 1030)
    1084 core / 1350 mem

    pls help. is it a driver issue? I dont think my OC is too high. After like 30-60 mins of BF3 or SC2 the temps are high 60's to low 70's, so i know its not that bad
     
  17. Espionage724

    Espionage724 Guest

    Need more details; is this a new card? Does it only happen with these drivers? Have you tried other drivers? Did you do anything physical with your GPU (bump it, reseat it, etc.)?

    I might try reseating thermal paste if you haven't though, helped me with my 7850 PE
     
  18. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    are your idle clock 300/150?

    if not, thats your culprit
     
  19. jackliu913

    jackliu913 Master Guru

    Messages:
    574
    Likes Received:
    0
    GPU:
    GTX 980Ti AMP Extreme


    how do i fix that? YES that is correct it's running at that all the time? the clocks dont go down, how do i fix it? please help everyone. is it a MSI Afterburner bug that messes up the clocks?
     
  20. Faruk

    Faruk Active Member

    Messages:
    93
    Likes Received:
    0
    GPU:
    EVGA 980TI Classified
    Good news;

     
Thread Status:
Not open for further replies.

Share This Page