AMD Catalyst 12.10 WHQL_Modded for LEGACY GPUs - SUPER STABLE SUPER PERFORMANCE

Discussion in 'Videocards - AMD Radeon Drivers Section' started by ankinferno, Oct 31, 2012.

  1. ankinferno

    ankinferno Master Guru

    Messages:
    315
    Likes Received:
    0
    GPU:
    GeForce GT 840M
    Personally... didn't felt any difference by installing the driver using any of the .inf files....

    but ..

    for Windows 7 - use c7****.inf
    for Windows 8 - use c8****.inf
    for Windows Vista - use ch****.inf
     
  2. dinovom

    dinovom New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    AMD HD 4650 (RV730 PRO)
    Okay - i see. Thank you.

    EDIT: Well not the complete answer. True for x64 Windows, but on W8_INF we have CE148276.inf, CL148276.inf, CW148276. I just checked again as i know now what to look at: [Manufacturer] and below resulting in: CE148276 NTx86.6.2 Win8 / CW148276 NTx86.6.1 Win7 / CL148276 NTx86.6.0 WinVista
     
    Last edited: Dec 22, 2012
  3. KindaSmooth

    KindaSmooth New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    HD 4850
    Cganged name of ATi Filerepository now can't find the name to change it back

    Follwed these directions and renamed my ati file repository but never copied the original name of the folder. Now can't find the name to rename it so windows finds the default ati driver when uninstalling ATI Software.. Please Help!
     
  4. bullet00

    bullet00 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    hd radeon
    hi to all!i have problem with 12.10..:Driver Signature Enforcement disabled,install from Driver through Device Manager:Best driver software for your device is already installed,Windows has determined the driver software for your device is up to date i have windows 7 32bit(X86) and ati radeon hd 3850 512mb
     

  5. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    The 12.11 CAP 1 install is buggy. Use 12.11 CAP 2.
     
  6. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    In my investigative travels Catalyst 12.10 as well as the modded 12.10 has an atiogl.xml which has multiple problem profile entries that can never work correctly on legacy GPU's.

    Infact i'm apprehensive they might even work on modern GPU's correctly either.

    Examples :

    <profile exename="doom3.exe">
    <OpenGLCaps>0x00008000</OpenGLCaps>
    <OpenGLCapsEx>0x00000000</OpenGLCapsEx>
    <OpenGLCapsEx2>0x00020000</OpenGLCapsEx2>
    <CrossFireCaps>0x00000100</CrossFireCaps>
    </profile>

    If you look at an old atiogl.xml file applicable to legacy cards it will be like this :

    <profile exename="doom3.exe">
    <OpenGLCaps>0x00008000</OpenGLCaps>
    <OpenGLCapsEx>0x00000000</OpenGLCapsEx>
    <OpenGLCapsEx2>0x00020000</OpenGLCapsEx2>
    <CrossFireCaps>0x00000001</CrossFireCaps>
    </profile>

    <CrossFireCaps>0x00000001</CrossFireCaps> ---> enables AFR crossfire for OpenGL doom3, whereas the default 12.10 atiogl.xml on legacy cards will do diddly squat.

    <profile exename="ForceSingleGPU.exe">
    <CrossFireCaps>0x00001000</CrossFireCaps>
    </profile>

    Nope, value should be 0x00000010 instead.

    <!-- AFR-FriendlyOGL -->
    -<profile exename="afr-friendlyogl.exe">
    <CrossFireCaps>0x00000100</CrossFireCaps>
    </profile>

    Should be 0x00000001 instead to work.

    I have noticed multiple errors/dubious alterations to this file after the 12.6 legacy drivers. Possible mix up with the Linux drivers maybe ?!?.

    You never know what you might find when your not looking for it. :)

    I would suggest supplanting it with 12.6's legacy's older version instead of 12.10's that will function correctly using OpenGL Apps/games on legacy GPU's.

    Regards, K.
     
    Last edited: Jan 14, 2013
  7. ankinferno

    ankinferno Master Guru

    Messages:
    315
    Likes Received:
    0
    GPU:
    GeForce GT 840M
    Yes you are absolutely correct kev, and will keep in mind to use the 'atiogl.xml' from the 12.6 Legacy Drivers instead of the new one for modding the drivers.

    Odd thing is ,, I think my HD 7900 is not even using the .xml file in any ways, its running all OpenGL apps according to the OpenGL subsytem files and not the atiogl.xml. May be its of no use for the newer cards and can be removed..!!!

    Well ,, I'm waiting for the Catalyst 13 or what so ever stable catalyst AMD's going to launch. Will mod it for the Legacy GPUs and even post it if only performance improvements are present. and will keep in mind to use the 12.6 atiogl.xml.

    ThnX
     
  8. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Something may have changed the way the drivers handle OpenGL, and now the profile file has had to become different for newer cards. Thing is I see profiles in there for Linux stuff that isn't even applicable to Windows drivers.

    You can maybe test this out on 7900 by enabling Show Crossfire status Icon in catalyst.

    Downloading this :

    http://www.ozone3d.net/demos_projects/soft_shadows_benchmark.php

    And renaming the .exe to AFR-FriendlyOGL.exe, running it and see if you get a Crossfire logo top right *when* using the newer atiogl.xml file in the C:\Windows\ folder.

    It shouldn't work on 7900 because the profile for AFR-FriendlyOGL.exe in this case is now 0x00000100 and not 0x00000001 like it has to be for legacy for it to work.

    If it does work in the 0x00000100 configuration, then they have changed the values, but then this file won't work on legacy. If it doesn't work, then this file is broken for all.

    Could you maybe test this out ankinferno, I don't have access to 7K h/w. :)
     
    Last edited: Jan 15, 2013
  9. karnasw

    karnasw Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    AMD HD7850 2GB
    Modern apps (camera app, music app) and firefox hardware acceleration in flash aren't working for me with this drivers. :( On hd4570 and hd4890. I have message that this app don't work with this version of windows. I choose C8xxxxx.inf file.
     
    Last edited: Jan 15, 2013
  10. ankinferno

    ankinferno Master Guru

    Messages:
    315
    Likes Received:
    0
    GPU:
    GeForce GT 840M
    hmm.. Guies Plz wait for a few more days, I have gathered a lot of info in these days and have successfully created the Best performance driver for the Legacy GPU's (specifically the HD 4000 series). The Driver is based on the 12.11 Beta 11, and I can run all the games at high Anti-Aliasing levels and Anisotropic-Filtering with almost no Performance hits..

    The Driver is almost ready, but I'm just waiting for the 13.1 WHQL to be launched today, so that I can perform some tests with the new catalyst driver files also.


    EDIT: And this time, No "Driver Signature Enforcement" issues will be there in the driver :D


    Regards,
    Ankinferno
     
    Last edited: Jan 16, 2013

  11. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    We shall therefore twiddle our thumbs in feverish anticipation at what you are currently concocting oh infernal one. :thumbup:

    Let's just hope 13.1 isn't just 12.11 b11 with a logo stamp. :bonk:

    I want to completely forget Catalyst release notes 2012 in their entirety & kick 2012's drivers into the abyss, they were a complete head **** and utter plop... :grab:

    Maybe they didn't bother fixing them back then, or even stick to promised legacy release schedules because they believed the world was going to end in an apocalyptic mayan prophecy who knows... :funny:

    But you know what they say about the number, erm...13. :)
     
    Last edited: Jan 16, 2013
  12. iced2009

    iced2009 New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Gigabyte GTX 670 WF3
    This erro appers to me too!

    How I can fix this? I select the C8148226 but nothing happen, the box stay blank...~~

    Windows 8 x64 With Media Center
    HD4870 512mb
    Test Mode ON

    [​IMG]
     
    Last edited: Jan 18, 2013
  13. ankinferno

    ankinferno Master Guru

    Messages:
    315
    Likes Received:
    0
    GPU:
    GeForce GT 840M
    can you specify me your Device ID ...??
     
  14. iced2009

    iced2009 New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Gigabyte GTX 670 WF3
    this?
    PCI\VEN_1002&DEV_9440&SUBSYS_24471682&REV_00\4&1A5DA968&0&0008
     
  15. ankinferno

    ankinferno Master Guru

    Messages:
    315
    Likes Received:
    0
    GPU:
    GeForce GT 840M
    Odd.. I re-checked all the Inf's your device is present..

    I see you have the test mode turned ON , thts good

    Did you disable driver signature enforcement when booting into windows when you were installing the driver..??? coz this is very important..
     
    Last edited: Jan 19, 2013

  16. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Try replacing the inf files in your driver folder with the files from the link provided
    http://www.mediafire.com/?n2kdya2kop1j186
     
  17. ankinferno

    ankinferno Master Guru

    Messages:
    315
    Likes Received:
    0
    GPU:
    GeForce GT 840M
    Yes.. You can follow the above post by dellon132

    OR you can go for Other New Modded drivers than this one.

    like, kevsamiga1974 's Catalyst 12.6 Reloaded :

    http://forums.guru3d.com/showthread.php?t=367402

    Or
    Catalyst 12.11 Modded by dellon132.

    OR If you are looking for performance, Then install any Catalyst Control center that's working properly with your GPU and then use my performance Patch to Get its full potential (Which is much easier :D)

    Performance Patch Link : http://forums.guru3d.com/showthread.php?t=373669
     
  18. algeeba

    algeeba New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    HIS HD 4870 1gb
    Is there any way to make any of these modded performance drivers work for WinXP and a HD 4870?
     
  19. ankinferno

    ankinferno Master Guru

    Messages:
    315
    Likes Received:
    0
    GPU:
    GeForce GT 840M
    Un hu.. not possible.. Only Vista/7/8
     
  20. ottomanhero

    ottomanhero New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    ATI Radeon 4810 HD 512 mb
    Works great

    Hello, i installed your moded driver and it works great! :banana: Thank you for making this great mod. Im playing planetside 2 and been expecting any performance optimizations from ATI. NVIDIA already released performance patches and so did ATI but its only for non-legacy drivers.I got like 5 - 10 average fps boost in Planetside 2 :dave: .Thats a huge difference considering even on lowest settings you would only get like 5 - 8 fps difference from highest settings. if you don't know the game, its the most GPU or CPU dependent game in the world since its unoptimized, its GPU dependent for me tho, i've got an ati radeon HD 4810 sapphire (may sound unfamiliar, its actually a moded graphics card with 4730 chip, if you google it you'll find other users having problem with learning their graphics card's actual name)

    Could you mod newer drivers, i heard they optimized performance for newer games in non-egacy drivers, including planetside 2.I saw a few 13 mods on forums but not sure if they make any changes in performance

    Guess im one of ATI customers thats never going to buy ATI ever again, i bought this PC like 3 years ago and i could play every game out there until ati began to release legacy "drivers", im kinda GPU bound in most games now :bang:

    Note : I used same CCC settings, had same amount of free memory, background apps in same state while testing my FPS and i used planetside 2's FPS shortcut to monitor my FPS, also nearly same amount of people in same place.
     
    Last edited: Feb 1, 2013

Share This Page