AMD Catalyst 11.4 Early Preview Win7 x86/x64

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Mar 8, 2011.

Tags:
  1. master2k8

    master2k8 Active Member

    Messages:
    63
    Likes Received:
    0
    GPU:
    7950 1.1 Ghz Edition
    same here ,) 10.5 beta / 10.10e ftw (im still using 10.5b) all new games run without problems so far. (this was the 380 mb sized huge release) dont know anymore if it was a promo driver for 5970 cards or something, additionally i tested 11.2 on linux , and the problem didn't appeared at all, but again i got issues, it seems that 2d->3d swichting doenst work with the metacity windows manager at all, if i enable compiz fusion 3d desktop, my glxgears gained 6000 fps ... (lmao) , hopefully there will be a port of gallium 3d on windows, i'wd use it instantly instead of the closed source drivers.
     
    Last edited: Mar 20, 2011
  2. The General

    The General Ancient Guru

    Messages:
    3,108
    Likes Received:
    5
    GPU:
    FirePro W5000 2GB
    SF IV benchmark 11.4 VS 10.5
    Celeron e3300 5750 Win7 x86

    Sorry about not having a image from the 11.4, forgot to take it.

    11.4
    8222
    70fps

    10.5 Drivers
    [​IMG]

    And the same goes for any other game i tried, the new drivers sucks for my card anyways. Maybe they just work for the new 6000 series. Performance is amazing with the 10.5 ones. These are the drivers from the disc anyways.
     
  3. Razer(x)

    Razer(x) New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    5870 HD
    Oh, so it's not just only me, i'm having a lot of stuttering with Fifa 11 :bang:
     
  4. BlackZero

    BlackZero Ancient Guru

    Messages:
    8,878
    Likes Received:
    478
    GPU:
    RX Vega
    I get the same with these drivers where it almost freezes for a second at random intervals in a few games.
     

  5. The General

    The General Ancient Guru

    Messages:
    3,108
    Likes Received:
    5
    GPU:
    FirePro W5000 2GB
    Why not use the drivers from the disc, if none of that helps, go back to x86 its better.
     
  6. BlackZero

    BlackZero Ancient Guru

    Messages:
    8,878
    Likes Received:
    478
    GPU:
    RX Vega
    I haven't used x86 for a few years and really have no intention of going back though I do have dual boot with xp x86, in anycase I had no issues with 11.2 so it's just an issue with these particular drivers.
     
  7. tyRant.594

    tyRant.594 Master Guru

    Messages:
    472
    Likes Received:
    0
    GPU:
    MSI R9 280x
    Well I am finally moving from the 10.10 drivers to these.. going to give a few games a go tonight. I installed a fresh windows 7 with spk1.. so we will see! also kinda off topic.. do you guys think I should disable cnq?
     
  8. tyRant.594

    tyRant.594 Master Guru

    Messages:
    472
    Likes Received:
    0
    GPU:
    MSI R9 280x
    Well these drivers seem pretty damn good. I tried black ops and tf and all seemed smoother. I decided to also try with my overclock off kept getting weird hic cups, this seemed to help alot.
     
  9. Mr Dohz

    Mr Dohz Active Member

    Messages:
    89
    Likes Received:
    0
    GPU:
    6970 Lightning
    My first 6970 -> Install windows 7 and gfx driver , hang at welcome screen and bsod. Whatever driver i tried , it is the same. My previous 5870 was alright at least (occasionally amdkmdap crap).

    My 2nd 6970 (after rma) -> Able to get into windows. When comes to gaming , after a short while it gives me blank screen(could be any colour) , and then the fan runs 100% with amdkmdap crap. Sometimes , it shows the atikmpag bsod.

    I ran out of ideas of how to fix this annoying problem.
     
  10. BlackZero

    BlackZero Ancient Guru

    Messages:
    8,878
    Likes Received:
    478
    GPU:
    RX Vega
    Could easily be an issue with your motherboard needing a bios update or a virus/trojan. Seeing as you were able to rma both cards(?) it could possibly just be two faulty 6970's, as unlikely as that sounds. Though sometimes you just have to accept that things are going your way as out of the millions of systems that run a given hardware/software mix, some will undoubtedly have issues that no one can forsee.

    Did you contact AMD with the crash dumps when having these issues?
     

  11. davetheshrew

    davetheshrew Ancient Guru

    Messages:
    4,089
    Likes Received:
    0
    GPU:
    some green some red
    I have found a major bug when changing pixel format to full RGB, in previous driver I could change to whatever I want but now Im stuck at one setting, if I change it I get a green screen and desktop all fked up. I switch to any previous driver (using sh*t cleaner) and all is well but this one is borked :(
     
  12. perosmct

    perosmct Banned

    Messages:
    1,072
    Likes Received:
    0
    GPU:
    unknown
    and why you need full rgb the ycbcr 4:4:4, it's superior to it...
     
  13. xin0710

    xin0710 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    XFX ATi Radeon HD5970 2GB
    You probably have the 99% GPU activity bug but you just don't see it.
     
  14. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    6,964
    Likes Received:
    1,196
    GPU:
    NVIDIA GTX 1070
    Thought it was gone for me aswell lol. Then after 2 days when i rebooted the PC it looked at 99% after 2 min idle heh.
     
  15. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    6,964
    Likes Received:
    1,196
    GPU:
    NVIDIA GTX 1070
    Any chance you got a link for that 10.5b huge dl driver? ^^
     

  16. asder00

    asder00 Don Di Driver Staff Member

    Messages:
    1,193
    Likes Received:
    2
    GPU:
    RX VEGA 64 Liquid
  17. Alpha

    Alpha Master Guru

    Messages:
    225
    Likes Received:
    0
    GPU:
    MSI 6950
  18. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    6,964
    Likes Received:
    1,196
    GPU:
    NVIDIA GTX 1070
    XP, isn't that some OS from 25 years back? :p
     
  19. asder00

    asder00 Don Di Driver Staff Member

    Messages:
    1,193
    Likes Received:
    2
    GPU:
    RX VEGA 64 Liquid
    Yes xp is included
     
  20. marichuu

    marichuu Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    Inno3D GTX 770 iChill 4GB
    Hello
    I just got my XFX 6950 (6970) today, and these are the first drivers I installed. It's a new rig, so I can't really compare it to my previous 560 Ti and 5850 cards, but for some reason, I can't see the option for 120Hz on my LG monitor.
    560 Ti and 5850 had no issues with it in my other rig... Can the GPU drivers have anything to do with this?

    Edit: Fixed it by switching around the DVI ports. :>
     
    Last edited: Mar 29, 2011

Share This Page