AMD Catalyst 11.11 WHQL (8.911.0 October 25) - Download & Discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by asder00, Nov 15, 2011.

Tags:
  1. mdcobra

    mdcobra Member

    Messages:
    24
    Likes Received:
    0
    GPU:
    Club3d 7970
    The best BF3 driver for me! Everything @Ultra @1920x1200 except MSAA, while MSAA 2X is still very playable! Thank you AMD!

    Time will tell how stable it is! I will report back later on this.
     
  2. Asgaro

    Asgaro Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    AMD HD 6950 1 GB
    So you get better FPS than with v11.10?
     
  3. SpajdrEX

    SpajdrEX AMD Vanguard

    Messages:
    2,272
    Likes Received:
    595
    GPU:
    N/A
    Can you test it with Vsync ON? (60Hz) how much gpus are used in percent.
     
  4. adrock311

    adrock311 Master Guru

    Messages:
    793
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 SC 8gb


    stop lying, you cant max BF3 and disable AA and get 55 fps constant with your cad.
     

  5. cowman

    cowman Master Guru

    Messages:
    257
    Likes Received:
    0
    GPU:
    XFX R9 290 4GB
    Hasn't this been confirmed to be a game engine bug? I could of swore I read somewhere that nvidia users were having the same issue. I've had this issue since the beta (it wasn't there with the alpha). It's random too... I can go hours on different servers/maps/game modes and not experience it. Then the next day I get it on the first map I play for the day.

    Edit: I'm running 11.10 preview 3 fyi
     
  6. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    Hey guys... big trouble here
    Installed the 11.11 mobility 64 bit win7 driver, and got a bluescreen. Now I can't install the old working one anymore.
    I even tried Driver Sweeper, still cant install the old driver again :/ Screen stays black when "Monitor Driver is installed".

    And trying to install the 11.11 again gives me a bluescreen...
    w/ HD 6970M crossfire
    Please help me guys :bang:
     
  7. cowman

    cowman Master Guru

    Messages:
    257
    Likes Received:
    0
    GPU:
    XFX R9 290 4GB
    Have you tried system restore? Do you have a windows 7 install disc? just boot from it and you can select system restore in there.
     
  8. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    Why would I restore my system? I can boot it no problem, just cant apply any driver... everything else workes fine
     
  9. xfrgtr

    xfrgtr Member

    Messages:
    48
    Likes Received:
    0
    GPU:
    1080 gtx
    same here,there is a prob with cat 11.11 mobility drivers
     
    Last edited: Nov 15, 2011
  10. cowman

    cowman Master Guru

    Messages:
    257
    Likes Received:
    0
    GPU:
    XFX R9 290 4GB
    I installed the 11.11 mobility drivers fine on my laptop that has a 6990M in it.
     

  11. Skynet5

    Skynet5 New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    eVGA 680 SLI
    BF3 no FPS improvements, but jumpy stuttering every 3-4seconds.

    Rage, 50% usage on each GPU and it feels terrible.

    Next card is 100% NVidia now. I know I'll have problems with them too, but at least its a different set of problems and different forums. A change is as good as a holiday :)

    This is a spectular pain in the arse.

    I'll be back on 10.10 + 10.9 CAP4 for both games, and i'll live with the odd stuttering in RAGE.

    Seriously, 10.10 + 10.9 CAP4 this doesnt make sense, its like an f'ing sweetshop...get what works from random releases! Copy dlls here there and everywhere....never again.
     
  12. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    @xfrgtr, can you too not install previous drivers?
     
  13. xfrgtr

    xfrgtr Member

    Messages:
    48
    Likes Received:
    0
    GPU:
    1080 gtx
    I restarted in safe mode and uninstalled the drivers through device managers and did a reinstall of 11.10
     
  14. John Dolan

    John Dolan Ancient Guru

    Messages:
    2,247
    Likes Received:
    0
    GPU:
    2x GTX 780 SLI
    That is with Vsync on.

    I have tried the thing to turn it off but it doesnt work on my game for some reason.

    Bought my game through Steam dont know if that has anything to do with it or not.

    The game auto sets to ultra then i adjust it higher in game with all sliders set to full right and its mostly solid 60 fps but seen the odd drop to 45 - 55 sometimes.

    Have played for 29 hours and completed the main game.
     
  15. SpajdrEX

    SpajdrEX AMD Vanguard

    Messages:
    2,272
    Likes Received:
    595
    GPU:
    N/A
    John Dolan : thanks for information, thats crazy that even three cards cant provide fluid 60fps all the time, but i guess that ati drivers needs some work to improve fps fluctuation.
     

  16. kevnb

    kevnb Master Guru

    Messages:
    355
    Likes Received:
    3
    GPU:
    Zotac 1070
    Same here, had to use atimans uninstaller, driver sweeper and ended up going back to catalyst 10.6 as it works 100% better than current drivers for la noire.
     
  17. kevnb

    kevnb Master Guru

    Messages:
    355
    Likes Received:
    3
    GPU:
    Zotac 1070
    its the cpu optimization (or lack of it) of this old modified engine.
     
  18. Russ369

    Russ369 Master Guru

    Messages:
    621
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 FE
    Rage performance SUCKS with these drivers compared to 11.10 pre3 drivers... Can someone post the opengl file from those drivers so I can throw it in my folder, I dont know where to get it from... thank you... Also, how do I fix the texture pop-in with these drivers that was fixed with the 11.10 preview drivers?
     
  19. kevnb

    kevnb Master Guru

    Messages:
    355
    Likes Received:
    3
    GPU:
    Zotac 1070
    that dll will fix it all, preview 2 is even a tad better.
     
  20. Russ369

    Russ369 Master Guru

    Messages:
    621
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 FE
    Can you upload that .dll cuz I dont know where to get it
     

Share This Page