1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AMD 2 Monitors Gaming on 1st - Flash/Web video on 2nd = Lag/Stuttering ingame

Discussion in 'Videocards - AMD Radeon Drivers Section' started by wazer, Jan 5, 2014.

  1. wazer

    wazer Member

    Messages:
    28
    Likes Received:
    1
    GPU:
    1080TI on water
    So ever since i can remember i always had problems when using amd graphics cards with dual monitors where you play games on the main screen and are watching YouTube/flash/webtv/twitch on the second monitor there comes this giant fps drops in-game as soon there's content on my 2nd monitor.

    Take for an example Playing counter-strike: Global offensive my FPS are steady at 100 all the time as soon as i play some YouTube/flash/webtv content on the 2nd monitor i get the choppiness feeling in-game and my fps starts to drop randomly as soon as i minimize the window its all gone again.

    I cannot believe that I'm the only one with this problem, i have had this ever since my first AMD card 5850 sapphire toxic. When i was on nVidia there was no problem like that.

    My cards which i remember.
    5850
    5970
    2x6950 mod to 6970
    2x 7970
    Currently cards 2x290@290x bios mod from XFX.

    All of them have got this problem.

    My currently geek setup;) is.

    Intel I7 3770k@4500mhz 10 hours stable stress test run.
    Asus motherboard z77-i deluxe
    16GB ram 1866mhz
    2x Samsung evo 250 SSD, 1 for OS and 1 for games.
    Windows 8.1
    AMD 2x290x

    Monitors:
    Primary monitor
    benq xl2410t - 1920x1080@120hz Main for gaming and on desktop.
    Second monitor
    Samsung P2770HD 1920x1080@60hz

    So as you can see my computer should not be the problem here


    Why do i first come here now and asking if others have the problem.

    Well i reached out to AMD but they did not really seem to care when i did it, i never got an answer back so i assume they are too busy doing something.

    And now i started ********* on http://twitch.tv, and i keep an eye on my 2nd monitor whats going on to with stream where i can see people writing to me including my stream video playing, so each time i want to check whats going on to my stream i open the browser tab and see what people writes and minimize it again when i go in-game else I'm getting so much stuttering that its unplayable.

    So if there's anybody out there that are just a little bit fps/smooth hungry hardcore player as i am i would kindly ask you to check if you have the same problems as I, we do not talk about 30 or 60 or even 80 fps but 100 fps or MORE, note you can still have 100 fps in-game and the game would feel choppiness, it does not necessary have to be cs you test in, it could be battlefield or any other game where you can see the fps and have the correct mouse feeling/smoothing.

    I'm not 100% sure what is going on, but my theory goes like this

    When playing the video browser content on 2nd monitor i think AMD is telling the driver/hardware to 'over' prioritizing the encoding/decoding/something? than anything else and put like 100% workload on that content, does that even make sense ?.


    I thought this forum would be the right place to ask since i see a lot of content in here and i download the latest beta drivers always from this forum, which I appreciate a lot for those guys spending tons of hours into finding/creating/modding the latest leaked/? drivers for us.

    I created this user today, been lurking in here for like 10 years. Sorry ;)
     
  2. teleguy

    teleguy Maha Guru

    Messages:
    1,262
    Likes Received:
    61
    GPU:
    GTX 1070/Vega 56
    Did you check your GPU clocks when that happens?

    Try disabling flash hardware acceleration.
     
  3. rflair

    rflair Don Commisso Staff Member

    Messages:
    3,813
    Likes Received:
    78
    GPU:
    GTX 980/290X
    Have you tried running both monitors at 60Hz?
     
  4. wazer

    wazer Member

    Messages:
    28
    Likes Received:
    1
    GPU:
    1080TI on water
    The GPU clock jumps randomly all the time when watching an twitch stream right now everything from 300mhz on gpu to 1000, just between numbers 300,5xx,6xx,8xx,9xx all the time

    Disabling flash hardware acceleration does not change anything :(



    Does not matter, checked. :(
     

  5. Cartridge

    Cartridge New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    ATI Xpress 1150
    Have you tried bypassing flash completely using Greasemonkey + Viewtube with a VLC Plugin according to your architechture you installed the browser in. The VLC Plugins comes with the standalone installation so you might already have it. It's quite less resource demanding than using flash for the most part and using VLC, I've never had a problem even with a 500MHz computer. Don't use Xine or something of the kind, you don't get any buttons not even a right click. Other plugins are shiny though. Anyway, if this does not fix your problem, maybe someone else has any suggestions.
     
  6. wazer

    wazer Member

    Messages:
    28
    Likes Received:
    1
    GPU:
    1080TI on water
    Actually it seems to help but that's just a workaround half of the stuff on youtube is not working, it can play a video without playing the next video, also sadly it does not support twitch.tv website i have no idea how to add support for it, i tried added the http(s)://link* etc. But no luck.


    So who fault is it that it runs so bad with adobe flash player, AMD or the Adobe team?. Still hoping for others to test this
     
  7. Cartridge

    Cartridge New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    ATI Xpress 1150
    You have to get the extra scripts for twitch.tv to work. There are many sites and I haven't found any web video to not respond to the VLC plugin (with viewtube ofc).
    I also have auto-play on. As of now I don't have 10 posts so I can't link you anywhere, so at the page where you grabbed viewtube, just scroll down 'till you see mods and patches, install all those scripts. They work magnificiently.
    Again, I have not seen any problems with any videos, even with Ultra HD (4K)
     
  8. Steppzor

    Steppzor Master Guru

    Messages:
    783
    Likes Received:
    42
    GPU:
    MSI 1080 Ti GamingX
    Evey movie for me lags on the second monitor - I don't even have to do anything on the main screen - The monitor works fine if i set it as primary but the the movies lags on the other monitor again - been like this for years

    Yet to find a solution for it.
     
  9. Sasquatch

    Sasquatch Master Guru

    Messages:
    383
    Likes Received:
    0
    GPU:
    Msi GTX 970 Gaming 4G
    I have something similar going on. I have my HD 7850 hooked up to my main 22" screen, and I also have an HD 6450 that I use for Folding@Home (currently not folding). My second monitor is a cheap Dell 19" that only supports VGA. So I have it plugged into the 6450 instead of using a DVI-VGA converter on the 7850.
    But like you, I also notice some stutter at times. Every time I do, it's linked to the Flash plugin of Firefox, and usually only when I've been doing something in-browser for a while and I've been alt+tab'ing back & forth.
    The main culprit seems to be ads on Facebook, and occasionally Pandora, and if I've been watching long videos on youtube.
    Minimizing the Firefox window usually restores the majority of my FPS. Netflix, using Hardware Acceleration & Fullscreen on the smaller monitor, doesn't produce any lag. Using VLC for movies also runs flawlessly using default settings. (I do have the AC3 surround sound filter installed)

    Just throwing all this out there. Anytime mine starts to stutter, I just close the offending window or Firefox tab & keeping going with my games, then come back to it & hope it runs better.
     
  10. Plug2k

    Plug2k Maha Guru

    Messages:
    1,484
    Likes Received:
    5
    GPU:
    2x Gigabyte Fe 1080TI +WB
    the lag on the 2nd monitor is due to funky hardware acceleration, you have to use a software player where by you can disable hardware acceleration and use CPU only.

    try out VLC player.
    or Stereo scopic player

    or upgrade your system to a z87 chipset and use internal graphics for that like i use that way i dont need to use my graphics cards for watching movies and stuff on the 2nd monitor ;) you actually have z77 chipset does it not come with intergrated graphics :)
     
    Last edited: Jan 6, 2014

  11. Enmity

    Enmity Maha Guru

    Messages:
    1,308
    Likes Received:
    0
    GPU:
    EVGA 1080ti FE SLI
    hey plug, how do you set your igpu to do those kinds of tasks and not use the dedicated cards?..i have a similar problem to the OP but my issue is due to the driver hack i need to use to unlock my monitor.

    Edit: more info..

    I've enabled the igpu in bios, my main monitor is connected directly to my primary graphics card via DL-DVI but cannot play a lot of flash videos (only youtube vids work) unless I turn off hardware accelleration, and even then theres a lot of vids that simply stay black whenever I try to play them. This is because of the driver hack for 120Hz unlocking with my Qnix QX2710 monitor.

    So I was thinking of plugging my old monitor back in and running it as a secondary screen. I've only got a VGA cable right now so im using that, i've plugged my monitor directly into the motherboards vga port. Windows can see it but nothing shows up on the monitor itself.

    Upon checking "advanced settings" when selecting my secondary monitor under display - it says that the display adaptor for this monitor is amd 7900 series, but its plugged directly into the motherboard..it should be intel HD4000 or whatever. Tried checking CCC also, it detects the second monitor too but says its disabled.

    Do i need to instal Lucid for this to work?..
     
    Last edited: Jan 6, 2014
  12. wazer

    wazer Member

    Messages:
    28
    Likes Received:
    1
    GPU:
    1080TI on water
    Well lets hope we can bump this thread and get some ones attention that can deliver this message to others, still no really fix.
     
  13. Plug2k

    Plug2k Maha Guru

    Messages:
    1,484
    Likes Received:
    5
    GPU:
    2x Gigabyte Fe 1080TI +WB
    with intergrated graphic ect when you plug your monitor into the motherboard then into the monitor it should just work and detect as a card.
    also you get options that appear when you install the intel graphics driver.
    though my motherboard has HDMI out to HDMI monitor, VGA might be different and need to be enabled.
    with HDMI out to HDMI in on monitor its detected instantly on my system and shows the desktop background ect it totally bypass`s my 2x graphics cards.

    there for when i watch HIGH def vids .mkv ect i get no graphics acceleration cause its useing the onboard though i have a glitch on mine where by i have to disable hardware acceleration on my onboard otherwise i get stuttering effect and massive juddering. with it disabled though works perfect.. i can also watch bluray 3d movies with my onboard igpu only ;) dont even need to use my graphics cards for video watching as its fast enough but for gaming its pritty sucky but it does run dx11 games :) just like crap lol
     
  14. freibooter

    freibooter Active Member

    Messages:
    58
    Likes Received:
    0
    GPU:
    PowerColor R9 280X 3GB OC
    This issue has to do with the way AMD does HW video acceleration.

    AMD uses separate UVD clocks for HW video. AMD Overdrive settings do not apply to UVD clocks are there is no known method (other than editing the VBIOS) to change the UVD clocks.

    There is a long discussion over here:

    http://forums.guru3d.com/showthread.php?t=380114

    There seems to be no good reason for the separate UVD clock maximums and changing the UVD clock maximums via BIOS mod appears to have no adverse effects. Max UVD clocks even differ from OEM to OEM.

    Yet, there is no known way to change or override them via software or built in overdrive.

    Any kind of HW video acceleration will trigger UVD clocks and that generally results in lowered clock speeds and worse performance. There is no known way to disable this inside the drivers.

    AMD could theoretically fix this, but have never done so and probably never will. They don't see it as an issue.

    If you want to watch videos while gaming you have the following options:

    1. Find a VBIOS mod or modify your VBIOS and change your GPU's UVD clock maximums (difficult or not possible with HD7000 series and higher).

    2. Disable any and all HW video acceleration in any program that may trigger it individually. This isn't possible for all programs and for will generally result in a significant loss of video quality.

    3. Don't watch videos while gaming (this was a serious and shockingly common suggestion by AMD fanboys defending AMD's crappy UVD clock implementation - apparently watching videos while gaming means that you are "using your GPU wrong". No, I wish I were kidding).

    4. Buy an Nvidia card instead. Nvidia does and always did HW video acceleration without the crutch of separate and unadjustable clock rates. Watching videos while gaming has almost no impact on performance.

    I actually like my AMD card, it's fast, quiet and cheap. And I still like it. But had I known about UVD clocks beforehand, I probably would have never bought it.
     
    Last edited: Jan 12, 2014
  15. wazer

    wazer Member

    Messages:
    28
    Likes Received:
    1
    GPU:
    1080TI on water

    Wow nice reply mate, so do you know if there's any vmod with the UVD modded ?. Next time i think ill go back to nvidia after many years trustee to AMD but this i cannot live without anymore since ********* is becoming more and more in my daily life.
     

  16. somemadcaaant

    somemadcaaant Master Guru

    Messages:
    356
    Likes Received:
    6
    GPU:
    MSI 1080 Seahawk Water
    Hmm I'd say every person on the planet would have this issue mate since the dawn of the computer age, obviously anything that trys to take focus off your cpu, ram or gpu while doing something intensive like say "playing a game" would be detrimental to the performance of "said game"...

    Only way to do this properly is to fork out and grab a dedicated capture card or device or separate computer/laptop/tablet/phone etc and second monitor, ssd's, truck loads of ram or an nvidia card wont help you with this sorry...
     
  17. Black_ice_Spain

    Black_ice_Spain Ancient Guru

    Messages:
    4,553
    Likes Received:
    0
    GPU:
    970GTX
    disable aero and/or vsync and pray for no tearing.

    Thing happens because of windows synchronizing the refresh rate between both screens i think, altho if both at 60hz, there shouldnt be any problem


    @OP, did you try to use your integrated i7 GPU (if you have one) attached to the second monitor, so each GPU does a different thing?
     
    Last edited: Jan 17, 2014
  18. Steppzor

    Steppzor Master Guru

    Messages:
    783
    Likes Received:
    42
    GPU:
    MSI 1080 Ti GamingX
    I've tried to disable aero. If i set refresh rate to 59Hz on the seconds monitor the stuttering/lag is reduced, but still very noticeable - Annoys the heck out of me :p
     
  19. DummyPLUG

    DummyPLUG Member Guru

    Messages:
    131
    Likes Received:
    0
    GPU:
    Titan X
    About the UVD clock, I am using a 7970 with asus UEFI bios (with UEFI enable), 13.9, 2xU3011 via DP, the GPU clock can goes up to max (which is 925) when I am playing simcity while playing youtube in chrome or IE 11 (Win 8.1) with HW acceleration enable.

    BIOS Version 015.032.000.000
    BIOS Part Number 113-C3860100-201
    BIOS Date 2013/02/19

    p.s. My 7970 is a reference card flashed with the asus bios, if you wanna try the bios get it here:

    https://mega.co.nz/#!KMZQVKTL!SL0YIUSHT2l_hm9EZfF7X0j8b81TcwaVOnvtXHEYkRk

    or you can use the ASUS tools found in http://rog.asus.com/forum/ to flash it, but you need to have both ASUS motherboard and graphic card, really trouble..

    p.s. hope you still have the 7970 to test it :)
     
    Last edited: Jan 17, 2014
  20. drbaltazar

    drbaltazar Banned

    Messages:
    416
    Likes Received:
    0
    GPU:
    amd 7950 3gb
    You are probably using ICC for color profile not wcs .try to change both to wcs .you should have 2 screen in color management .it should say wcs virtual device profile sRGB and or scrgb .I suggest scrgb (even tho your screen are probably sRGB .)don't let your GPU do this (the option in GPU shouldnt be gray )the way ms do thing if you are set to default sRGB they sidestep a lot of math and this speed thing up a lot .sadly it will fix only one part .a lot of stuff is on the way window do thing .only fast idea that come to me is try to install GPU driver via device manager if you still have lag after the color management idea I gave.(restart when changing and don't forget to go back to color management to confirm.
     

Share This Page