Alice: The Madness Returns - Physx tweaks, optimizations..

Discussion in 'Games, Gaming & Game-demos' started by TheHunter, Jun 20, 2011.

  1. Ferdimage1

    Ferdimage1 Member Guru

    Messages:
    162
    Likes Received:
    3
    GPU:
    Gigabyte RTX 2080
    changing these made the game run perfect across the board including menu

    bSmoothFrameRate=TRUE
    MinSmoothedFrameRate=22
    MaxSmoothedFrameRate=60

    Driver 275.36 Quadro
     
  2. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    6,245
    Likes Received:
    671
    GPU:
    MSI GTX 1070
    Tweak is buy console :p
     
  3. andressergio

    andressergio Master Guru

    Messages:
    895
    Likes Received:
    0
    GPU:
    GALAX GTX 1080Ti HOF SLI
    impressed by the IQ of this game but on OC'd GTX580 SLI i have 30fps lol wtf !!! i had it downsampled to 3041x1710 then i went to 1920x1080 and the same tought it was that but reading the thread i see that the game has problems dang
     
  4. Damien_Azreal

    Damien_Azreal Ancient Guru

    Messages:
    10,153
    Likes Received:
    1,274
    GPU:
    Gigabyte 1070 Ti
    Anyone know of any way to get rid of/disable the physx effects for the Peppergrinder only?
    The game runs great with a few tweaks posted above, and the phsyx effects for Alice's hair, and debris from smashing boxes/pots look fantastic...
    But, the debris from firing the Peppergrinder kills my framerate, and really... it doesn't even look that good.
     

  5. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    looks like its not possible...:infinity:

    but check this for some additional tweaks,
    http://physxinfo.com/news/5883/gpu-physx-in-alice-madness-returns/

    below


    i didn't know about these values before, except for physx gpu heap size and it made some strange lag down to 22fps in heavy fights default is pinned to 30fps..idk maybe it will be better for you:nerd:
     
  6. Damien_Azreal

    Damien_Azreal Ancient Guru

    Messages:
    10,153
    Likes Received:
    1,274
    GPU:
    Gigabyte 1070 Ti
    Thanks, I'll give those a try. :)
    I already had to do some "fixing" as I had the bug where you can't use the Umbrella... because I remapped my keys.

    Fixed that though.
     
  7. Nemes1s

    Nemes1s Master Guru

    Messages:
    689
    Likes Received:
    0
    GPU:
    2x560Ti SLI ASUS + EVGA
    I'm using a GTX460 as a PhysX GPU. My main problem though, is once my 460 hovers around the 50-60% Usage region, My main GPU (GTX560Ti) tends to slow down. The main GPU usage drops between 15-25% GPU usage, which causes my framerate to hover between 20-25FPS.

    Then when I quit the game, and reload, my FPS is constantly 60, and my main GPU usage is back up to 60%.

    It's like when the PhysX card starts taking strain, my main cards usage drops dramatically. I think it's a driver fault.
     
  8. MaLDo

    MaLDo Master Guru

    Messages:
    555
    Likes Received:
    3
    GPU:
    GTX1080
    The most demanding effects are pepper grind smoke (not debris) and freeze particles from fishes.

    Both effects have physx controlled particles but the performance problem is not in the physx side, but in the render power for too many transparencies.

    The worst part is when shooting an entire magazine of pepper and then moving the camera up to pass through all the particles or being frozen by a toothy fish.

    With one 480 rendering and one 480 for dedicated physx both situations have performance drops to 23 fps. With 2 way SLI rendering and one 480 dedicated for physx, both situations have performance drops at 45 fps. With 3 sli rendering and physx running in cpu, both situations show 60 fps. So, it's not a physx drop.

    Problem is that setting physx in cpu produces big slowdowns in combats with other types of effects.

    To reduce number of smoke particles you can modify ParticleResize variable in AliceEngine.ini. Value = 0 is not limit (I think is near 1024 by default). Setting particleresize to 256 rise performance. This value affects number of oil fluid particles in screen too, so it's not recomended to set particleresize under 128 or so.
     

Share This Page