Alice: The Madness Returns - Physx tweaks, optimizations..

Discussion in 'Games, Gaming & Game-demos' started by TheHunter, Jun 20, 2011.

  1. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    Here is my tweak post yours and compare, etc..


    removing that physxDevice.dll helped a bit, i saw it helped with smoother physx executions.. i also deleted these 2 files (aphex_clothing_legacy_x86.dll and apex_destructible_legacy_x86.dll)

    ---
    and this is what i tweaked in ini file; - physx high

    [Engine.Engine]
    FluidSimulationTimeLimit=20.0

    bUseBackgroundLevelStreaming=True << i need to test this some more im not sure atm if it fixes that loading stutter completely. (its for scripts, in HomeFront some scripts didnt work anymore if i disabled it, but it removed loading stutter)

    [Engine.ISVHacks]
    bInitializeShadersOnDemand=TRUE << was false idk maybe it will help, didnt saw any negative impact
    UseMinimalNVIDIADriverShaderOptimization=FALSE << nv thing its best keep it off according to tweakguides its for older gpus 7000 series

    [TextureStreaming]
    PoolSize=768 >>> it helped with loading
    .
    .
    .
    MinTimeToGuaranteeMinMipCount=0 >>eliminates loading buffer (it shows texture density at its max right away instead of loading it)..
    MaxTimeToGuaranteeMinMipCount=0 >> same..


    [SystemSettings]
    Trilinear=True <<added
    .
    .
    bAllowHardwareShadowFiltering=True << was false, no perf impact
    .

    [FullScreenMovie]
    ;StartupMovies=Intro_EA.bik
    ;StartupMovies=Intro_SH.bik
    ;StartupMovies=TechLogo_Short.bik
    ;PCStartupMovies=Intro_Nvidia.bik

    with ; infront of the line, to skip and go directly to main ingame menu.



    So far it have a 31fps cap all the time.. even in most intense part of the game.
     
    Last edited: Jul 5, 2011
  2. DesGaizu

    DesGaizu Ancient Guru

    Messages:
    3,693
    Likes Received:
    57
    GPU:
    JetStream 980Ti
    What does PoolSize do? Does it store textures in ram? so if I have 8gig I could set it quite high to eliminate loading of textures?
     
  3. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    yes and no, im not 100% sure either but its something to so with storing partial data..


    Imo don't go over 1024, for example Batman AA has 1024mb by default compared to Alice with 140mb.. vs HomeFornt 120mb, but by homefornt i found out it didnt help much, actually it made it worse..

    Its a testing string, if you dont have any streaming issues (loading stutter) then leave it at default.


    --

    edit: well the streaming isn't 100% fixed, even with 768mb but its allot better now.. im gonna test with 512mb again, i had this at first and idk it felt a little smoother..
     
    Last edited: Jun 20, 2011
  4. TDurden

    TDurden Ancient Guru

    Messages:
    1,980
    Likes Received:
    3
    GPU:
    Sapphire R9 390 Nitro
    I heard you can play Alice with full PhysX effects on running on a quad core cpu. (without geforce card) I heard physx in this game is better optimized
    Is this true?
     

  5. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    ^
    well if running at 20-30fps on high with cpu feels optimized to you then use it, but imo that's not it.. (without 31fps cap its all over the place)

    And those that ran high +cpu physx had i7 2600k (+4ghz) etc and still i saw it can drop to mid/low 20ish fps at times..



    Maybe someone will post a tweak here, but i didnt bother testing it with cpu..

    Well looks like fluids, smoke and some particles have the biggest impact and for fluid/particle there are these lines,

    default values

    [Engine.Engine]
    MaxFluidNumVerts=1048576
    FluidSimulationTimeLimit=20.0 >> already tweaked, default is 30, but i saw some said its fine with 15.0 anything below 10? doesn't work and disables fluids altogether.
    MaxParticleResize=0
    MaxParticleResizeWarn=0
    bCheckParticleRenderSize=True
    MaxParticleVertexMemory=131972


    [SystemSettings]
    ApexLODResourceBudget=1000000020040877300000.000000
    ApexDestructionMaxChunkIslandCount=150
    ApexDestructionMaxChunkIslandCountHigh=500
    ApexDestructionMaxChunkSeparationLOD=1.000000

    [Engine.PhysicsLODVerticalDestructible]
    MaxDynamicChunkCount=1000
    DebrisLifetime=50.0 >>> already "tweaked" is 60.0 by default

    [Engine.PhysicsLODVerticalEmitter]
    ParticlePercentage=100




    there is nothing for smoke..or maybe there is but i didnt find it.
     
    Last edited: Jun 20, 2011
  6. TDurden

    TDurden Ancient Guru

    Messages:
    1,980
    Likes Received:
    3
    GPU:
    Sapphire R9 390 Nitro
    still compared to crappy optimization of Mirrors Edge or Mafia 2 thats very fast :)
     
  7. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]

    i guess.. but if it were based on new physx 3 it would have been much better too ^^, probably at least 31 fps cap all the time.

    The funny thing is my gpu isn't maxing out in the most intense physx parts of the game it barely uses 55-60%, talk about great optimization (31fps cap On or Off it doesn't matter, the engine is bottlenecked inside out).
     
  8. lukas_1987_dion

    lukas_1987_dion Master Guru

    Messages:
    393
    Likes Received:
    11
    GPU:
    RTX 2080 Ti AMP! OC
    Hmn... I can play with PhysX High on my system (Phenom II X4 965@4.02GHz, 4GB RAM DDR3 1333@1470MHz, HD69502GB@6970). Sometimes FPS drop to 25, but for me overall performance is very good (90% of all the time i have 31fps). Alice MR is a nice game ;-)
     
  9. SUnSpot

    SUnSpot Master Guru

    Messages:
    475
    Likes Received:
    0
    GPU:
    MSI gaming 970 4GB
    Playing at 1920x1080 resolution(my 24" max res).

    Changed the INI for 60fps cap instead of 31, rest of the ini untouched.

    Everything is set ON (soft shadows, motion blur, antialiasing etc).

    PhysX on low = 60fps no dips rocksolid.
    PhysX on Medium = 60fps with some dips to 45fps when alot is happening.
    PhysX on High = 60fps with dips to 15-20fps while fighting.

    Difference between Medium and High, I have only noticed some less smoke while shooting, a little less debris to I guess. The fluids on the ground after killing the babie faced black monsters don't react when I move trough it.

    Hardware I use is what you see to the left in my sig, with the difference nothing is overclocked at all atm (cpu @ 2.9ghz, gpu core 675mhz, 3600mhz on mem. Ram running at 800mhz CL5).

    270.61 drivers, and forced the physX to be handled by my GPU.
     
  10. Spets

    Spets Ancient Guru

    Messages:
    2,986
    Likes Received:
    43
    GPU:
    RTX 2080Ti XC Ultra
    Pretty impressive it runs that well on a phenom, can't wait to see physx 3.x on some cpu's :banana:
     

  11. KodY

    KodY Master Guru

    Messages:
    627
    Likes Received:
    0
    GPU:
    Sapphire 280X Vapor-X
    It seems not one particle-related option in the .ini-files is actually modifying the PhysX behaviour. Particle count and all that stuff have no effect.
     
  12. EarlZ

    EarlZ Master Guru

    Messages:
    218
    Likes Received:
    0
    GPU:
    2x Zotac GTX 780
    This tweak seems to disable the fluid physics from those oil monsters and some ground eruption/cracks.
     
  13. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    ^
    what part(string) of the tweak?

    oil is still here with FluidSimulationTimeLimit=20.0
     
  14. EarlZ

    EarlZ Master Guru

    Messages:
    218
    Likes Received:
    0
    GPU:
    2x Zotac GTX 780
    Im not sure, I just applied them all.

    EDIT:

    Gonna delete the ini file and start from scratch with PhysX set to high b4 tweaking maybe it was left to low/med.
     
    Last edited: Jun 24, 2011
  15. BVALJALO

    BVALJALO Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    GB WF GTX670(1337c/7000m)
    I'm running all maxed, with 8xAA and 4xTRSSAA (via NVCP, which appears to 'work'), at 1920x1200, on SLI 470's at 775/1800 and i7 930 @ 4.02GHz ... although I'm about to give up on physX high because I hate the lag that comes w/it at times.

    My FPS are about the same at each physX setting as you describe, although my dips only go down to about 25fps at the lowest. The Pepper Grinder in zoom mode seems to be the main offender when it comes to crushing the FPS, although the beginning of Chapter 3 ("vale of sorrow" is it?) I get quite a few slowdowns just walking around.

    Just so y'all know, I'm pretty sure (after lots of my own tests) that physX usage doesn't get 'counted' in your GPU usage (in AB and such) unless the card is 'dedicated'. Otherwise what you're seeing is the 'rendering' GPU usage only.

    Anyone tested with a dedicated physx card yet? LIke, a before/after type of deal? Just to see?
     

  16. nzweers

    nzweers Master Guru

    Messages:
    241
    Likes Received:
    0
    GPU:
    Inno3D 980Ti iChill Ultra
    renaming the exe to bioshock.exe bumped my fps from 44 to 60.
     
  17. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    ok this is my final setting atm.. but before you try any of these settings back up your original cfg..

    [Engine.Engine]
    bUseBackgroundLevelStreaming=FALSE

    FluidSimulationTimeLimit=20.0


    [TextureStreaming]
    PoolSize=768
    HysteresisLimit=30
    DropMipLevelsLimit=28
    StopIncreasingLimit=18
    StopStreamingLimit=9
    MinEvictSize=11
    MinFudgeFactor=0.5
    FudgeFactorIncreaseRateOfChange=0.5
    FudgeFactorDecreaseRateOfChange=-0.4
    MinRequestedMipsToConsider=11
    MinTimeToGuaranteeMinMipCount=0
    MaxTimeToGuaranteeMinMipCount=0
    UseTextureFileCache=TRUE
    LoadMapTimeLimit=5.0
    LightmapStreamingFactor=0.04
    ShadowmapStreamingFactor=0.04
    MaxLightmapRadius=4000.0
    AllowStreamingLightmaps=FALSE
    TextureFileCacheBulkDataAlignment=1

    [SystemSettings]
    Trilinear=True

    [FullScreenMovie]
    ;StartupMovies=Intro_EA.bik
    ;StartupMovies=Intro_SH.bik
    ;StartupMovies=TechLogo_Short.bik
    ;PCStartupMovies=Intro_Nvidia.bik

    --------------------
    Now if i change any of these lines it ran much worse when i heavy fights, i saw some weird 22-25fps drops, otherwise it was capped at 31fps.

    MaxPhysicsSubsteps=5 (Default 10)
    PhysXGpuHeapSize=128 (Default 64)
    PhysXMeshCacheSize=16 (Default 8)

    so i left them at default.

    ----
    Anyway with those settings above im able to keep up with smooth 31fps cap with almost no streaming hickups, lowest streaming drop was 29-30ish fps, otherwise it dropped to low as 27-28fps with default settings.. and that looked allot worse when in motion, i can't stand such stutter.

    To eliminate it "completely" there is something with these settings, but i had enough.. btw these are "modded" and much higher then default.
    HysteresisLimit=30
    DropMipLevelsLimit=28
    StopIncreasingLimit=18
    StopStreamingLimit=9

    this how its at default

    [TextureStreaming]
    PoolSize=140
    HysteresisLimit=20
    DropMipLevelsLimit=16
    StopIncreasingLimit=12
    StopStreamingLimit=8
     
    Last edited: Jul 5, 2011
  18. nzweers

    nzweers Master Guru

    Messages:
    241
    Likes Received:
    0
    GPU:
    Inno3D 980Ti iChill Ultra
    I saw put FluidSimulationTimeLimit on 3 instead of 30. That is what is dropping my framerate from 60 to 50,40,30,25. I want to stay at least at 40. And I don't mind if fluid gets sucked into the ground. I just need good framerate when fighting.

    And this guy above, why play at 31 frames?
     
  19. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    ^
    because i can't stand frames all over the place >> 60fps drop to 40- 35-50- 60- 45- 60,etc.. i rather have a fluid game pined at 31fps.


    from what i've seen it disables it all together, 10 is the min.. at least one guru member said that, i didn't try lower then 20.
     
  20. yosef019

    yosef019 Ancient Guru

    Messages:
    2,114
    Likes Received:
    3
    GPU:
    EVGA 1080 ti
    We need tweak for peper gun
     

Share This Page