Alan Wake freezing with 7970.

Discussion in 'Videocards - AMD Radeon Drivers Section' started by GamingArena, Feb 16, 2012.

  1. GamingArena

    GamingArena Active Member

    Messages:
    79
    Likes Received:
    0
    GPU:
    EVGA Titan SC Sig x2 SLi
    Anyone else with AMD HD7970 card and this game?

    You guys have any problems?
    My game keeps freezing as soon as you start at the beginning where you choose the inverted control beside the car.
    I'm running Crossfire but i tried single card still same freezing, all default clocks, and this is the only game that does that, all my other games work fine so its definitely something wrong.
    I maxed all the graphic settings so it might be a setting that crashes the game and i need Hard Reboot.
    Cant pinpoint the exact problem.
    And yes i tried all the available beta drivers including latest one from 2 days ago same as CAPS.

    Let me know if anyone can play this game with 7970.
     
  2. Ninbri64

    Ninbri64 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970 2x CFX
    I have basically have the same setup as you, and am also experiencing the exact same freezing issue in the same spot with Alan Wake. You are not alone. I hope they fix this soon, or we figure out a fix.

    I'm running the latest release 7970 drivers and the new caps with Alan Wake crossfire support that was just recently released as well.
     
  3. AdamK47

    AdamK47 Banned

    Messages:
    207
    Likes Received:
    0
    GPU:
    Verite V1000 & Voodoo 4MB
    A Radeon card that has problem with a new game? Say it isn't so!
     
  4. PhazeDelta1

    PhazeDelta1 Ancient Guru

    Messages:
    15,616
    Likes Received:
    14
    GPU:
    EVGA 1080 FTW
    it isnt so. :wanker:
     

  5. mao5

    mao5 Guest

    Alan Wake can burn Tahiti GPU to 84c with 42% fixed fan speed, bf3 MP only 71c, so check your fan speed.
     
  6. Choseh

    Choseh Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    Sapphire 7970 3GB
    hey there,

    i'm still on the rc11 drivers and i don't experience this crash

    just signed up to say this :)
     
  7. bobutz

    bobutz New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    MSI 7970


    same here :)
     
  8. thatguy91

    thatguy91 Ancient Guru

    Messages:
    6,643
    Likes Received:
    99
    GPU:
    XFX RX 480 RS 4 GB
    Have you updated the game? (there are updates out for it)
     
  9. GhostXL

    GhostXL Ancient Guru

    Messages:
    6,084
    Likes Received:
    54
    GPU:
    Merc 319 6800 XT
    Very same issue here bro. I tried booting with Crossfire and without. I tried all low settings, and all high. Nothing helped.

    And those suggesting updating the game, Steam does this automatically, no need. I have the steam version and have this bug, it's an HD 7 series issue.
     
  10. Anvi

    Anvi Member Guru

    Messages:
    131
    Likes Received:
    1
    GPU:
    R9 390 8GB
    My Sapphire 7970 does the same in TERA Online. I have to hard reset my computer to recover.. There's no BSOD, just sound looping until shutdown.
     

  11. GhostXL

    GhostXL Ancient Guru

    Messages:
    6,084
    Likes Received:
    54
    GPU:
    Merc 319 6800 XT
    I'm betting on either another pre-release or the WHQL fixing at least the Alan Wake issue. I can't comment on the TERA Online issue, as AMD might not even consider looking at it since its beta.
     
  12. erocker

    erocker Master Guru

    Messages:
    212
    Likes Received:
    0
    GPU:
    Sapphire HD 7970
    Same here. Played for a few hours last night. :)
     
  13. pcgamers

    pcgamers Master Guru

    Messages:
    308
    Likes Received:
    0
    GPU:
    RTX 2080Ti
    mine 7970 and just completed the Game..great games indeed. no issues at all playing this game with single 7970. Maybe this only appears on those who have 2x7970s even though you disabled one? just guessing since no single 7970 user experienced the freeze so far...
     
  14. GamingArena

    GamingArena Active Member

    Messages:
    79
    Likes Received:
    0
    GPU:
    EVGA Titan SC Sig x2 SLi
    I'm glad im not alone cause i thought my cards are going bad or something, even thought i play every other game rock solid for hours.
    I knew it must be the combination of 7970's crossfire with the drivers and this game that locks.

    Anyways after investigating more i found that if you play -window, it plays perfectly since it uses single card in window so i checked the second card and it was in low power state.
    When i tried fullscreen with custom profile with crosfire disabled i checked 2nd card and it still was full speed even though the crossfire was off in the game and the game would lock.
    So finally i just disabled totally crossfire not with profiles and the game work in Fullscreen without locking up. i checked the 2nd card and was still in low power state.

    So definitely its the problem with crossfire and the new drivers...

    At least im happy cause i was going crazy trying to find anyone else with the same problem and thinking that my cards are bad now i know everything is ok, im not alone :)
     
    Last edited: Feb 18, 2012
  15. GhostXL

    GhostXL Ancient Guru

    Messages:
    6,084
    Likes Received:
    54
    GPU:
    Merc 319 6800 XT
    Well, I find it odd, as I disable xfire and still have the issue. Oh well, I'll just wait for a fix.
     

  16. jaredpace

    jaredpace Active Member

    Messages:
    77
    Likes Received:
    0
    GPU:
    4890 975/1150
    Keep your default GPU core clock the same and increase the core voltage and run 100% fan, see if it still crashes in that spot.
     
  17. Maspast

    Maspast Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    RADEON HD7970 Double D
    I have the same issue with freezing.
    Happens randomly every 10-30 secs, and the freezes can last 2secs to 10-20secs.
    Really damn frustrating, have tried both x-fire on and off, the problem persists.

    GIEF FIX
     
  18. GamingArena

    GamingArena Active Member

    Messages:
    79
    Likes Received:
    0
    GPU:
    EVGA Titan SC Sig x2 SLi
    Nah its not the OC i tried to even underclock the card and still does it, its definitely X-fire problem and the drivers, as you see looks like all X-fire 7970 cards have problem with this game.
     
  19. GhostXL

    GhostXL Ancient Guru

    Messages:
    6,084
    Likes Received:
    54
    GPU:
    Merc 319 6800 XT
    Yeah it's a driver issue 100% with 7970 Xfire.

    OC has nothing to do with it, you are right. I tried backing off the OC, no difference. Besides AMD/ATI made these cards to max out OD.
     
  20. GamingArena

    GamingArena Active Member

    Messages:
    79
    Likes Received:
    0
    GPU:
    EVGA Titan SC Sig x2 SLi
    Lots of people on rage3d with same problem,
    http://www.rage3d.com/board/showthread.php?t=33987015
     

Share This Page