1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Absurd FPS drops after updating to 1809

Discussion in 'Operating Systems' started by GPz, Oct 11, 2018.

  1. GPz

    GPz Active Member

    Messages:
    58
    Likes Received:
    1
    GPU:
    MSI GTX 970
    Update: After a lot more hours of research and testing, I've conclusively isolated the problem to IDtech6 games (so, Doom 2016 and Wolfenstein 2). Absolutely all other games run just fine after I've disabled spectre and meltdown protection via inSpectre. Also, it's not Vulkan per se, as vkQuake runs as usual, between 480 and 500 fps. Any thoughts?

    Original post:
    Hello! I turn to you good and smart people, for guidance, for I'm a fellow gamer in need...

    Ever since my system auto-updated to this Win10 October update, my games have been experiencing severe fps dips, far worse than I ever had on my system. I've observed such behaviour in Overwatch, SOTTR and CS:GO. But the worst offender, by far, is Doom (2016) - when all in-game statistics are showing, the GPU graph periodically shows a 3-5 second red lagspike that tanks fps to the high 20s (before the win update, fps never dipped below 80). These don't seem to be caused by anything on screen in particular - like particle effects or many monsters / geometry - they're random. The numerical ms display for CPU also periodically shows random very long red number stings instead of the XX.XX ms value. Never seen that. Resource monitor, windows task manager and MSI afterburner all show the GPU being pegged to 100% (tested it with vsync off) and the CPU being utilised pretty much like normal while playing DOOM (40-70% for my CPU). The framerate dips are real though - it's not only the numbers showing, you can really feel your mouse lag pretty hard - just like when playing at below 30 fps!

    My hardware: Asrock P67 Pro, non-oc 2500k, 8 GB 1333 DDR3, MSI GTX970, Samusng 830 SATA SSD, Sound BlasterX AE-5.

    What I tried:
    - cleaning dust out of my case, removing the GPU, cleaning dust and such...
    - tweaking and tuning windows - disabling unneeded functionality, including group policy-ing win defender, disabling telemetry via OOSU10 and such
    - uninstalling all metro apps, including the store
    - installing the latest intel chipset drivers (actually noticeably improved my network performance!)
    - uninstalling my video drivers via DDU in safe mode, clean installing v416.16
    - doing the same for 416.34
    - trying out pretty much every nvidia control panel setting.
    - enabling and disabling "game mode" in windows settings
    - in DOOM, switching to OpenGL (even worse performance)

    The very dubious part of the whole story is that at one point (3 days ago), without me having any apparent influence on it, the problem was suddenly gone... and then, today, windows auto-installed the patch tuesday cummulative update for 1809... and the problems returned.

    I am quite baffled by this phenomena. Never seen anything like it. And... to make it even more troubling - windows itself and pretty much everything except games works even better / snappier than before! /facepalm

    Does anyone have an inking about what the hell is going on? Any constructive thoughts would be greatly appreciated.
     
    Last edited: Oct 13, 2018
    Strange Times likes this.
  2. Strange Times

    Strange Times Member

    Messages:
    11
    Likes Received:
    2
    GPU:
    GTX 750Ti
    every windows update has stutters in games for me after release. just wait for cumulative updates and new drivers
     
  3. GPz

    GPz Active Member

    Messages:
    58
    Likes Received:
    1
    GPU:
    MSI GTX 970
    I get what you're trying to convey. I also had similar issues in the past. This time it's radically different, and that's why I'm seeking help; I'm experiencing 0 stutters, at least not more than usual and the fps tanks - like I periodically have only 25% of my GPUs power available. It's VERY bizzare.

    But in the end, if waiting for more updates is the only cure, oh well, so be it.

    I still did have a random miracle happen for it to go away for like almost 4 days... then this cursed cumulative update landed...
     
  4. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,297
    Likes Received:
    809
    GPU:
    1080Ti H20
    Have you tried disabling game-mode?

    I've seen it cause hitches in several games, but I don't recall if it was before or after they changed the way it works.
     

  5. tsunami231

    tsunami231 Ancient Guru

    Messages:
    8,699
    Likes Received:
    175
    GPU:
    EVGA 1070Ti Black
    you know i am confused by this gamemode thing in recent build there is NO on/off in settings/gaming other then "record game clips, screenshots and broadcasts with gamebar" off which supposed to turn it off? or does one have have that enabled and window key + g and turn it off in each game before doing the above?
     
  6. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,297
    Likes Received:
    809
    GPU:
    1080Ti H20
    It's missing?

    I have a submenu with Game mode where you can toggle it on/off in settings app.
     
  7. jbmcmillan

    jbmcmillan Ancient Guru

    Messages:
    2,486
    Likes Received:
    84
    GPU:
    Gigabyte G1 Gaming GTX970
    I do as well.
     
  8. GPz

    GPz Active Member

    Messages:
    58
    Likes Received:
    1
    GPU:
    MSI GTX 970
    I forgot to mention this in my opening post - yes, game mode on and off - makes no discernible difference.
     
  9. tsunami231

    tsunami231 Ancient Guru

    Messages:
    8,699
    Likes Received:
    175
    GPU:
    EVGA 1070Ti Black
    I mean when I go in to "Settings>Gaming" settings where windows update, I not talking about in the actual game by using the windows key + g

    in the "setting> gaming there is no option to "turn it on or off" just an option to turn the bar off

    I did do this
    https://www.windowscentral.com/how-disable-and-remove-game-bar-windows-10-creators-update

    it was set to 4 in reg i set it to 3 and i not sure i really see any diffrence, i mean it been set 4 this whole time i had 1803 build installed, I just disable the gamebar in settings>gaming and all games ran like the should it was all nice and smooth
     
  10. jbmcmillan

    jbmcmillan Ancient Guru

    Messages:
    2,486
    Likes Received:
    84
    GPU:
    Gigabyte G1 Gaming GTX970
    Settings>Gaming>Game Mode It's on the left.
     

  11. stormy

    stormy Ancient Guru

    Messages:
    2,563
    Likes Received:
    8
    GPU:
    Gigabyte RX 570
  12. mbk1969

    mbk1969 Ancient Guru

    Messages:
    5,661
    Likes Received:
    1,881
    GPU:
    GeForce GTX 1070
    You can suffer doing numerous little what-ifs, but instead you can go pro and suffer doing one big clean install of Windows.
     
  13. tsunami231

    tsunami231 Ancient Guru

    Messages:
    8,699
    Likes Received:
    175
    GPU:
    EVGA 1070Ti Black
    im on 1803 build there is no such option in it that or i really blind

    [​IMG]

    [​IMG]
     
  14. stormy

    stormy Ancient Guru

    Messages:
    2,563
    Likes Received:
    8
    GPU:
    Gigabyte RX 570
    I think you are right and that they added it back in 1809.
     
  15. tsunami231

    tsunami231 Ancient Guru

    Messages:
    8,699
    Likes Received:
    175
    GPU:
    EVGA 1070Ti Black
    like said it it acutal is on and has been all this time, then dont mater to me cause they all play silky smooth for me, only games that stutter for me still are games that game engines issues that cause it
     

  16. RealNC

    RealNC Ancient Guru

    Messages:
    2,391
    Likes Received:
    675
    GPU:
    EVGA GTX 980 Ti FTW
    I also don't have it, and I'm on 1709.
     
  17. GPz

    GPz Active Member

    Messages:
    58
    Likes Received:
    1
    GPU:
    MSI GTX 970
    I am aware of this, an doing a clean install, complete through a boot-up usb, will be my final resort. I'm still not diving into it because a) there is no guarantee that it will alleviate the problem, and b) I somehow accidentally solved the problem before without a clean install, but unfortunately haven't got the foggiest what I did.
     
  18. mbk1969

    mbk1969 Ancient Guru

    Messages:
    5,661
    Likes Received:
    1,881
    GPU:
    GeForce GTX 1070
    Good. Operating System is a mystery.
     
  19. GPz

    GPz Active Member

    Messages:
    58
    Likes Received:
    1
    GPU:
    MSI GTX 970
    Bumping for visibility of the update I made to the opening post.
     
  20. PapaJohn

    PapaJohn Member Guru

    Messages:
    163
    Likes Received:
    0
    GPU:
    GTX 970
    I have an older setup with a GTX 970 and I have also noticed this in the new windows update. Most things play fine but Diablo III now has really low GPU usage creating a stutterfest and idtech games are also really low like the op. On previous versions of windows 10 and on windows 7, the gpu usage would always go to 99% and I would have smooth gameplay ( I play with vsync off).

    I'm going to try a lot more of my games and see if there are any other issues I'll report back. Will also give feedback to Nvidia and Microsoft.
     

Share This Page