AA in Bioshock 2

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Remekra, Feb 10, 2010.

  1. Remekra

    Remekra Active Member

    Messages:
    85
    Likes Received:
    6
    GPU:
    AMD Radeon RX6900XT
    Hello.

    Is there anyway to force AA in Bioshock 2 with ATI card(Radeon HD5770)? I tried to rename Bioshock2.exe to UT3.exe like in ME2, but because of the launcher, it does not work.:bang:
     
  2. blackfloyd

    blackfloyd Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    GTX 580
    Then don't launch the game from launcher, launch it from the exe itself.
     
  3. Remekra

    Remekra Active Member

    Messages:
    85
    Likes Received:
    6
    GPU:
    AMD Radeon RX6900XT
    It can't be launched straight from the .exe.
     
  4. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    if it's a STEAM version you need the no.-cd crack or this trick don't work, not only with this game burt with any steam game
     

  5. Gameslove

    Gameslove Master Guru

    Messages:
    650
    Likes Received:
    0
    GPU:
    GTX760 4GB OC/GTS450physX
    So not available AA for ATI at the moment?
     
  6. dsbig

    dsbig Ancient Guru

    Messages:
    4,046
    Likes Received:
    42
    GPU:
    EVGA RTX 2070
    keep thinking about switching back to nvidia becuase of this
     
  7. UZ7

    UZ7 Ancient Guru

    Messages:
    5,523
    Likes Received:
    67
    GPU:
    GB Vision 3080 10GB
    The Way It's Meant To Be Played? lol
     
  8. Gameslove

    Gameslove Master Guru

    Messages:
    650
    Likes Received:
    0
    GPU:
    GTX760 4GB OC/GTS450physX
    Playing this atmospheric game without AA - only spoil impression :(
     
  9. dsbig

    dsbig Ancient Guru

    Messages:
    4,046
    Likes Received:
    42
    GPU:
    EVGA RTX 2070
    I got AA to work

    for people using the steam version,, in the set options put -dx9

    yes I know its directx 9 and not 10

    WARNING!!!

    THERE IS MAJOR GRAPHIC PROBLEMS WITH TEXTURES DISAPPEARING AND REAPPEARING AND YES THERE IS LOSS IN FRAME RATES:bang:

    let me know if the same is happening for you
     
  10. Gameslove

    Gameslove Master Guru

    Messages:
    650
    Likes Received:
    0
    GPU:
    GTX760 4GB OC/GTS450physX
    What names of others games use Unreal engine 2.5 there work AA forcing in CCC?
     

  11. Gameslove

    Gameslove Master Guru

    Messages:
    650
    Likes Received:
    0
    GPU:
    GTX760 4GB OC/GTS450physX
    For Dx 10 version?
     
  12. dsbig

    dsbig Ancient Guru

    Messages:
    4,046
    Likes Received:
    42
    GPU:
    EVGA RTX 2070
    ok I figured out you can not set AA to full in ccc control panel
    I changed it to 4x and its working better, still takes a performance hit

    I havent figured out how to get it to work in dx10 mode yet
     
  13. japamd

    japamd Ancient Guru

    Messages:
    2,448
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970Ghz
    With Catalyst 10.1 you can force AA in CCC and play in DX9 mode (on games explorer, right-click the bioshock icon and choose play dx9)

    Too bad DX9 mode looks ugly comparing to DX10 mode

    DX9 + AA 4x
    [​IMG]

    DX10 - no AA
    [​IMG]
     
  14. Razorrig

    Razorrig Banned

    Messages:
    312
    Likes Received:
    0
    GPU:
    HD 5870 Xfire 1025mhz
    They dont look any different. Only thing DX10 has over DX9 is extra water effects and slightly better shadows.
     
  15. fellix

    fellix Member Guru

    Messages:
    194
    Likes Received:
    33
    GPU:
    KFA² GTX 1080 Ti
    Resized screen-shots are not good for AA comparison. ;)
     

  16. stormclaw

    stormclaw New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    5850 CFX
    ...so then they are no different..? :bang:
     
  17. kitch9

    kitch9 Ancient Guru

    Messages:
    1,891
    Likes Received:
    0
    GPU:
    XFX 7990 3GB
    Nvidia has the same issue with the UE3 engine, so good luck with that!!

    The DX10 shaders UE3 engine uses are incompatible with AA normally. ATI and Nvidia do have workarounds for this limitation but they have to manually tweak the game at a driver level to get it to work. When it is enabled you will see some edges have AA and some don't, its just how it is.

    Saying that the dark nature of the game makes the aliasing not stand out very much so its not something I'm worried about. I normally hate it along with tearing.
     
    Last edited: Feb 11, 2010
  18. ATI DOMINATOR

    ATI DOMINATOR Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    2xSapphire 5850 CF
    i think in this game,you do not need AA like Mass Effect 2,in ME2 there are lots of jaggies on every detail but Bioshock looks fine.
     
  19. Bo_Fox

    Bo_Fox Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    4870 1GB, 8800GTX
    Hmm, to DX10 or to AA?

    That's the question! hehe..
     
  20. Funky Doodle

    Funky Doodle Master Guru

    Messages:
    792
    Likes Received:
    0
    GPU:
    Gigabyte ATI HD 5830 1GB
    mby they patch it soon, i wait.
     

Share This Page