a simple way to truly disable catalyst A.I.

Discussion in 'Videocards - AMD Radeon Drivers Section' started by perosmct, Apr 22, 2011.

  1. perosmct

    perosmct Banned

    Messages:
    1,072
    Likes Received:
    0
    GPU:
    unknown
    first kill processes "mom.exe" and "ccc.exe"

    just go to "user"->"appdata"->"local"->"ATI"->ACE->right click "profiles.xml"

    ->and open it with wordpad OR edit it with notepad

    find this

    </Feature>
    <Feature name="CatalystAI">
    <Property name="CatalystAI" value="Enable" />


    then do this

    </Feature>
    <Feature name="CatalystAI">
    <Property name="CatalystAI" value="Disable" />

    save any changes

    now finally re-open catalyst control center...it works...too bad that they just left an option on ccc and you must do all these steps...anyway dont forget to revert the changes if you want to enable it again, especially crossfire&cfx...:)
     
    Last edited: Apr 22, 2011
  2. geeunit

    geeunit Master Guru

    Messages:
    375
    Likes Received:
    0
    GPU:
    intel 4500mhd
    does it disable x-fire?
     
  3. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    6,834
    Likes Received:
    1,070
    GPU:
    NVIDIA GTX 1070
    Would test it for you, but i sold my 5970.

    Then again i don't know if it works for Dual GPU users. Because when i set Xfire disabled in RadeonPro some games had massive glitches or half of the screen not rendering.

    Beside, you got a different Xfire setup and can simply disable it in the CCC.
     
  4. Metz

    Metz Master Guru

    Messages:
    229
    Likes Received:
    0
    GPU:
    2x 5850 TOP CF
    Last part of his post.
     

  5. cig84

    cig84 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    ATI Mobility HD5470 512MB
    Why you have to disable it?? Don't the A.I. improve (a little bit) your graphics performance??
     
  6. PhazeDelta1

    PhazeDelta1 Moderator Staff Member

    Messages:
    15,616
    Likes Received:
    14
    GPU:
    EVGA 1080 FTW
    iirc disabling cat ai shuts off xfire
     
  7. Maziar

    Maziar Member Guru

    Messages:
    116
    Likes Received:
    0
    Because some games run better with Catalyst AI turned off(at least for me, such as PES 2011,Bioshock 2,SC2 etc.)
     
  8. DarkKnightDude

    DarkKnightDude Maha Guru

    Messages:
    1,089
    Likes Received:
    0
    GPU:
    MSI GTX770 4 GB OC
    I know Crysis 2 runs better with it off, and BFBC2 with it on.
     
  9. bart5986

    bart5986 Member Guru

    Messages:
    109
    Likes Received:
    0
    GPU:
    Gigabyte 290x OC
    You probably just don't know what your doing.


    The only game I have that doesn't use crossfire is NFS hot pursuit, something that was fixed to automatically disable it in the recent CAP update.


    Crysis 2 has full crossfire support.
     
  10. EN[joi]DK

    EN[joi]DK Active Member

    Messages:
    57
    Likes Received:
    0
    GPU:
    msi 1060 6GB
    this "fix" doesnt do anything at all period! waste of time
     

  11. DarkKnightDude

    DarkKnightDude Maha Guru

    Messages:
    1,089
    Likes Received:
    0
    GPU:
    MSI GTX770 4 GB OC
    I was talking about single card lul.
     
  12. blesner

    blesner Ancient Guru

    Messages:
    2,699
    Likes Received:
    0
    GPU:
    MSI Nvidia GTX 690
  13. perosmct

    perosmct Banned

    Messages:
    1,072
    Likes Received:
    0
    GPU:
    unknown
    your brain does need to get fixed noob...waste of time is posting BS like this...

    it's a nice fix for crossfirex users, when a game doesnt have nice support for mgpu...especially 5970 and 6990 users...and they cant disable crossfire...

    and for single card users, when you disable catalyst AI, you have the best IQ...
     
  14. blesner

    blesner Ancient Guru

    Messages:
    2,699
    Likes Received:
    0
    GPU:
    MSI Nvidia GTX 690
    Why not just disable xfire with RPRO ?
     
  15. perosmct

    perosmct Banned

    Messages:
    1,072
    Likes Received:
    0
    GPU:
    unknown
    yeah that's the easy way, but in case when somebody dont have RP installed...and with new catalyst he cant find disable option...it's a hard solution... :)

    anyway, single card users, should not use catalyst AI at all...it steals image quality...by far...a bad cheating...i remember when i was on single gpu...i won 10 fps on crysis only by catalyst AI...lol
     

  16. Mineria

    Mineria Ancient Guru

    Messages:
    4,165
    Likes Received:
    107
    GPU:
    Asus RTX 2080 Super
    Setting the slider to High Quality does exact the same thing with the xml, at least with 8.841
    So I guess you got an OS protection option/application on the system, which doesn't allow CCC to change the xml settings.
     
    Last edited: Apr 23, 2011
  17. mbd2884

    mbd2884 Banned

    Messages:
    317
    Likes Received:
    0
    GPU:
    Mobility HD5870
    My understanding is that it doesn't disable CrossFireX, but it disables visual optimizations on High Quality. CFX is still available. The only way to disable CF may be this method and to use RP.
     
  18. Captainrave

    Captainrave New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    295X2
    This solution fixed my crashing problem in Sims 3 and Dead Space. I wish there was an easier way to do it - RadeonPro only sometimes seems to disable CatalystAI sometimes for me :(
     
    Last edited: May 6, 2011
  19. z7x

    z7x Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    HD7990 6GB
    This also enabled me to play games in stereoscopic 3D mode on my 3DTV. Only 720p60Hz or 1080p24Hz...
    Unfortunately, due to disabled crossfire, games like crysis can't manage solid 60fps at 720p60 3D (720p 60fps times two).

    HD3D checker exe from TriDef site says that my hardware (HD6990) is not supported with HD3D (probably because crossfire is enabled by default in HD6990 drivers).

    Shame... but apparently AMD and TriDef are working on this :>
     
    Last edited: Sep 4, 2011
  20. ziddy123

    ziddy123 Banned

    Messages:
    53
    Likes Received:
    0
    GPU:
    5770
    Was thinking the same.

    Really? Cross-Fire disables your HD3D? Have you confirmed this with other 3D gaming fans with CFX? Just pretty funny reading this.
     

Share This Page